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FIM-TROUBLESHOOTING: ORACLE MA: Full Import Error “Completed No Objects”

 

OVERVIEW / PURPOSE

Recently worked an issue, where we had data in an Oracle 11g table.  However, when executing a Full Import (Stage Only), the Oracle Management Agent would display the status as “Completed No Objects”.  We would not see any errors, just no objects would be imported.

The Oracle Management Agent will reach out to the database server and execute a query to pull the data back.  It pulls the data into a text file in the %programfiles%\Microsoft Forefront Identity Manager\2010\Synchronization Service\MADATA\{ MANAGEMENT AGENT NAME }} folder.  The import process then pulls the data from the text file into the Oracle Management Agent connector space.

Troubleshooting this issue, we confirmed the environment, reviewed the Application and System Event Logs, and requested the text file. 

ENVIRONMENT

  • Forefront Identity Manager 2010 Update 2 ( Build 4.0.3606.2 )

  • Oracle Management Agent

  • Oracle Client: 11.2.0.1.0 (64-Bit)

    ****NOTE: The Oracle 11g Client needs to be 64-Bit.  You can find additional information on Microsoft TechNet here.

    ***

  • Oracle Database Server: 11g

 

APPLICATION EVENT LOG – ERROR – EVENT ID 6013

In review of the Application Event Log, we found several errors with the Event ID 6013.   The text of this message indicated there is no data objects to be imported.  The next step here is to review the text file that the Oracle Management Agent is referencing for the data.

The management agent ‘My Oracle Management Agent’ failed on run profile ' My Oracle Full Import' because the management agent did not import any objects during the run step.  The input file name is 'D:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\MaData\My Oracle Management Agent\My Oracle Full Import.txt'.

 

MY ORACLE FULL IMPORT.TXT

We found the text file, and opened it up to review the data.  In this case, there is no data in the text file.

<?xml version="1.0" encoding="UTF-16"?> <mmsml xmlns="http://www.microsoft.com/mms/mmsml/v2" step-type="full-import">   <directory-entries>   </directory-entries> </mmsml>

 

CAUSE

At this point, we were able to isolate the issue to a problem with the Oracle Database Table.  We reviewed the Oracle Database Table and found that it contained data, but that the data had not been committed. 

 

RESOLUTION

Have your Oracle DBA Commit the data in the Oracle Database Table.  Once you commit the data, then you will be able to execute the Full Import (Stage Only)

ADDITIONAL INFORMATION

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