Windows Server: Troubleshooting CAU: Cluster Connectivity Problems
This topic provides recommended steps to troubleshoot cluster connectivity problems that might occur when you try to update a Windows Server 2012 failover cluster by using the Cluster-Aware Updating (CAU) feature.
Symptom
Using the CAU tools, you attempt to connect to a failover cluster to apply updates or perform a related action. A connection cannot be made to the cluster. You might see an error message similar to:
Check the spelling of the cluster name. Otherwise, there might be a problem with your network. Make sure the cluster nodes are turned on and connected to the network or contact your network administrator.
Cause
To help identify the cause of the problem and possible resolution steps, check the following:
- Using Failover Cluster Manager or the Get-ClusterResource Windows PowerShell cmdlet, verify that the failover cluster status is Online and that the cluster is providing clustered roles.
- If you are using CAU in remote-updating mode, check network connectivity and name resolution functionality between the Update Coordinator computer and the cluster nodes. For example, you can run the ping and nslookup commands. Verify also that the Update Coordinator and the failover cluster are in the same Active Directory domain.
- Check the System event log on the Update Coordinator and on the cluster nodes to determine if there are errors related to network functionality.
- Review the requirements for cluster node configuration and the requirements for remote management in Requirements and Best Practices for CAU. Make any necessary changes. Although many of the requirements are met during default installations of Windows Server 2012, it is possible you will need to manually enable certain features in your environment. For example, to support WinRM remoting on cluster nodes, ensure that the Windows Remote Management service is started and the startup type is set to Automatic. Verify also that the inbound firewall rule for Windows Remote Management (HTTP-In) is enabled.
- If you are providing explicit domain credentials to perform a CAU action, ensure the user account is a local administrator on each node in the failover cluster.
Resolution
If the problem appears to be related to network connectivity, follow general network troubleshooting guidance.
If there is a cluster name resolution problem, check and if necessary correct the DNS configuration.
If you need to enable WinRM remoting on a cluster node, you can run the following command with elevated privileges:
winrm quickconfig -q
If you need to configure an administrator account to use CAU, see “Obtain an administrator account” in Requirements and Best Practices for CAU.
Add others as appropriate
See Also
- Requirements and Best Practices for Cluster-Aware Updating
- Troubleshoot Cluster-Aware Updating (CAU) in Windows Server 2012 Failover Clusters