Share via


Windows Server: Troubleshoot CAU: Remote-Updating Problems

This topic provides information to troubleshoot problems that might occur when you try to update a Windows Server 2012 failover cluster by using the Cluster-Aware Updating (CAU) feature from a remote Update Coordinator computer.

For more information about CAU and the two updating modes that are available, see Cluster-Aware Updating overview in the Windows Server Library.

Symptom

From a remote computer where you have installed the Windows Server 2012 Failover Clustering tools, you are able connect to a failover cluster by using the Failover Clustering tools or the Cluster-Aware Updating tools. However, you are unable to apply updates using CAU. In the CAU UI, you might see error messages in the Log of Updates in Progress tab, or in an Updating Run report. If you are using the CAU Windows PowerShell cmdlets to apply updates, you might see error messages in the cmdlet output.

Cause

An error message in the CAU UI or in the output of a Windows PowerShell cmdlet might indicate a possible cause and suggested resolution steps. To gather more information, do one or more of the following:

  • Generate a detailed report on the last Updating Run. To do this, run the Get-CauReport Windows PowerShell cmdlet with the –Detailed parameter. For example:

    $result=Get-CauReport -ClusterName <ClusterName> -Detailed -Last
    $result.ClusterResult
    
  • Try running the CAU Best Practices Analyzer model to test your environment for cluster-updating readiness. For more information, see Test cluster updating readiness.

  • On the Update Coordinator computer, review the ClusterAwareUpdating-Management-Admin event log for error messages.

  • Review the configuration of each cluster node to ensure that it meets the requirements for remote management using CAU and other CAU requirements. Make any necessary changes. Many of the requirements are met during a default installation of Windows Server 2012. However, it is possible you will need to manually enable certain features in your environment. For example:

    • Ensure the Windows Remote Management service is started and the startup type is set to Automatic. Verify also that the inbound firewall rule for Windows Remote Management (HTTP-In) is enabled. This will support remote management by using WinRM remoting. If your nodes are configured with a non-Microsoft firewall, ensure that an equivalent firewall rule is configured.
    • If the Updating Run is configured to run a pre-update or post-update Windows PowerShell script, make sure that the Windows PowerShell 3.0 and .NET 4.0 packages are installed on each cluster node. In addition, you need to enable Windows PowerShell remoting, if it is not already enabled.
    • Confirm that all cluster nodes can access a pre-update or post-update Windows PowerShell script or a WSUS server, if one is in use.
  • If you were using the CAU UI to apply updates, try to apply updates on a node using an equivalent CAU Windows PowerShell cmdlet such as Invoke-CauRun.

Resolution

If the problem appears to be caused by a misconfiguration of WinRM remoting or Windows PowerShell remoting, you can run the Enable-PSRemoting cmdlet to enable both WinRM remoting and Windows PowerShell remoting in a single step.

*Add other resolution steps as appropriate

*


See Also