OVERVIEW / PURPOSE / GOAL |
The purpose of this wiki is to share knowledge of an issue that I recently worked concerning a stopped-server error message with a SQL Server Management Agent.
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PROBLEM STATEMENT |
The SQL Server Management Agent was running fine, and then in
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APPLICATION EVENT LOG |
Log Name: Application
Source: Application Error
Date: 7/24/2012 8:22:10 PM
Event ID: 1000
Task Category: Application Crashing Events
Level: Error
Keywords: Classic
User: N/A
Computer: <COMPUTER NAME>
Description:
Faulting application name: miiserver.exe, version: 4.0.2592.0, time stamp: 0x4b6790ea
Faulting module name: MSVCR90.dll, version: 9.0.30729.4940, time stamp: 0x4ca2e32e
Exception code: 0xc0000005
Fault offset: 0x000000000001e654
Faulting process id: 0x%9
Faulting application start time: 0x%10
Faulting application path: %11
Faulting module path: %12
Report Id: %13 |
EXPORT OF RUN HISTORY |
<run-history>
<run-details>
<ma-id>{GUID}</ma-id>
<ma-name>SQL Server Management Agent</ma-name>
<run-number>1997</run-number>
<run-profile-name>Full Import</run-profile-name>
<security-id>DOMAIN1\sqlmaacct</security-id>
<step-details step-number="1" step-id="{D2A88A69-A662-496D-976B-666A1792E960}">
<start-date>2012-07-25 00:22:10.437</start-date>
<end-date>2012-07-25 00:22:19.127</end-date>
<step-result>stopped-server</step-result>
<step-description>
</step-description>
<current-export-step-counter>0</current-export-step-counter>
<last-successful-export-step-counter>0</last-successful-export-step-counter>
<ma-connection>
</ma-connection>
<ma-discovery-errors>
</ma-discovery-errors>
<ma-discovery-counters>
</ma-discovery-counters>
<synchronization-errors/>
<mv-retry-errors/>
<staging-counters>
<stage-no-change detail="false">0</stage-no-change>
<stage-add detail="true">0</stage-add>
<stage-update detail="true">0</stage-update>
<stage-rename detail="true">0</stage-rename>
<stage-delete detail="true">0</stage-delete>
<stage-delete-add detail="true">0</stage-delete-add>
<stage-failure detail="true">0</stage-failure>
</staging-counters>
<inbound-flow-counters>
<disconnector-filtered detail="true">0</disconnector-filtered>
<disconnector-joined-no-flow detail="true">0</disconnector-joined-no-flow>
<disconnector-joined-flow detail="true">0</disconnector-joined-flow>
<disconnector-joined-remove-mv detail="true">0</disconnector-joined-remove-mv>
<disconnector-projected-no-flow detail="true">0</disconnector-projected-no-flow>
<disconnector-projected-flow detail="true">0</disconnector-projected-flow>
<disconnector-projected-remove-mv detail="true">0</disconnector-projected-remove-mv>
<disconnector-remains detail="false">0</disconnector-remains>
<connector-filtered-remove-mv detail="true">0</connector-filtered-remove-mv>
<connector-filtered-leave-mv detail="true">0</connector-filtered-leave-mv>
<connector-flow detail="true">0</connector-flow>
<connector-flow-remove-mv detail="true">0</connector-flow-remove-mv>
<connector-no-flow detail="true">0</connector-no-flow>
<connector-delete-remove-mv detail="true">0</connector-delete-remove-mv>
<connector-delete-leave-mv detail="true">0</connector-delete-leave-mv>
<connector-delete-add-processed detail="true">0</connector-delete-add-processed>
<flow-failure detail="true">0</flow-failure>
</inbound-flow-counters>
<export-counters>
<export-add detail="true">0</export-add>
<export-update detail="true">0</export-update>
<export-rename detail="true">0</export-rename>
<export-delete detail="true">0</export-delete>
<export-delete-add detail="true">0</export-delete-add>
<export-failure detail="true">0</export-failure>
</export-counters>
</step-details>
</run-details>
</run-history>
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CAUSE |
In this particular case, the problem was data corruption in the SQL Server Management Agent Connector Space.
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RESOLUTION |
To resolve this issue, you will need to delete the SQL Server Management Agent Connector Space. You may be an advanced user of FIM, and maybe familiar with this scenario. However, it is recommended to review the following Microsoft TechNet Wiki before actually deleting the connector space.
Things to think about before deleting a connector space
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OTHER POSSIBLE RESOLUTIONS |
- Run the Management Agent in a separate process
- Run a Full Import (Stage Only) followed by a Full Synchronization on the Management Agent
- Re-Index all tables in the backend SQL Server - FimSynchronizationService database
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POSSIBLE TROUBLESHOOTING STEPS |
- If the failure is occurring on an import, then execute the import to a drop file. If that completes without error, then it is possible that the problem is within the Connector Space.
- If the failure is happening during a synchronization, you might utilize a SQL Server Profiler Trace and/or a Network Monitor trace to ensure that the Synchronization Service Engine is connecting to the backend SQL Server.
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FIM Landing Page: Resource Wiki Contents |