Share via


FIM Sync Troubleshooting: Event ID 6801 - The Exchange server address list service failed to respond

Problem Statement

In this issue, we were exporting a new user object to Active Directory using an Active Directory Management Agent.  We were provisioning to Microsoft Exchange 2007.  During this export process, we started receiving several Event ID 6801 errors in the Application Event Log.  The error will contain information like stated below in the error message.  In receiving the error message, we would see the Active Directory User Object get created with some of the Microsoft Exchange Attributes populated.  However, the Microsoft Exchange Mailbox is not created.

This is an indication that there is a problem with the Update-Recipient Exchange PowerShell CMDLET.

Error message

Cannot update recipient 'CN=<Distinguished Name of the User Object>.' Error: The Exchange server address list service failed to respond. This could be because of an address list or email address policy configuration error.

Cause

Problem with the Microsoft Exchange System Attendant

Resolution

Restart the Microsoft Exchange System Attendant