Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
For one of my Premier 'FAST search for SharePoint 2010' customers, 'get-FASTSearchSettingGroup' command was throwing an error.
Here are details of the issue and it’s resolution:
Symptom
When running PowerShell command : "Get-FASTSearchSettingGroup" in order to update a bestbets file, getting an error: "Failed to communicate with the WCF service."
Cause
FAST administration app pool account's password was changed so it had to be updated manually in the App pool identity.
Resolution
· We went to IIS manager and found that the Fast Administration app pool was stopped.
· We manually started it.
· Then went to FAST PowerShell again and ran the command get-FASTSearchSettingGroup which returned the same error.
· Checked that the FAST administration site App pool got stopped again.
· We suspected that the app pool identity was not updated when the password might have been changed for the account.
· Went to app pool and updated App pool credentials with new password.
· Then ran the same PowerShell command and it worked this time.
I Hope that helps! Happy searching !!
Comments
- Anonymous
July 06, 2017
I have a few points to make:1. get-FASTSearchSettingGroup should be get-FASTSearchSearchSettingGroup and2 If the FastSearch Search settings group is missing it is automatically created by launching the page /_layouts/contextualkeywordmanagement.aspx 3. Ensure the SPAppPool account and fast admin are members of the FAST server local group FASTSearchKeywordAdministrators, if this group is missing then create it.- Anonymous
April 05, 2018
Great points Paul, Thank you !!
- Anonymous