Share via


Outlook crashes with CRM Outlook Client Add-In

Hello everyone,

Today, I am talking about a scenario where outlook crashes with CRM outlook client with the following error in the event logs:

Error:

   Application Error

   Faulting application name: Microsoft.Crm.Application.Outlook.ConfigWizard.exe, version: 5.0.9690.2243, time stamp: 0x4f991e69

   Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319

   Exception code: 0xe0434352

   Fault offset: 0x0000b9bc

   Faulting process id: 0x2d14

   Faulting application start time: 0x01cd76898e0c651a

   Faulting application path: C:\Program Files (x86)\Microsoft Dynamics CRM\Client\ConfigWizard\Microsoft.Crm.Application.Outlook.ConfigWizard.exe

   Faulting module path: C:\Windows\syswow64\KERNELBASE.dll

   Report Id: ce5e5ffe-e27c-11e1-8ad8-88532e978910

Cause:

Initially there was Office 64 bit installed with CRM Outlook Client 64 bit. Later Office 64 and CRM Outlook Client 64 bit was replaced with the Office 32 bit and CRM 32 bit.

Though CRM was switched over to 32 bit, the registry at HKEY_CURRENT_USER | Software | Microsoft | MSCRMClient | InstallPath was pointing to C:\Program Files\Microsoft Dynamics CRM 2011.

However, after the 32 bit install of CRM Outlook Client, we have the CRM physical components and files located at C:\Program Files (x86)\Microsoft Dynamics CRM 2011.

And, this issue was because of the above mentioned conflicts, registry and the actual Install path. When you launch Outlook client, it is looking for registry, picking the path of C:\Program Files and trying to load the add-in. However, the add-in is not present in this location, rather it is present at C:\Program Files(x86).

Resolution:

  • Back up the registry and uninstall CRM client for Outlook.
  • Download CRM 2011 client from - https://www.microsoft.com/en-us/download/details.aspx?id=27821
  • Uninstall CRM client from Add/Remove Programs.
  • Clean up the registry at HKEY_CURRENT_USER | Software | Microsoft | MSCRMClient & HKEY_LOCAL_MACHINE | Software | Microsoft | MSCRMClient. You can also follow manual uninstall of CRM Outlook client steps to clean the system.
  • Install fresh copy of CRM client for outlook. Configure the Outlook client.

Additional Information:

You may also notice, 2.4 folder under - HKEY_CLASSES_ROOT\TypeLib\{2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}. This key is not required if we have CRM 2011 client. This behavior may occur because of registry keys that are left over from an earlier version of Microsoft Outlook.

 

Regards,

Ritesh Ranjan – Microsoft Dynamics CRM Premier Field Engineer (EMEA – Norway)

Comments

  • Anonymous
    January 16, 2014
    Great blog post.  Encountered this exact issue and the resolution steps worked a treat!  Thanks

  • Anonymous
    November 19, 2014
    Worked great, thanks!!

  • Anonymous
    November 19, 2014
    appreciate your feedback James and Bravos

  • Anonymous
    December 15, 2015
    I've had this issue recently as well on Office/outlook 2010 32 bit + CRM 2015 + Windows 7 64 bit. Some were 32 bit replacements for 64 bit Office, however there have also been some straight 32 bit installs which has the issue. Uninstalling and reinstalling as per the instrucitons above and this page (for a full uninstall) have fixed the issue :blogs.msdn.com/.../manually-uninstall-amp-install-dynamics-crm-2013-for-outlook.aspx I just uninstalled the client, and removed the folders and reg entries.

  • Anonymous
    February 10, 2016
    I have the same issue but with Skype Add in. If Skype Add in is activated in MS Outlook 2013, Outlook freezes constantly and i can only close the program and it will then freeze again if i try starting Outlook again. If i manage to disable the Skype Add in, Outlook is all ok again. Is there any solution for this? I have tried Repairing Outlook.

  • Anonymous
    July 12, 2016
    Great blog post Ritesh. I really appreciate your work. You have Worked great, thanks a lot for this beneficial post.

    • Anonymous
      September 22, 2016
      Thank you Evelloaus, appreciate your feedback.