Business Contact Manager 2007 Database: Unable to connect to the Database
When user tries connecting to a local database (hosted on Terminal server) for a user created instance , they encountered the following errors
"The database <DATABASENAME> is no longer shared. Only the database owner may connect to the database .Check with the database owner to get permission to connect to this server ." or
This action cannot be completed because Business Contact Manager cannot access the database.Cannot open the database "<DATABASENAME>" requested by the login.The login failed.The Login failed for user '<Domain\Username>'. or
Database <DATABASENAME> is not online.
Cause
The issue happen because the client (by default) would only look for the MSSMLBIZ instance and not the user created instance.
Resolution
We were able to resolve the issue by navigating to the following registry keys
HKLM > Software > Wow 6432 Node> Microsoft > Business Solution eCRM (for a 64 bit OS)
and changing the value of SQL Instance name from “MSSLMBIZ” (the default) to the user created instance.
Note : For a (32 bit OS) , it would be under HKLM > Software > Microsoft > Business Solution eCRM
More Information
User will still be able to connect to the database created under the MSSMLBIZ instance (default) without any issue .
Thanks & Regards
Rahul Thomas