Support-Tip: (SYNC): Unable to connect to the Synchronization Service" error when you attempt to open the MIISCLIENT.EXE
APPLIES TO
- Forefront Identity Manager 2010 Synchronization Server / R2 / R2 SP1
- Microsoft Identity Manager 2016 / 2016 SP1
- Azure AD Connect Sync
PROBLEM SCENARIO DESCRIPTION
You attempt to launch the Synchronization Service Manager Console either by clicking on the icon on the Start Menu or by attempting to launch the MIISCLIENT.EXE and you receive the following dialog
CAUSE
There are a few causes to this some of which are documented on the dialog itself
- The logged on user is not part of the correct Synchronization Service Group
NOTE | Here is more information on the Security Groups:
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- The Forefront Identity Manager Synchronization Service is not started.
NOTE | Here are the names of the service based on the product.
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RESOLUTION
Ensure the Synchronization Service is started |
In Administrative Tools double click on Services Locate the Sync Service to the Product that you are working with here Ensure that the Sync Service is Started |
Add logged on account to the proper security group based on the logged on user needs to do | ||
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Verify the connectivity to the backend database |
One way you can do this is through a UDL file. Here is how to create a UDL File to test SQL Connectivity:How to create a UDL file to test the connection to SQL Server
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ADDITONAL RESOURCES / INFORMATION
- Support-Info: (AADCONNECT): Azure AD Connect Sync Security Groups: https://blogs.technet.microsoft.com/iamsupport/2017/03/21/support-info-azure-ad-connect-sync-security-groups/
- Forefront Identity Manager Security Groups: https://technet.microsoft.com/en-us/library/jj590183(v=ws.10).aspx
- User Profile Synchronization Configuration Service cannot connect to SQL Server - Event 4 (SharePoint 2010): https://technet.microsoft.com/en-us/library/ff519520(v=office.14).aspx
- "Unable to connect to the Synchronization Service" error when you try to open MIISCLIENT.EXE in the Azure Active Directory Sync installation folder: https://support.microsoft.com/en-us/help/2791422/-unable-to-connect-to-the-synchronization-service-error-when-you-try-to-open-miisclient.exe-in-the-azure-active-directory-sync-installation-folder
DOCUMENTATION
- Synchronization Service Manager (FIM2010R2): https://technet.microsoft.com/en-us/library/jj590321(v=ws.10).aspx
- Install MIM 2016: MIM Synchronization Service: /en-us/microsoft-identity-manager/install-mim-sync