Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
今回は Exchange 2013 環境で Microsoft Exchange Health Manager サービスに関する一部の内部診断ログが意図せずに D ドライブに出力されてしまう不具合についてご紹介いたします。
Exchange 2016 RTM でも同様の問題が発生しますが、Exchange 2016 CU1 以降では本不具合は修正されています。
現象
Exchange 2013 がインストールされているサーバー上に D ドライブが存在する場合、以下のパスにフォルダーが作成されて Microsoft Exchange Health Manager サービスに関する内部診断ログが出力されます。
D:\MonitoringDiagnosticLogs\MSExchangeHMHost
また、D ドライブが存在しない場合には Microsoft Exchange Health Manager サービスの起動時に以下のエラーがアプリケーション ログに記録されます。
原因
本現象は Microsoft Exchange Health Manager サービスに関する一部の内部診断ログの出力先が D ドライブにハードコードされていることが原因となります。
Exchange 2013 に関しては残念ながら現時点で修正が見送られておりますが、Exchange 2016 CU1 以降では以下のパスに出力されるように修正されています。
%ExchangeInstallPath%\Logging\Monitoring\Monitoring\MonitoringDiagnosticLogs\MSExchangeHMHost
補足
MonitoringDiagnosticLogs フォルダーの出力先に関しては Exchange Server でハードコードされていますので、設定などで変更する方法は残念ながらございません。
なお、D ドライブが存在しない場合にはサービス起動時に MSExchange Common のイベント ID 6003 のエラーが記録されますが、一部の内部診断ログが出力されないだけで Exchange Server の動作に影響を及ぼすものではございませんので、エラーは無視していただけますようお願いいたします。
※本情報の内容(添付文書、リンク先などを含む)は、作成日時点でのものであり、予告なく変更される場合があります。