Windows Server 2016 上にインストールした Exchange 2016 でバックアップのリストアが成功しない
現象
Windows Server 2016 上にインストールした Exchange 2016 環境において、Windows Server Backup で取得したバックアップから以下の条件でリストアを行うと、エラーが発生します。
[回復の種類の選択] ページで、[アプリケーション] を選択
[回復オプションの指定] ページで、[元の場所に回復する] を選択
リストアを行うとエラーが発生
発生条件
1. Windows Server 2016 + Exchange Server 2016 にてシステムを構築している
2. Windows Server バックアップにて回復(リストア)を行うにあたり、以下を選択している。
- 回復の種類に [アプリケーション] を選択している。
- 回復オプションの指定に [元の場所に回復する] を選択している。
原因
弊社製品の不具合による Windows Server 2016 と Exchange Server 2016との互換性の問題になります。Windows Server バックアップと Exchange Server 2016 との間で行われる RPC 通信において、お互いに利用するインターフェースのバージョン形式が異なっているために発生します。
Windows Serverバックアップは Exchange Server のデータをリストアする際、データを戻す順番を確認するため、RPC 通信にて Exchange Server とやり取りを行います。このとき、お互いに通信で利用するインターフェースのバージョン形式を指定して通信を行いますが、それらのバージョン形式が異なるため、Windows Serverバックアップが受け取るデータの書式が期待したデータ形式にならないためにエラーとなり、本事象が発生いたします。Windows Server 2016のWindows Server バックアップと Exchange Server 2016 にて利用しているインターフェースのバージョン形式は以下の通りです。
Windows Server バックアップ : NT61
Exchange Server : NT50
各形式の詳細については以下をご参照ください。
/target switch
/ja-jp/windows/desktop/Midl/-target
回避策
Exchange の設定変更や CU 適用など、Exchange 2016 による回避策はありません。
本対策
本事象に対する修正を含んだ Windows Server 2016 のロールアップ適用が対策となります。
修正は Windows Server バックアップのモジュールに対して行っております。現在、OS の修正はロールアップの形式でのみ提供を行っておりますので、本修正を含んだロールアップの適用を行っていただく必要がございます。
この問題の修正を含んだロールアップが 9 月 21 日に公開されておりますので、以下のロールアップを適用いただき、事象が改善されることをご確認いただければと思います。
文書番号 : 4457127
September 20, 2018—KB4457127 (OS Build 14393.2517)
https://support.microsoft.com/ja-jp/help/4457127/windows-10-update-kb4457127
その他
[回復オプションの指定] ページで、[別の場所に回復する] を選択すれば、リストアが可能です。
Windows Server 2012 R2 上にインストールした Exchange 2016 では [元の場所に回復する] でもリストアは可能です。
情報のアップデートや修正が確定いたしましたら本 Blog でも情報を更新いたします。
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