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Support Tip: The App-V Client service fails to start and logs Event ID 7024

~ Keshav Deo Jain 

ToolsHi everyone, my name is Keshav and I’m an App-V support engineer here at Microsoft. I recently came across an interest issue where the App-V Client service would fail to start so I thought I would share the resolution with you here in case you happen to run across it. 

When you encounter this issue you’ll notice that the Microsoft App-V Client service is failing to start and generates the following error:

Windows could not start the Microsoft App-V Client on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 3.

image

You’ll also see an event similar to the following:

Log Name: System
Source: Service Control Manager
Event ID: 7024
Level: Error
User: N/A
Description: The Microsoft App-V Client service terminated with service-specific error The system cannot find the path specified..

Event Xml:
<Event xmlns="https://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
<EventID Qualifiers="49152">7024</EventID>

 

CAUSE

Generally we see these errors when App-V packages are manually deleted from the App-V cache (C:\Programdata\App-v). To demonstrate this, I reproduced this in my environment by deleting packages from the App-V cache and then taking a Process Monitor trace of “APP-V Client Service”. As seen below, we get ‘PATH NOT FOUND’ instances for the missing packages.

image

Note that the App-V cache is not the only locations where information about packages is stored; it is also stored in the registry at this location:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\Packages

Here’s what they looked like on my computer:

image

Although I deleted the packages from the App-V cache, the information in the registry hive still exists, thus Appvclient.exe is trying to write data to the cache and getting the error ‘PATH NOT FOUND’.

 

RESOLUTION

If for whatever reason you manually deleted packages from the App-V cache, you need to be sure to remove the information regarding the same App-V packages from the registry hive at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\Packages

Keep in mind that Microsoft does not normally recommend that you delete anything from the App-V cache, however if you find yourself in a situation where you need to do this, we have steps on how to do it in the KB article below.

KB2768945 - How to remove a cached copy of an unpublished package in Microsoft App-V v5 (https://support.microsoft.com/kb/2768945)

NOTE: THESE STEPS SHOULD ONLY BE IMPLEMENTED IN THE SCENARIO WHERE PACAKGES ARE DELETED FROM THE APP-V CACHE. IT IS HIGHLY RECOMMENDED TO VERIFY WHETHER PACAKAGES ARE DELETED FROM THE APP-V CACHE BEFORE PERFORMING THE ACTION PLAN ABOVE.

Keshav Deo Jain | Support Engineer | Microsoft GBS Management and Security Division

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Comments

  • Anonymous
    January 16, 2015
    Thanks this post really helped me resolve the issue happening on my laptop. I had tried repairing and uninstall and re-install of App-V client SP3 with no resolutions. This article saved me :)
  • Anonymous
    May 21, 2015
    Amazing! Thank you. After comparing the local cache and the registry, I was able to start the service.
  • Anonymous
    October 31, 2015
    This worked great !
    Thank you so much !