I am a delegate who can't delete calendar entries I've created in their Outlook

Shiralee Slattery 1 Reputation point
2022-07-18T23:34:59.297+00:00

I create calendar entries in my boss' Outlook and when I try to delete them I get the following error message. I've checked the permissions and I have editor status. "Could not complete the deletion. The items may have been already deleted or moved." A little annoying as I like to create calendar entries as HOLD if I've promised a particular time to someone and am waiting for their confirmation.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,606 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Joyce Shen - MSFT 16,661 Reputation points
    2022-07-19T07:42:21.477+00:00

    Hi @Shiralee Slattery

    Could you please tell what permission is assigned to you? We could refer to the introduction here, make sure the permission you owned contain the DeleteOwnedItems operation:

    Get-MailboxFolderPermission -Identity yourboss@domain.com:\Calendar -User yourname@domain.com  
    

    222118-image.png

    As workarounds, you could firstly try using OWA to delete the items.
    Or you may check the discussion here in this similar thread: Deleting calendar items

    PROBLEM
    In Microsoft Office 365, a delegate is granted permissions to a calendar in Microsoft Outlook. When the delegate tries to delete an calendar item, the following error message is displayed:
    The item could not be deleted, it was either moved or already deleted, or access was denied.

    CAUSE
    When an calendar item is deleted, Outlook 2016 attempts to move it to the Deleted Items folder of the original mailbox.
    If the delegate does not have permissions on the Deleted Items folder, the operation will fail.

    SOLUTION
    Assign the delegate with at least Author permissions on the Deleted Items folder in Outlook.

    FURTHER INFORMATION
    In earlier versions of Outlook this was not an issue as deleted items were moved to the delegate mailbox.
    This behavior is controlled via the DelegateWasteBasketStyle registry key which can be found under:
    Computer\HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\options\general\DelegateWasteBasketStyle
    This key can have values of:
    4 – move deleted items to the Deleted Items folder in the original mailbox.
    8 – move deleted items to the Deleted Items folder in the delegate mailbox.
    Outlook 2016 sets this key value to 4 by default. "


    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    2 people found this answer helpful.

Your answer

Answers can be marked as Accepted Answers by the question author, which helps users to know the answer solved the author's problem.