Could you please tell what permission is assigned to you? We could refer to the introduction here, make sure the permission you owned contain the DeleteOwnedItems operation:
Get-MailboxFolderPermission -Identity yourboss@domain.com:\Calendar -User yourname@domain.com
As workarounds, you could firstly try using OWA to delete the items.
Or you may check the discussion here in this similar thread: Deleting calendar items
PROBLEM
In Microsoft Office 365, a delegate is granted permissions to a calendar in Microsoft Outlook. When the delegate tries to delete an calendar item, the following error message is displayed:
The item could not be deleted, it was either moved or already deleted, or access was denied.
CAUSE
When an calendar item is deleted, Outlook 2016 attempts to move it to the Deleted Items folder of the original mailbox.
If the delegate does not have permissions on the Deleted Items folder, the operation will fail.
SOLUTION
Assign the delegate with at least Author permissions on the Deleted Items folder in Outlook.
FURTHER INFORMATION
In earlier versions of Outlook this was not an issue as deleted items were moved to the delegate mailbox.
This behavior is controlled via the DelegateWasteBasketStyle registry key which can be found under:
Computer\HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\options\general\DelegateWasteBasketStyle
This key can have values of:
4 – move deleted items to the Deleted Items folder in the original mailbox.
8 – move deleted items to the Deleted Items folder in the delegate mailbox.
Outlook 2016 sets this key value to 4 by default. "
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