Hello @Udi Ben Hamo,
Thank you for posting your query on Microsoft Q&A.
Please note that based on the error message what you are getting when you are trying to access the application, AADSTS50105: Your administrator has configured the application Google Cloud ('839b71ae-0c22-485e-935e-ee093171a97c') to block users unless they are specifically granted ('assigned') access to the application. The signed in user '******@upstream.auto' is blocked because they are not a direct member of a group with access, nor had access directly assigned by an administrator. Please contact your administrator to assign access to this application.
I would like to share the following details about this Error code: AADSTS50105 below.
Symptoms
You receive the following error message when you try to sign in to an application that has been set up to use Microsoft Entra ID for identity management using SAML-based Single Sign-On (SSO):
Error AADSTS50105 - The signed in user is not assigned to a role for the application.
Cause
The user hasn't been granted access to the application in Microsoft Entra ID. The user must belong to a group that is assigned to the application, or be assigned directly.
Note:
Nested groups are not supported, and the group must be directly assigned to the application.
Resolution
To assign one or more users to an application directly, please refer to the steps mentioned in the document below.
Quickstart: Assign users to an app.
For more details about this error code AADSTS50105, please refer to the below document for your reference.
I hope this above information provided is helpful. Please feel free to reach out if you have any further questions.
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Thanks and Regards,
Sanoop Mohan