How to Relax or Remove the “LocalRequestPartnerRateLimit” Rule in Azure Front Door?

西村和海 25 Reputation points
2025-01-05T05:01:36.7833333+00:00

We are hosting a web app on Azure App Service, with traffic routed through Azure Front Door. Most of the time, everything works smoothly. However, we occasionally get a 429 Too Many Requests error, and upon investigation, it appears that a rule named “LocalRequestPartnerRateLimit” in Azure Front Door is causing the block. We want to relax or remove this limitation because it sometimes blocks our normal usage.

Our Front Door WAF policy is currently set to Detection mode, so it should log but not block. We have not set up any custom WAF rules, and we cannot find any configuration related to the “LocalRequestPartnerRateLimit” rule to adjust or disable it. Does anyone know how to loosen or remove this block caused by the LocalRequestPartnerRateLimit rule? Any help would be greatly appreciated.fig1

fig2

fig3

fig4

Azure Front Door
Azure Front Door
An Azure service that provides a cloud content delivery network with threat protection.
724 questions
Azure Web Application Firewall
Azure Startups
Azure Startups
Azure: A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.Startups: Companies that are in their initial stages of business and typically developing a business model and seeking financing.
508 questions
{count} vote

Accepted answer
  1. Rohith Vinnakota 1,780 Reputation points Microsoft Vendor
    2025-01-06T02:41:32.28+00:00

    Hi @西村和海

    Welcome to the Microsoft Q&A Platform! Thank you for asking your question here.

    Cause

    • Azure Front Door has default platform rate limits. If your traffic exceeds the limit, AFD will start rate limiting the traffic and return 429 responses.

    Troubleshooting steps

    • If you start seeing 429s for your legitimate traffic and a higher quota limited is need, create an Azure support request.

    Refer this link: https://learn.microsoft.com/en-us/azure/frontdoor/troubleshoot-issues#429-responses-from-azure-front-door


    If above is unclear and/or you are unsure about something add a comment below.

    Please don’t forget to close the thread by clicking "Accept the answer" wherever the information provided helps you, as this can be beneficial to other community members.

    Regards,

    Rohith

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful

Your answer

Answers can be marked as Accepted Answers by the question author, which helps users to know the answer solved the author's problem.