@Ray, Pam, Thanks for sharing the solution here. I appreciate it. To help others who has the same issue, please let me write a brief summary:
Issue Description:
Some iOS devices (about 60) which are enrolled in Intune, but the device ownership is "unknown" UPN is 'none'. Azure AD registered is 'unknown'
Cause:
The issue was caused by the change Apple made that no longer allows Company Portal authentication.
Resolution:
Changing the authentication method to "Setup Assistant with Modern Authentication" allowed the user to complete the enrollment process, and the device ownership and UPN now show correctly in Intune.
Thanks for your time and have a nice day!