LinkedIn Sales Navigator display widgets don't load properly
This article helps you resolve issues related to LinkedIn Sales Navigator display widgets not loading properly in different web browsers.
Symptoms
When you try to sign in to LinkedIn Sales Navigator, the display widgets show the following error:
LinkedIn Sales Navigator subscription not found. You need a LinkedIn Sales Navigator Team contract in order to gain access.
Or, the display widgets don't load in different browsers.
Cause
This issue occurs because tracking protection is enabled in the browser.
Resolution
To resolve the issue, disable tracking protection in your web browser (Microsoft Edge, Mozilla Firefox, Google Chrome, or Apple Safari).
Microsoft Edge
In Microsoft Edge, select Settings and more in the upper-right corner and go to Settings.
From the site map, go to Privacy, search, and services.
In the Tracking prevention section, select Balanced and turn off the Always use "Strict" tracking prevention when browsing InPrivate option.
Mozilla Firefox
In Mozilla Firefox, open your organization.
Select the shield icon before the address bar to view enhanced tracking protection details.
Turn off the Enhanced tracking protection is ON for the site option and refresh the browser.
Refresh the page to ensure the display widgets load as expected.
Google Chrome
If browsing in incognito mode, turn off the Block third-party cookies option to ensure the display widgets load as expected.
Apple Safari
In Apple Safari, open your organization.
Go to Preferences and confirm the following configurations:
- Ensure LinkedIn and your Dynamics 365 organization aren't listed in Content Blockers. For more information, see Change Websites preferences in Safari on Mac.
- Allow pop-up windows for your Dynamics 365 organization.
- Ensure the Prevent cross-site tracking and Block all Cookies options aren't selected in the Privacy tab.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.