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Fehlerüberprüfung 0xC000021A: WINLOGON_FATAL_ERROR

Die WINLOGON_FATAL_ERROR Fehlerüberprüfung hat einen Wert von 0xC000021A. Dies bedeutet, dass der Winlogon-Prozess unerwartet beendet wurde.

Wichtig

Dieser Artikel richtet sich an Programmierer. Wenn Sie ein Kunde sind, der während der Verwendung Ihres Computers einen Bluescreen-Fehlercode erhalten hat, lesen Sie " Problembehandlung bei Bluescreen-Fehlern".

WINLOGON_FATAL_ERROR Parameter

Parameter Beschreibung

1

Eine Zeichenfolge, die das Problem identifiziert

2

Den Fehlercode

3

Reserviert

4

Reserviert

Ursache

Dieser Fehler tritt auf, wenn ein Benutzermodus-Subsystem, z. B. WinLogon oder das Client Server Run-Time Subsystem (CSRSS), schwerwiegend kompromittiert wurde und die Sicherheit nicht mehr garantiert werden kann. Als Reaktion wechselt das Betriebssystem in den Kernelmodus. Microsoft Windows kann nicht ohne WinLogon oder CSRSS ausgeführt werden. Daher ist dies einer der wenigen Fälle, in denen der Fehler eines Benutzermodusdiensts das System herunterfahren kann.

Nicht übereinstimmende Systemdateien können auch diesen Fehler verursachen. Diese Übereinstimmung kann auftreten, wenn Sie ihre Festplatte aus einer Sicherung wiederhergestellt haben. Einige Sicherungsprogramme können das Wiederherstellen von Systemdateien überspringen, die sie bestimmen, dass sie verwendet werden.

Lösung

Das Ausführen des Kerneldebuggers ist in dieser Situation möglicherweise nicht hilfreich, da der tatsächliche Fehler in einem Benutzermodusprozess aufgetreten ist.

Beheben eines Fehlers in einem Benutzermodus-Gerätetreiber, Systemdienst oder Drittanbieteranwendung

Da die Fehlerüberprüfung 0xC000021A in einem Benutzermodusprozess auftritt, sind die häufigsten Täter Anwendungen von Drittanbietern. Wenn der Fehler nach der Installation eines neuen oder aktualisierten Gerätetreibers, Eines Systemdiensts oder einer Drittanbieteranwendung aufgetreten ist, sollte die neue Software entfernt oder deaktiviert werden, um die Ursache zu isolieren. Wenden Sie sich an den Hersteller der Software über ein mögliches Update.

Beheben eines Problems mit einer nicht übereinstimmenden Systemdatei

Wenn Sie Ihre Festplatte kürzlich aus einer Sicherung wiederhergestellt haben, überprüfen Sie, ob eine aktualisierte Version des Sicherungs-/Wiederherstellungsprogramms vom Hersteller verfügbar ist.

  • Sehen Sie sich die zuletzt installierten Anwendungen an. Navigieren Sie dazu in der Systemsteuerung zu "Programm deinstallieren oder ändern", und sortieren Sie die installierten Anwendungen nach Installationsdatum.

  • Überprüfen Sie das Systemprotokoll Ereignisanzeige auf zusätzliche Fehlermeldungen, die dazu beitragen können, das Gerät oder den Treiber zu bestimmen, das den Fehler verursacht. Weitere Informationen finden Sie unter "Öffnen Ereignisanzeige". Suchen Sie im Systemprotokoll nach kritischen Fehlern, die in demselben Zeitfenster wie der Bluescreen aufgetreten sind.

  • Überprüfen Sie das Systemprotokoll Ereignisanzeige auf zusätzliche Fehlermeldungen, die dazu beitragen können, das Gerät oder den Treiber zu bestimmen, das den Fehler verursacht. Suchen Sie im Systemprotokoll nach kritischen Fehlern, die in demselben Zeitfenster wie der Bluescreen aufgetreten sind.

Hinweise

  • Verwenden Sie das Systemdateiprüfungstool, um fehlende oder beschädigte Systemdateien zu reparieren. Die Systemdateiprüfung ist ein Hilfsprogramm in Windows, mit dem Benutzer nach Beschädigungen in Windows-Systemdateien suchen und beschädigte Dateien wiederherstellen können. Verwenden Sie den folgenden Befehl, um das Systemdateiprüfungstool (SFC.exe) auszuführen.

    SFC /scannow
    

    Weitere Informationen finden Sie unter Verwenden des Tools für die Systemdateiprüfung, um fehlende oder beschädigte Systemdateien zu reparieren.

  • Führen Sie ein Virenerkennungsprogramm aus. Viren können alle Arten von Festplatten, die für Windows formatiert sind, infizieren, und die resultierende Datenträgerbeschädigung kann Systemfehlerüberprüfungscodes generieren. Stellen Sie sicher, dass das Virenerkennungsprogramm den Master Boot Record auf Infektionen überprüft.

  • Stellen Sie sicher, dass das System die neuesten Updates installiert hat. Um zu erkennen, welche Version auf Ihrem System installiert ist, wählen Sie "Start" aus, wählen Sie "Ausführen" aus, geben Sie winver ein, und drücken Sie dann die EINGABETASTE. Im Dialogfeld "Informationen zu Windows " wird die Windows-Versionsnummer (und die Versionsnummer des Service Packs, sofern installiert) angezeigt.

Verwenden des Tresor-Modus

Erwägen Sie die Verwendung Tresor Modus zum Isolieren von Elementen zur Problembehandlung und bei Bedarf zur Verwendung von Windows. Die Verwendung Tresor Modus lädt nur die minimal erforderlichen Treiber und Systemdienste während des Windows-Starts.

Um Tresor Modus einzugeben, verwenden Sie Update und Sicherheit in Einstellungen. Wählen Sie den erweiterten Wiederherstellungsstart> aus, um mit Standard Modus zu starten. Wählen Sie im resultierenden Menü die Option "Problembehandlung>beim Start von erweiterten Optionen>" Einstellungen> Restart aus. Nachdem Windows neu gestartet und der Bildschirm "Start" Einstellungen angezeigt wird, wählen Sie option 4, 5 oder 6 aus, um mit Tresor Modus zu starten.

Tresor Modus kann auch durch Drücken einer Funktionstaste beim Start verfügbar sein, z. B. F8. Informationen des Herstellers des Computers finden Sie unter bestimmten Startoptionen.