"Kommunikationsfehler" und die Verbindung zwischen Power Automate-Komponenten schlägt fehl.
Gilt für: Power Automate
Symptome
Wenn Sie versuchen, Power Automate zu starten, erhalten Sie die folgende Fehlermeldung:
Kommunikationsfehler:
Die Verbindung zwischen Power Automate-Komponenten konnte nicht hergestellt werden. Eine erforderliche Named Pipe wird von einer anderen Anwendung verwendet. Wenden Sie sich an Ihren IT-Administrierenden.
Ursache
Dieses Problem kann auftreten, wenn zwei verschiedene Versionen von Power Automate für Desktop auf dem Computer installiert sind. In diesem Szenario wird eine Version mit dem MSI-Installationsprogramm installiert, und eine andere Version wird aus dem Microsoft Store installiert. Dies kann zu Konflikten zwischen den beiden Versionen führen und ist ein nicht unterstütztes Szenario.
Lösung
Führen Sie basierend auf Ihrer Version von Power Automate für Desktop die folgenden Schritte aus, um das Problem zu beheben.
Wenn die Installationsprogrammversion Ihres Power Automate für Desktop 2.34.176.23181 oder höher ist (Microsoft Store-Version 10.0.7118.0 oder höher), führen Sie die folgenden Schritte aus, um eine Version der App zu deinstallieren:
- Wechseln Sie zu installierten Starteinstellungen-Apps>>>.
- Suchen Sie nach Power Automate.
- Deinstallieren Sie eine der beiden Versionen der App.
Wenn die Installationsprogrammversion Ihres Power Automate für Desktop vor 2.34.176.23181 (Microsoft Store-Version vor 10.0.7118.0) liegt, kann dieser Fehler auftreten, wenn ein anderer Prozess einen Server mit benannten Rohren auf demselben Computer ausführt. Dieser Prozess wird wahrscheinlich ausgeführt, indem erhöhte Rechte und der localhost-Endpunkt verwendet wird. Daher blockiert der Prozess die Verwendung des Endpunkts durch andere Anwendungen.
Führen Sie die folgenden Schritte aus, um festzustellen, ob ein anderer Prozess den Fehler verursacht:
Schließen Sie Power Automate. Verwenden Sie den Windows Task-Manager, um zu überprüfen, ob der Power Automate-Prozess nicht mehr ausgeführt wird.
Laden Sie die Sysinternals-Suite herunter.
Extrahieren Sie die komprimierte Datei in einen Ordner auf Dem Desktop.
Öffnen Sie ein Eingabeaufforderungsfenster mit erhöhten Rechten.
Navigieren Sie zu dem Ordner, in den Sie Sysinternals extrahiert haben.
Führen Sie den folgenden Befehl aus:
handle net.pipe
Wenn Sie diesen Befehl ausführen, sollte eine Liste der Prozesse angezeigt werden, die benannte Rohre verwenden, und die Adresse anzeigen, auf die sie lauschen.
Bestimmen Sie, ob ein Prozess, der die EbmV0LnBpcGU6Ly8rLw== Zeichenfolge anzeigt, vorhanden ist.
Wenn ein solcher Prozess vorhanden ist, beenden Sie den Vorgang.
Starten Sie Power Automate erneut.
Um das Problem zu beheben, beenden Sie den Prozess, der dazu führt, dass das Problem ausgeführt wird. Wenn der Prozess intern ist, können Sie ihn auch so konfigurieren, dass er einen spezifischeren Endpunkt verwendet, z . B. net.pipe://localhost/something.
Wenn diese Aktionen nicht möglich sind, geben Sie ausführbare Power Automate-Dateien an, die im Verwaltungsmodus ausgeführt werden sollen. Diese Lösung kann das Problem jedoch in allen Fällen nicht beheben. Darüber hinaus bewirkt diese Lösung, dass jedes Mal, wenn Sie die App ausführen, eine UAC-Eingabeaufforderung angezeigt wird.