MaxRDSessionDurationReached oder SessionHasLoggedOffWithMaxIdleTime tritt während eines Desktopablaufs auf
Dieser Artikel enthält eine Lösung für Fehlercodes, die während eines Desktopflusses in einer Cloudumgebung in Microsoft Power Automate ausgeführt werden.
Problembeschreibung
Wenn Sie einen Desktopfluss in einer Cloudumgebung in Power Automate ausführen, schlägt der Ablauf möglicherweise mit einem der Fehlercodes fehl, die den Namen des Registrierungswerts und seinen spezifischen Registrierungspfad angibt.
{
"error":{
"code": "MaxRDSessionDurationReached",
"message": "The session 5 duration (1856000 milliseconds) exceeded the one set in registry for MaxConnectionTime with value 1200000 in registry path Software\Policies\Microsoft\Windows NT\Terminal Service."
}
}
{
"error":{
"code": "SessionHasLoggedOffWithMaxIdleTime",
"message": "The session 5 duration (1856000 milliseconds) exceeded the one set in registry for MaxIdleTime with value 1200000 in registry path Software\Policies\Microsoft\Windows NT\Terminal Service."
}
}
Ursache
Die Fehlermeldung gibt an, dass die Remotedesktopsitzung abgemeldet wurde, da sie das in der Registrierung angegebene Zeitlimit überschritten hat (MaxConnectionTime oder MaxIdleTime). Dieses Problem tritt auf, wenn das Sitzungszeitlimit in der Registrierungseinstellung kürzer ist als die Zeit, die zum Abschließen des Desktopablaufs erforderlich ist.
Lösung
Um dieses Problem zu beheben, wenden Sie sich an Ihren Administrator, um die Einstellungen mithilfe einer der Optionen zu ändern.
Option 1: Über den Editor für lokale Gruppenrichtlinien
Überprüfen Sie die Gruppenrichtlinieneinstellungen, um sicherzustellen, dass keine Konfigurationen festgelegt sind, um sich aufgrund von Zeitlimits bei der Remotedesktopsitzung abzumelden. Sie können dies tun, indem Sie den Editor für lokale Gruppenrichtlinien öffnen und zu Administrativen Vorlagen für Computerkonfigurations-Administrative>Vorlagen>für Windows-Komponenten>für Remotedesktopdienste>-Sitzungszeitlimits navigieren.
- Wenn die Fehlermeldung auf den Registrierungswert MaxConnectionTime verweist, überprüfen Sie die Einstellung " Zeitlimit festlegen" für aktive Remotedesktopdienstesitzungen . Wenn sie aktiviert ist, deaktivieren Sie ihn, oder legen Sie den Grenzwert der aktiven Sitzung auf "Nie" fest.
- Wenn die Fehlermeldung auf den Registrierungswert "MaxIdleTime " verweist, überprüfen Sie die Einstellung " Zeitlimit festlegen" für aktive, aber im Leerlauf befindliche Remotedesktopdienstesitzungen . Wenn sie aktiviert ist, deaktivieren Sie ihn, oder legen Sie den Grenzwert der aktiven Sitzung auf "Nie" fest.
Option 2: Über den Registrierungs-Editor
Öffnen Sie den Registrierungs-Editor , und suchen Sie den Namen des Registrierungswerts aus der Fehlermeldung im angegebenen Registrierungspfad unter Computer\HKEY_LOCAL_MACHINE\.
Beispiel: Computer\HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Terminal Service
Wenn der Registrierungswert "MaxConnectionTime " oder "MaxIdleTime " vorhanden ist, legen Sie ihn auf 0 (Null) fest, was bedeutet, dass er unbegrenzt ist.
Notiz
Der Registrierungswert kann auch gelöscht oder auf einen Wert festgelegt werden, der größer als die maximale Ausführungszeit des Desktopflusses ist.
Name des Registrierungswerts | Beschreibung |
---|---|
MaxConnectionTime | Gibt die maximale Zeit (in Millisekunden) an, die eine Remotedesktopsitzung unabhängig von der Aktivität aktiv bleiben kann. |
MaxIdleTime | Gibt die maximale Zeit (in Millisekunden) an, die eine Remotedesktopsitzung im Leerlauf bleiben kann (ohne Benutzereingabe, z. B. Tastatur oder Mausaktivität), bevor sie abgemeldet wird. |