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Configuration Manager-Clients werden alle fünf Stunden neu installiert und können zu einem versehentlichen Clientupgrade führen.

In diesem Artikel wird ein Problem im System Center 2012 Configuration Manager-Client und system Center 2012 R2 Configuration Manager-Client erläutert, der zu einem versehentlichen Clientupgrade in einer Configuration Manager-Current Branch- oder long-Term Servicing Branch (LTSB)-Umgebung führen könnte.

Originalproduktversion: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Ursprüngliche KB-Nummer: 4018655

Zusammenfassung

Die Configuration Manager-Clientinstallation (CCMSetup) schlägt zunächst fehl und bewirkt, dass eine Client-Wiederholungsaufgabe in Windows Task Scheduler registriert wird. Nachdem die Clientinstallation erfolgreich war, wird die Wiederholungsaufgabe nicht wie erwartet gelöscht. Daher werden die Clients alle fünf Stunden weiter neu installiert.

Wenn Sie in diesem Fall die Configuration Manager-Infrastruktur auf configuration Manager current branch oder LTSB aktualisieren und wenn Sie die Configuration Manager-Clients nicht aktualisieren, erzwingt die geplante Wiederholungsaufgabe alle fünf Stunden die Neuinstallation eines Clients.

Beim nächsten Ausführen von CCMSetup finden die Clients einen aktualisierten Verwaltungspunkt oder Verteilungspunkt, und sie installieren die Clientsoftware erneut. Dadurch werden die Clients auf Configuration Manager aktualisiert.

Diese kontinuierlichen Upgrades erfolgen außerhalb des normalen Upgradeprozesses, der vom Administrator konfiguriert wird. Dies schließt das Clientpiloting-Feature ein.

Problembeschreibung

In einer Microsoft System Center 2012- oder System Center 2012 R2-Umgebung bemerken Sie die folgenden Symptome:

  • Clients installieren sich alle fünf Stunden erfolgreich erneut. Diese Aktivität wird in ccmsetup.log- und Windows-Ereignisprotokollen protokolliert.
  • Wenn Sie den Ordner \Microsoft\Microsoft\ConfigurationManager in Task Scheduler anzeigen, finden Sie eine Aufgabe namens Configuration Manager Client Retry Task.

Ursache

Dieses Problem tritt auf, da CCMSetup die Client-Wiederholungsaufgabe im falschen Ordner auf dem Client erstellt. Dadurch wird verhindert, dass CCMSetup die Aufgabe auffindt und entfernt.

Die geplante Aufgabe wird im Ordner \Microsoft\Microsoft\Configuration Manager anstelle des Ordners \Microsoft\Configuration Manager erstellt.

Problemumgehung 1

Entfernen Sie den Konfigurations-Manager-Client-Wiederholungsvorgang manuell aus dem Ordner "\Microsoft\Microsoft\Configuration Manager" mithilfe von Task Scheduler.

Problemumgehung 2

Stellen Sie ein Skript bereit, um configuration Manager Client Retry Task aus dem Ordner \Microsoft\Microsoft\Configuration Manager zu entfernen.

Beispiel für Windows PowerShell-Befehle zum Hinzufügen zu Ihrem Skript:

get-scheduledtask -taskname "Configuration Manager Client Retry Task"  
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false

Weitere Informationen

In Configuration Manager, version 1602 und höher, und in LTSB, Version 1606, entfernt Ccmsetup die geplante Aufgabe ordnungsgemäß, nachdem die Clients aktualisiert wurden.