Fehler AADSTS750054: „SAMLRequest“ oder „SAMLResponse“ muss als Abfragezeichenfolgenparameter in der HTTP-Anforderung für die SAML-Umleitungsbindung vorhanden sein
In diesem Artikel wird ein Problem beschrieben, bei dem Sie die Fehlermeldung "Error AADSTS750054 - SAMLRequest oder SAMLResponse müssen als Abfragezeichenfolgenparameter in der HTTP-Anforderung für SAML-Umleitungsbindung vorhanden sein.", wenn Sie versuchen, sich bei einer SAML-basierten single sign-on (SSO) konfigurierten App anzumelden, die in Microsoft Entra ID integriert wurde.
Symptome
Beim Versuch, sich bei einer Anwendung anzumelden, die für die Verwendung der Microsoft Entra-ID für die Identitätsverwaltung mit SAML-basiertem SSO eingerichtet wurde, wird eine Fehlermeldung AADSTS750054
angezeigt.
Ursache
Microsoft Entra ID konnte die SAML-Anforderung in den URL-Parametern in der HTTP-Anforderung nicht identifizieren. Dies kann passieren, wenn die Anwendung keine HTTP-Umleitungsbindung verwendet, wenn die SAML-Anforderung an Die Microsoft Entra-ID gesendet wird.
Lösung
Die Anwendung muss die SAML-Anforderung codiert im Adressheader unter Verwendung der HTTP-Umleitungsbindung senden. Weitere Informationen zur Implementierung finden Sie im Abschnitt zur HTTP-Umleitungsbindung in den SAML-Protokollspezifikationen.
Meistens liegt der Fehler auf einem der folgenden Probleme:
- Stellen Sie sicher, dass einmaliges Anmelden auf der Anwendungsseite aktiviert ist.
- Die Anwendung muss vom Dienstanbieter initiiertes Einmaliges Anmelden (manchmal als SP-initiiertes SSO bezeichnet) unterstützen. Wenn Sie eine Anmelde-URL für eine Anwendung eingeben, die nur das vom Identitätsanbieter initiierte single sign-on unterstützt, kann zu einer Zurückspringung von der Anwendung ohne SAML-Antwort führen.
- Stellen Sie sicher, dass die Anmelde-URL ordnungsgemäß konfiguriert ist.
Verwenden der Test-SSO-Funktion im Microsoft Entra Admin Center
Das Microsoft Entra Admin Center kann Ihnen bei der Behandlung von SAML-Konfigurationsfehlern helfen.
- Wechseln Sie im Microsoft Entra Admin Center zu Enterprise-Anwendungen , und klicken Sie auf die Anwendung, die Problembehandlung benötigt.
- Navigieren Sie mithilfe des linken Navigationsmenüs zur Seite "Einmaliges Anmelden "
- Klicken Sie auf "Diese Anwendung testen" , um die SSO-Funktion "Testen" zu verwenden.
- Kopieren und einfügen Sie den empfangenen Fehler im Abschnitt "Beheben von Fehlern ", und klicken Sie auf " Anleitung zur Lösung abrufen".
- Führen Sie die Schritte zum Beheben von Fehlern aus.
AADSTS750054
Weitere Informationen:
Eine vollständige Liste der Active Directory-Authentifizierungs- und Autorisierungsfehlercodes finden Sie unter Microsoft Entra-Authentifizierungs- und Autorisierungsfehlercodes
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