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Fehler AADSTS50011 mit SAML-Authentifizierung – Die in der Anforderung angegebene Antwort-URL stimmt nicht überein.

Dieser Artikel enthält eine Lösung für den AADSTS50011 Fehler, der während der Verbundauthentifizierung mit Microsoft Entra ID auftritt.

Symptome

Beim Versuch, sich bei einer Anwendung anzumelden, die für die Verwendung der Microsoft Entra-ID für die Identitätsverwaltung mit SAML-basiertem SSO eingerichtet wurde, wird eine Fehlermeldung AADSTS50011 angezeigt.

Fehler AADSTS50011 : Die Antwort-URL stimmt nicht mit den für die Anwendungs-GUID <>konfigurierten Antwort-URLs überein. Stellen Sie sicher, dass die in der Anforderung gesendete Antwort-URL mit einer der Antworten übereinstimmt, die Ihrer Anwendung im Azure-Portal hinzugefügt wurde. Navigieren Sie zu https://aka.ms/urlMismatchError weiteren Informationen dazu, wie Sie dies beheben können.", wenn Sie versuchen, sich bei einer SAML-basierten Single Sign-On (SSO)-konfigurierten App anzumelden, die mit Microsoft Entra ID integriert wurde.

Ursache

Der AssertionConsumerServiceURL Wert in der SAML-Anforderung stimmt nicht mit dem In Microsoft Entra ID konfigurierten Antwort-URL-Wert oder Muster überein. Der AssertionConsumerServiceURL-Wert in der SAML-Anforderung ist die URL in der Fehlermeldung.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Stellen Sie sicher, dass der AssertionConsumerServiceURL Wert in der SAML-Anforderung mit dem in Microsoft Entra ID konfigurierten Antwort-URL-Wert übereinstimmt.
  2. Vergewissern Sie sich, dass der Wert im Textfeld für die Antwort-URL dem AssertionConsumerServiceURL-Wert in der SAML-Anforderung entspricht, oder aktualisieren Sie ihn entsprechend.

Ausführliche Schritte zum Konfigurieren der Werte in der Microsoft Entra-ID finden Sie im folgenden Artikel:

Notiz

Die Antwort-URL wird auch als Umleitungs-URI bezeichnet. Diese Werte hängen davon ab, welche Anwendung verwendet wird. Sie sollten die Werte vom Hersteller der Anwendung erhalten.

Nachdem Sie den Antwort-URL-Wert in der Microsoft Entra-ID aktualisiert haben und mit dem Wert übereinstimmen, der von der Anwendung in der SAML-Anforderung gesendet wurde, sollten Sie sich bei der Anwendung anmelden können.

Weitere Informationen:

Eine vollständige Liste der Active Directory-Authentifizierungs- und Autorisierungsfehlercodes finden Sie unter Microsoft Entra-Authentifizierungs- und Autorisierungsfehlercodes.

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