Die Importdatei ist zu groß, um einen Uploadfehler beim Importieren einer Lösung in Microsoft Dynamics 365 zu groß zu machen.
Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie versuchen, eine Lösung in Microsoft Dynamics 365 zu importieren.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4462491
Problembeschreibung
Wenn Sie versuchen, eine Lösung in Dynamics 365 zu importieren, schlägt der Import fehl, und die folgende Meldung wird angezeigt:
"Die Importdatei ist zu groß, um sie hochzuladen.
Fehlercode 80040375"
Ursache
Obwohl die Fehlermeldung auf ein Problem mit der maximalen Größe der zu importierenden Lösung hinweist, kann ein anderes Problem wie ein SQL-Fehler die Ursache sein.
Lösung
Wählen Sie die Schaltfläche "Protokolldatei herunterladen" aus, um eine detailliertere Meldung anzuzeigen. Möglicherweise werden Details wie die folgende Meldung angezeigt:
Fehler beim Import. Weitere Informationen finden Sie in den zugehörigen Fehlermeldungen. : System.Data.SqlClient.SqlException (0x80131904) Spaltennamen in jeder Tabelle müssen eindeutig sein. Der Spaltenname '<Spaltenname>' in der Tabelle '<Entitäts-/Tabellenname>' wird mehrmals angegeben.
Die obige Beispielmeldung ist ein SQL-Fehler, der auftreten kann, wenn Sie versuchen, ein Feld zu importieren, das bereits in dieser Entität vorhanden ist.
Beispiel: Wenn Sie ein benutzerdefiniertes Feld in der Organisation mit einem Schemanamen namens new_field1 für die Kontoentität erstellt haben. Jetzt versuchen Sie, eine Lösung zu importieren, die ein Feld mit demselben Schemanamen in der Kontoentität enthält. SQL lässt nicht mehrere Spalten mit demselben Namen in derselben Tabelle zu, sodass der Import fehlschlägt. Möglicherweise haben Sie in der Zielumgebung bereits ein Feld mit demselben Schemanamen, aber verschiedene Groß-/Kleinschreibungen wie new_Field1 und das Feld in der zu importierenden Lösung ist new_field1. Wenn das Feld mit demselben Namen in der Zielumgebung nicht benötigt wird, löschen Sie es, und versuchen Sie es dann erneut.
Wenn der Fehler weiterhin besteht und Sie das Problem nicht mithilfe der Details in der Protokolldatei beheben können, wenden Sie sich an Microsoft-Support, um Hilfe zu erhalten. Sie können auch die Informationen in der Protokolldatei verwenden, um nach potenziellen Lösungen in den Dynamics 365 Communities zu suchen.