Fehler beim Importieren der Lösung aufgrund fehlender Komponenten
Dieser Artikel enthält eine Lösung für den Fehler "Fehler beim Importieren der Lösung [Lösungsname] ", der auftreten kann, wenn Sie versuchen, eine Lösung in Microsoft Dynamics 365 zu importieren.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4346030
Problembeschreibung
Beim Versuch, eine Lösung in Microsoft Dynamics 365 zu importieren, schlägt der Import mit der folgenden Meldung fehl:
Fehler beim Importieren der Lösung [Lösungsname]. Die folgenden Komponenten fehlen in Ihrem System und sind nicht in der Lösung enthalten. Importieren Sie die verwalteten Lösungen, die diese Komponenten enthalten ([Name der fehlenden Lösung] ([Lösungsversion])), und versuchen Sie dann erneut, die Lösung zu importieren.
Möglicherweise wird auch ein Verweis auf den Fehlercode 8004801d angezeigt.
Ursache
Dieser Fehler tritt auf, wenn Sie versuchen, eine Lösung zu importieren, die von anderen Komponenten abhängt, die sich nicht in Ihrer Microsoft Dynamics 365-Organisation befinden.
Beispiel: Sie haben eine Entwicklungsumgebung, in der Sie eine Lösung (Lösung A) erstellt haben, die eine benutzerdefinierte Entität (Widget) enthält. Sie haben eine andere Lösung (Lösung B) erstellt, die von einer Komponente in Lösung A abhängt (z. B. ein neues Feld zur Widget-Entität hinzugefügt). Wenn Sie versuchen, Lösung B in eine andere Organisation (z. B. Ihre Produktionsorganisation) zu importieren, die noch keine Lösung A installiert hat, tritt dieser Fehler auf.
Lösung
Überprüfen Sie die fehlenden Komponentendetails, die im Importdialogfeld angezeigt werden. Wenn andere Lösungen aufgeführt sind, die noch nicht in der Organisation importiert werden, in der Sie versuchen, diese Lösung zu importieren, importieren Sie diese Lösungen zuerst, bevor Sie versuchen, diese Lösung zu importieren.
Beispiel: Wenn Sie mit dem Beispiel aus dem obigen Abschnitt "Ursache" fortfahren, sehen Sie möglicherweise, dass in der Liste der fehlenden Komponenten eine oder mehrere Zeilen angezeigt werden, in denen die Spalte "Verwaltete Lösung" auf Lösung A verweist. Dies gibt an, dass Sie die erwähnte Version von Lösung A importieren müssen, bevor Sie Lösung B erfolgreich importieren können.
Weitere Informationen
Wenn sich die Fehlermeldung auf eine Microsoft-Lösung bezieht, finden Sie in der folgenden Liste der Lösungen, wo sie gefunden werden können, wenn sie nicht in der Zielorganisation installiert sind:
LinkedIn Sales Navigator für Dynamics 365
Lösungsnamen:
LinkedInSalesNavigatorControlsForUnifiedClient
LinkedIn
msdyn_LinkedInSalesNavigatorAnchor
Notiz
Wenn Sie diese Lösungen deinstallieren möchten, müssen sie in der Reihenfolge der obigen Liste deinstalliert werden.