Fehler 400 oder 401 beim Festlegen der Sichtbarkeit der virtuellen Dataverse-Tabelle
Fehlercode: SYS81183
In diesem Artikel werden die Fehlercodes (400 und 401) beschrieben, die auftreten können, wenn Sie die sichtbarkeit der virtuellen Microsoft Dataverse-Tabelle für den Steuerberechnungsdienst in einer RCS-Umgebung (Regulatory Configuration Service) festlegen. Außerdem wird erläutert, was die Probleme verursacht und wie sie behoben werden.
Notiz
Dieser Artikel gilt für Version 10.0.38 oder früher.
Fehler 400 mit "InternalServerError"
Symptome
Wenn Sie die Sichtbarkeit der virtuellen Tabelle festlegen oder die Masterdatensuche in der Steuerfunktion einrichten, erhalten Sie die folgende Fehlermeldung:
Fehler bei der Verbindung mit Microsoft Dataverse. Details: Der Remoteserver hat einen Fehler zurückgegeben: (400) Ungültige Anforderung. 0x80048d0b: Ein Token wurde abgerufen, um "Finance and Operations" aufzurufen, aber "Finance and Operations" hat einen Fehler vom Typ "InternalServerError" zurückgegeben.
Ursache
Dieses Problem tritt auf, wenn der Finanz- und Betriebsdienst ausgefallen ist oder die Ziel-URL für Finanzen und Vorgänge falsch festgelegt ist.
Lösung
- Vergewissern Sie sich, dass Sie sich bei Finanz- und Betriebs-Apps anmelden können, indem Sie dasselbe Konto verwenden, mit dem Sie sich bei Dataverse anmelden.
- Wechseln Sie zu "Dataverse>Advanced settings Administration>>Virtual Entity Data Sources", und wählen Sie die Datenquelle aus, die den Namen "Finanzen und Vorgänge" hat.
- Vergewissern Sie sich, dass die Ziel-URL direkt im Browser geöffnet werden kann. Weitere Informationen finden Sie unter Konfigurieren Sie die Datenquelle für virtuelle Entitäten.
Fehler 400 mit "Der Remotename konnte nicht behoben werden"
Symptome
Wenn Sie die Sichtbarkeit der virtuellen Tabelle festlegen oder die Masterdatensuche in der Steuerfunktion einrichten, erhalten Sie die folgende Fehlermeldung:
Fehler bei der Verbindung mit Microsoft Dataverse. Details: Der Remoteserver hat einen Fehler zurückgegeben: (400) Ungültige Anforderung. 0x80040224: TokenProvider.AcquireTokenAsync(Clientld '{ApplicationId}', Authority '{IncorrectURL}', Ressource '00000015-0000-0000-c000-00000000000'): Ausnahme ohne Ausnahme: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: Der Dienst hat einen Fehler zurückgegeben. Weitere Informationen ---> System.Net.WebException finden Sie unter InnerException: Der Remotename konnte nicht aufgelöst werden:...
Ursache
Dieses Problem tritt auf, wenn die OAuth-URL (Open Authorization) oder die Mandanten-ID falsch ist. Weitere Informationen finden Sie unter Konfigurieren Sie die Datenquelle für virtuelle Entitäten.
Lösung
Wechseln Sie zu "Dataverse>Advanced settings Administration>>Virtual Entity Data Sources", und wählen Sie die Datenquelle aus, die den Namen "Finanzen und Vorgänge" hat.
Vergewissern Sie sich, dass die OAuth-URL und die Mandanten-ID korrekt sind. Weitere Informationen finden Sie unter Konfigurieren Sie die Datenquelle für virtuelle Entitäten.
- Die OAuth-URL ist ein hartcodierter Wert:
https://login.windows.net/
. - Um die richtige Mandanten-ID zu finden, melden Sie sich bei der Azure-Portal mit demselben Konto an, mit dem Sie sich bei Dataverse und RCS anmelden. Wählen Sie Microsoft Entra-ID und dann Ihre Instanz von Microsoft Entra ID aus. Die Mandanten-ID oder primäre Domäne wird im Feld "Mandant " angezeigt.
- Die OAuth-URL ist ein hartcodierter Wert:
Fehler 400 mit "Anwendung mit Bezeichner {ApplicationId} nicht gefunden"
Symptome
Wenn Sie die Sichtbarkeit der virtuellen Tabelle festlegen oder die Masterdatensuche in der Steuerfunktion einrichten, erhalten Sie die folgende Fehlermeldung:
Fehler bei der Verbindung mit Microsoft Dataverse. Details: Der Remoteserver hat einen Fehler zurückgegeben: (400) Ungültige Anforderung. 0x80040224: TokenProvider.AcquireTokenAsync(Clientid '{IncorrectApplicationId}', Autorität '', Ressource '<
https://login.windows.net/microsoft.com
>00000015-0000-0000-c000-000000000000'): nicht behandelte Ausnahme: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: AADSTS700016: Anwendung mit dem Bezeichner "{IncorrectApplicationId}" wurde im Verzeichnis "Microsoft" nicht gefunden. Dies kann auftreten, wenn die Anwendung nicht vom Administrator des Mandanten installiert wurde oder wenn sie von den Benutzern des Mandanten keine Zustimmung erhalten hat. Unter Umständen haben Sie Ihre Authentifizierungsanforderung an den falschen Mandanten gesendet.
Ursache
Dieses Problem tritt auf, wenn die Anwendungs-ID falsch ist. Weitere Informationen finden Sie unter Konfigurieren Sie die Datenquelle für virtuelle Entitäten.
Lösung
- Wechseln Sie zu "Dataverse>Advanced settings Administration>>Virtual Entity Data Sources", und wählen Sie die Datenquelle aus, die den Namen "Finanzen und Vorgänge" hat.
- Vergewissern Sie sich, dass die Anwendungs-ID korrekt ist. Weitere Informationen finden Sie unter Konfigurieren Sie die Datenquelle für virtuelle Entitäten.
Sie sollten die Anwendungs-ID während der Registrierung der App im Azure-Portal Schritt abrufen. Stellen Sie sicher, dass Sie die richtige Anwendungs-ID eingegeben haben.
Fehler 401
Symptome
Wenn Sie die Sichtbarkeit der virtuellen Tabelle festlegen, führen Sie die Masterdatensuche im Steuerfeaturesetup aus, oder führen Sie die Modellzuordnungsüberprüfung durch, erhalten Sie eine der folgenden Fehlermeldungen:
Fehler bei der Verbindung mit Microsoft Dataverse. Details: Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert.
Fehler bei der Entität "Entity Warehouse"-Entität "Filtered Warehouse" mit Microsoft Dataverse. Details: Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert.
Ursache
Der Fehler 401 "Nicht autorisiert" tritt auf, wenn der Prozess "Verbindung überprüfen" für verbundene Anwendungen in RCS nicht erfolgreich ist oder wenn der Prozess "Verbindung überprüfen" nicht ausgeführt wird, nachdem Änderungen an den Einstellungen der verbundenen Anwendungen in RCS vorgenommen wurden.
Notiz
Das Konto, das für die Anmeldung bei RCS verwendet wird, sollte auch in der Lage sein, sich bei der Dataverse-Instanz anzumelden.
Lösung
- Wechseln Sie in der RCS-Umgebung zu "Electronic reporting>Connected applications>Dataverse application record".
- Das Feld "Anwendung " zeigt die URL der Datenbankinstanz an. Vergewissern Sie sich, dass Sie sich bei dieser Dataverse-Instanz anmelden können, indem Sie dasselbe Konto verwenden, mit dem Sie sich bei der RCS-Umgebung anmelden.
- Vergewissern Sie sich, dass das Feld "Mandant" auf die Mandanten-ID Ihres Kontos festgelegt ist (z. B. d335a570-a05b-4bc5-8eb3-c42c65f9560d) oder Mandanten-URL (z. B
taxserviceint.onmicrosoft.com
. ). - Wählen Sie " Verbindung überprüfen" aus. Der Prozess sollte erfolgreich sein.
Wichtig
Wenn der Prozess "Verbindung überprüfen" nicht erfolgreich ist, ist das Dataverse-Setup nicht korrekt. Weitere Informationen finden Sie unter Aktivieren der Hauptdatensuche für die Konfiguration der Steuerberechnung, und stellen Sie sicher, dass die Schritte 1, 2 und 3 alle ordnungsgemäß ausgeführt werden.