Fehler "Fehler beim Aktivieren der Replikation" im Cloudmigrationssetup
In diesem Artikel wird eine Fehlermeldung behoben, die auftritt, wenn Sie das Setuphandbuch für die Cloudmigration in Business Central ausführen.
Symptome
Wenn Sie das Setuphandbuch für die Cloudmigration während des Datenmigrationsprozesses von lokal nach Business Central online ausführen, erhalten Sie die folgende Fehlermeldung:
Fehler beim Aktivieren der Replikation. Stellen Sie sicher, dass die Integrationslaufzeit erfolgreich verbunden ist, und versuchen Sie es erneut.
Ursache
Es kann mehrere Gründe für die Fehlermeldung geben. Der häufigste Grund ist jedoch ein Konflikt zwischen der lokalen Version und den Online-Business Central-Versionen und dem im Handbuch für die Cloudmigrationseinrichtung ausgewählten Produkttyp.
Lösung
Führen Sie das Cloudmigrationssetup aus, und stellen Sie sicher, dass der Produkttyp mit Ihren lokalen und Onlineversionen konsistent ist. Business Central-Versionsnummern sollten das Format "Major.Minor.Revision.Build " aufweisen, z. B. 20.1.12345.67890.
- Wenn die lokalen und Online-Hauptversionen identisch sind, wie 20.1 für lokale Und 20.3 für Online, wählen Sie Dynamics Business Central aktuelle Version aus.
- Wenn die lokalen und Online-Hauptversionen unterschiedlich sind, z . B. 14.3 für lokale Versionen und 20.3 für Online, wählen Sie Dynamics Business Central in früheren Versionen aus.
Sie können die folgende SQL-Abfrage ausführen, um zu überprüfen, ob die lokale Datenbank die richtige Versionsnummer enthält:
SELECT [applicationversion]
FROM [$ndo$tenantdatabaseproperty]