Eine Aktivitätsüberschreitung bei der Business Central-Cloudmigration
Dieser Artikel enthält Schritte zur Problembehandlung für ein Problem, bei dem eine Aktivität während der Business Central-Cloudmigration zu einem Ausfall führt.
Symptome
Eine Aktivitätsüberschreitung während der Business Central-Cloudmigration.
Ursache
Wenn eine Aktivität während des Cloudmigrationssetups zu einem Timeout kommt, kann es vorkommen, dass integrations runtime keine Verbindung mit SQL Server herstellen konnte oder aufgrund der Indexdefragmentierung in großen lokalen Datenbanken. Wenn während einer Migrationsausführung ein Zeitüberschreitung auftritt, ist der Grund wahrscheinlich ein schwacher oder ausgelasteter lokaler SQL Server.
Lösung
Wenn die SQL-Verbindung dauerhaft unterbrochen ist, überprüfen Sie, ob .NET 4.72 oder höher auf dem Host der Integrationslaufzeit ausgeführt wird.
Überprüfen Sie weitere Integrations-Runtime-Anforderungen auf der Azure Data Factory-Seite .
Bei Problemen mit der Datenbankleistung wird empfohlen, Statistiken zu aktualisieren und Indizes in der lokalen Datenbank vor dem Einrichten der Cloudmigration neu zu organisieren.
Führen Sie zum Aktualisieren von Statistiken die folgende Abfrage aus (z. B. in Microsoft SQL Management Studio, das mit der lokalen Datenbank verbunden ist):
EXEC sp_updatestats;
Führen Sie die folgende Abfrage aus, um Indizes neu zu organisieren:
EXEC sys.sp_MSforeachtable 'ALTER INDEX ALL ON ? REORGANIZE'