Freigeben über


Behandeln von Bereitstellungsproblemen beim Neustart oder Ändern der Größe einer vorhandenen Windows-VM in Azure

Gilt für: ✔️ Windows-VMs

Wenn Sie versuchen, einen beendeten virtuellen Azure-Computer zu starten oder die Größe eines vorhandenen virtuellen Azure-Computers zu ändern, tritt häufig ein Zuordnungsfehler auf. Dieser Fehler tritt auf, wenn in dem Cluster oder der Region keine Ressourcen verfügbar sind, oder wenn die angeforderte Größe des virtuellen Computers nicht unterstützt werden kann.

Suchen Sie in den Azure-Foren bei MSDN und Stack Overflow, falls Sie Ihr Azure-Problem mit diesem Artikel nicht beheben konnten. Sie können Ihr Problem in diesen Foren oder an @AzureSupport auf Twitter posten. Sie können auch eine Azure-Supportanfrage senden. Wenn Sie eine Supportanfrage senden möchten, wählen Sie auf der Azure-Support-Seite die Option Support erhalten aus.

Erfassen von Aktivitätsprotokollen

Sammeln Sie zur Problembehandlung zunächst die Aktivitätsprotokolle, um den Fehler zu ermitteln, auf den das Problem zurückzuführen ist. Die folgenden Links enthalten detaillierte Informationen zur Vorgehensweise:

Bereitstellungsvorgänge anzeigen

Anzeigen von Aktivitätsprotokollen zum Verwalten von Azure-Ressourcen

Problem: Fehler beim Starten eines angehaltenen virtuellen Computers

Sie versuchen, einen angehaltenen virtuellen Computer zu starten, erhalten aber eine Zuordnungsfehlermeldung.

Ursache

Die Anforderung zum Start des angehaltenen virtuellen Computers muss im Originalcluster, der den Clouddienst hostet, ausgeführt werden. Im Cluster ist jedoch nicht genügend freier Speicherplatz verfügbar, um die Anforderung zu erfüllen.

Lösung

  • Beenden Sie alle virtuellen Computer in der Verfügbarkeitsgruppe, und starten Sie dann jeden virtuellen Computer neu.

    1. Klicken Sie auf Ressourcengruppen>Ihre Ressourcengruppe>Ressourcen>Ihre Verfügbarkeitsgruppe>Virtuelle Computer>Ihr virtueller Computer>Beenden.
    2. Nachdem alle virtuellen Computer angehalten wurden, wählen Sie jeden einzelnen angehaltenen virtuellen Computer aus, und klicken Sie auf "Start".
  • Wiederholen Sie die Neustartanforderung zu einem späteren Zeitpunkt.

Problem: Fehler beim Ändern der Größe eines vorhandenen virtuellen Computers

Sie versuchen, die Größe eines angehaltenen virtuellen Computers zu ändern, erhalten aber eine Zuordnungsfehlermeldung.

Ursache

Die Anforderung zur Größenänderung des virtuellen Computers muss im Originalcluster, der den Clouddienst hostet, ausgeführt werden. Der Cluster unterstützt jedoch nicht die angeforderte Größe des virtuellen Computers.

Lösung

  • Wiederholen Sie die Anforderung mit einer geringeren Größe des virtuellen Computers.

  • Wenn die Größe des angeforderten virtuellen Computers nicht geändert werden kann:

    1. Beenden Sie alle virtuellen Computer in der Verfügbarkeitsgruppe.

      • Klicken Sie auf Ressourcengruppen>Ihre Ressourcengruppe>Ressourcen>Ihre Verfügbarkeitsgruppe>Virtuelle Computer>Ihr virtueller Computer>Beenden.
    2. Nachdem alle virtuellen Computer beendet wurden, vergrößern Sie den gewünschten virtuellen Computer.

    3. Wählen Sie den virtuellen Computer mit der geänderten Größe aus, und klicken Sie auf Starten. Starten Sie dann jeden einzelnen beendeten virtuellen Computer.

Fehler beim Stoppen, Starten, Neustarten oder erneuten Bereitstellen eines vorhandenen virtuellen Computers

Wenn Sie versuchen, einen vorhandenen virtuellen Computer zu beenden, zu starten, neu zu starten oder erneut bereitzustellen, schlägt der Prozess fehl, und Sie erhalten einen "Unerwarteter Fehler beim Verarbeiten des Netzwerkprofils der VM. Bitte versuchen Sie es später erneut" Fehlermeldung. Wenn dieser Fehler auftritt, wird der virtuelle Computer in einen fehlerhaften Zustand versetzt.

Ursache

Dieses Problem tritt auf, wenn es ein Problem bei der Zuweisung oder Aktualisierung von Netzwerkressourcen gibt.

Lösung

Versuchen Sie, den Zustand des virtuellen Computers erneut anzuwenden. Bei diesem Vorgang wird die VM-Bereitstellung erneut ausgeführt und der VM-Zustandsfehler behoben, der bei einer nicht erfolgreichen VM-Bereitstellung auftritt, wenn Sie eine vorherige VM-Aktion ausgeführt haben.

  1. Navigieren Sie zu dem virtuellen Computer, der im fehlerhaften Zustand hängen geblieben ist.
  2. Wählen Sie unter Hilfe die Option Erneut bereitstellen + erneut anwenden aus.
  3. Wählen Sie die Option Erneut anwenden aus.

Nächste Schritte

Wenn beim Erstellen eines neuen virtuellen Windows-Computers in Azure Probleme auftreten, finden Sie Informationen unter Behandeln von Bereitstellungsproblemen beim Erstellen eines neuen virtuellen Windows-Computers in Azure.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.