Sicherungsfehler des Microsoft Azure Recovery Services Agent System State (Fehler-ID 8007007B)
In diesem Artikel werden die Symptome und die Lösung für einen Fehler beschrieben, der auftritt, wenn Sie den Systemstatus mithilfe des Microsoft Azure Recovery Services (MARS)-Agents sichern.
Ursprüngliche Produktversion: Azure Backup
Ursprüngliche KB-Nummer: 4053355
Symptome
Eine der folgenden Fehlermeldungen wird auf der Registerkarte "Fehler " des Dialogfelds "Auftragsdetails " angezeigt, das einem fehlerhaften Sicherungsauftrag für den Systemstatus auf der Microsoft Azure Recovery Services Agent-Konsole entspricht.
Fehler beim Ausführen des Vorgangs als Windows Server-Sicherungsauftrag mit fehlermeldung: Keine der in der Sicherung enthaltenen Elemente wurde gesichert. Detaillierter Fehler: Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=847810 , um dieses Problem zu beheben. (0x1873D)
Fehler bei der Sicherung des Systemstatus durch Windows Server, weil ein Systemwriter einen ungültigen Pfad gemeldet hat. Fehlermeldung zur Windows Server-Sicherung: Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=859092 , um dieses Problem zu beheben. (0x18770)
Wenn Sie auf WSB-Fehlerprotokolle klicken, wird eine Datei geöffnet, die eine Fehlermeldung enthält, die etwa wie folgt aussieht:
Fehler bei der Sicherung von Systemroot_pathduring Aufzählung: Fehler [0x8007007b] Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
Ursache
Dieser Fehler tritt auf, wenn die Dateispezifikation, die zum Aufzählen von Dateien erforderlich ist, die als Teil des Windows Server-Systemstatus gesichert werden müssen, falsch aktualisiert wird.
Lösung
Warnung
Schwerwiegende Probleme können auftreten, wenn die Registrierung mit dem Registrierungs-Editor oder einer anderen Methode unsachgemäß bearbeitet wird. Aufgrund dieser Probleme kann eine Neuinstallation des Betriebssystems erforderlich sein. Microsoft gibt keinerlei Garantien dafür ab, dass diese Probleme behoben werden können. Das Ändern der Registrierung erfolgt auf eigenes Risiko.
Führen Sie die folgenden Schritte aus, um sicherzustellen, dass die Dateispezifikation aktualisiert wird:
Überprüfen Sie in der Datei, die geöffnet wird, wenn Sie auf WSB-Fehlerprotokolle klicken, ob die Systemroot_path korrekt ist. Beispielsweise sollte Systemroot_path in der folgenden Fehlermeldung wie folgt aussehen
C:\Windows\\systemroot\
:Fehler bei der Sicherung von c:\windows\systemroot\ während der Aufzählung: Fehler [0x8007007b] Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
Führen Sie an einer Eingabeaufforderung mit erhöhten Rechten den folgenden Befehl aus:
diskshadow /l Output_File_Path
Notiz
Der Platzhalter Output_File_Path sollte ähnlich aussehen
C:\outputfilepath.txt
.Geben Sie die folgenden Befehle an einer DISKSHADOW-Eingabeaufforderung ein, und drücken Sie dann nach jedem Befehl die EINGABETASTE:
list writers detailed exit
Öffnen Sie die Ausgabedatei, die Sie in Schritt 2 angegeben haben.
Suchen Sie die Zeile, die Systemroot_path enthält (
C:\Windows\\systemroot\
in unserem Beispiel oben). Die Zeile sollte z. B. wie folgt aussehen: Dateiliste: Pfad = Systemroot_path\system32\drivers, Filespec = File_Spec_PathBeispiel:
Dateiliste: Pfad =
C:\windows\\systemroot\system32\drivers
, Filespec = winmad.sysStarten Sie den Registrierungs-Editor. Klicken Sie hierzu mit der rechten Maustaste auf "Start", klicken Sie auf "Ausführen", geben Sie "regedit " in das Feld "Öffnen " ein, und klicken Sie dann auf "OK".
Suchen Sie den folgenden Unterschlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Klicken Sie mit der rechten Maustaste auf "Dienste", und klicken Sie dann auf "Suchen".
Geben Sie im Feld "Suchen nach" den File_Spec_Path Pfad ein, den Sie in Schritt 5 gefunden haben, und klicken Sie dann auf "Weitersuchen".
Beispiel:
Die Suchergebnisse enthalten einen Registrierungsschlüssel mit dem Namen ImagePath. Wenn der Wert einen führenden umgekehrten Schrägstrich "" aufweist, doppelklicken Sie auf diesen Wert, und entfernen Sie ihn. Wenn der Wert nicht mit einem umgekehrten Schrägstrich beginnt, senden Sie eine Supportanfrage von der Azure-Portal.
Vor der Änderung Nach der Änderung Wechseln Sie zurück zur MARS Agent-Konsole, und starten Sie eine Systemstatussicherung, indem Sie auf "Jetzt sichern" klicken.
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