HPC-Computeknoten werden nicht angezeigt oder befinden sich im Fehlerzustand
Dieser Artikel enthält eine Lösung für ein Problem, bei dem Computeknoten nicht angezeigt werden oder sich in einem Fehlerzustand befinden, wenn Sie einen HPC-Cluster (High-Performance Computing) in Azure bereitstellen.
Symptome
Wenn Sie einen HPC-Cluster in Azure bereitstellen, ist die Bereitstellung erfolgreich, aber Computeknoten werden nicht angezeigt oder befinden sich in einem Fehlerzustand. Im Computeknoten werden Zertifikat- und Netzwerkfehler in den HpcNodeManager-Dienstprotokollen angezeigt.
Hier ist ein Netzwerkfehlerbeispiel:
System.Net.Sockets.SocketException: Ein Verbindungsversuch ist fehlgeschlagen, da der verbundene Anbieter nach einem bestimmten Zeitraum nicht ordnungsgemäß reagiert hat oder die Verbindung fehlgeschlagen ist, da der verbundene Host nicht auf x.x.x.x.xxx reagiert hat.
Ursache
Dieses Problem tritt aufgrund von Netzwerkkonfigurationsproblemen oder einer Art von Zertifikatkonflikt auf.
Lösung
Überprüfen Sie Netzwerk- und Zertifikatfehler in den HpcNodeManager-Dienstprotokollen auf dem Computeknoten.
Korrigieren Von Zertifikatkonflikten, falls vorhanden. Weitere Informationen finden Sie unter Verwalten von Zertifikaten für HPC Pack 2019 Cluster.
Um Netzwerkprobleme mit dem obigen Fehler zu beheben, konfigurieren Sie die Regeln und Firewallregeln der Netzwerksicherheitsgruppe. Weitere Informationen finden Sie im Abschnitt "Configure Network Security Group for Azure virtual network" in Burst to Azure IaaS VM from an HPC Pack Cluster.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.