HPC-Computeknoten werden nicht angezeigt oder befinden sich im Fehlerzustand
Dieser Artikel bietet eine Lösung für ein Problem, bei dem Computeknoten nicht angezeigt werden oder sich in einem Fehlerzustand befinden, wenn Sie einen HPC-Cluster (High Performance Computing) in Azure bereitstellen.
Symptome
Wenn Sie einen HPC-Cluster in Azure bereitstellen, ist die Bereitstellung erfolgreich, aber Computeknoten werden nicht angezeigt oder befinden sich in einem Fehlerzustand. Zertifikat- und netzwerkbezogene Fehler werden in den HpcNodeManager-Dienstprotokollen auf dem Computeknoten angezeigt.
Hier sehen Sie ein Beispiel für einen Netzwerkfehler:
System.Net.Sockets.SocketException: Ein Verbindungsversuch ist fehlgeschlagen, weil die verbundene Partei nach einem bestimmten Zeitraum nicht ordnungsgemäß reagiert hat, oder weil die verbindung hergestellte Verbindung fehlgeschlagen ist, weil der verbundene Host nicht reagiert hat x.x.x.xxx
Ursache
Dieses Problem tritt aufgrund von Netzwerkkonfigurationsproblemen oder einer Art von Zertifikatkonflikt auf.
Lösung
Überprüfen Sie Netzwerk- und Zertifikatfehler in den HpcNodeManager-Dienstprotokollen auf dem Computeknoten.
Korrigieren Sie ggf. fehlende Zertifikatübereinstimmungen. Weitere Informationen finden Sie unter Verwalten von Zertifikaten für HPC Pack 2019-Cluster.
Um Netzwerkprobleme mit dem obigen Fehler zu beheben, konfigurieren Sie die Regeln für Netzwerksicherheitsgruppen und Firewallregeln. Weitere Informationen finden Sie im Abschnitt "Konfigurieren der Netzwerksicherheitsgruppe für ein virtuelles Azure-Netzwerk" unter Burst to Azure IaaS VM from an HPC Pack Cluster (Burst to Azure IaaS VM from an HPC Pack Cluster).
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.