Behandeln von Ausnahmen für die Wiederverwendung von Rollen in CloudDienst (klassisch)
Wichtig
Cloud Services (klassisch) ist jetzt für neue Kunden veraltet und wird am 31. August 2024 für alle Kunden eingestellt. Neue Bereitstellungen sollten das neue azure Resource Manager-basierte Bereitstellungsmodell, Azure Cloud Services (erweiterter Support), verwenden.
Dieser Artikel hilft Ihnen bei der Problembehandlung bei UpdateDeploymentRoleRecycleThresholdReached-Ausnahmen, die während der Bereitstellung von Clouddiensten auftreten.
Symptom
Ihre Dienstrolleninstanzen werden während eines Updates oder Upgrades kontinuierlich wiederverwendet. Das Update oder Upgrade mit Ihren Konfigurationseinstellungen hat verhindert, dass die Rolleninstanzen ausgeführt werden.
Die folgende Meldung wird angezeigt:
Ihre Rolleninstanzen haben während eines Aktualisierungs- oder Upgradevorgangs eine Reihe von Male wiederverwendet. Dies gibt an, dass die neue Version Ihres Diensts oder die Konfigurationseinstellungen, die Sie beim Konfigurieren des Diensts bereitgestellt haben, verhindern, dass die Rolleninstanzen ausgeführt werden. Überprüfen Sie, ob der Code keine unbehandelten Ausnahmen auslöst und dass Ihre Konfigurationseinstellungen korrekt sind, und starten Sie dann einen anderen Update- oder Upgradevorgang.
Ursache
Eine UpdateDeploymentRoleRecycleThresholdReached-Ausnahme bedeutet, dass die Rolleninstanzen des Clouddiensts während eines Updates eine Weile wiederverwertt wurden.
Weitere Informationen zu unbehandelten Rollen exceptions finden Sie unter Allgemeine Probleme, die dazu führen, dass Azure Cloud Service (klassische) Rollen wiederverwendet werden.
Lösung
Führen Sie eine der folgenden Schritte aus, um dieses Problem zu beheben:
Löschen Sie den Bereitstellungsplatz , aus dem die Rollen wiederverwertet werden. Führen Sie dann eine neue Bereitstellung für einen leeren Platz aus.
Erstellen Sie eine neue Clouddienstinstanz, stellen Sie sie bereit, und aktualisieren Sie den kanonischen Namen des Diensts (CName).
Was geschieht, wenn Sie die IP-Adresse, die Ihrem vorhandenen Bereitstellungsplatz zugeordnet ist, nicht verlieren möchten? Führen Sie dann die folgenden Schritte aus, um die Adresse zu reservieren und freizugeben. Weitere Informationen finden Sie unter Reservierte IP-Adressen für Clouddienste und virtuelle Computer.
Reservieren Sie die IP-Adresse des vorhandenen Bereitstellungsplatzes.
Geben Sie die zugeordnete reservierte IP-Adresse frei.
Löschen Sie den Bereitstellungsplatz.
Erstellen Sie eine neue Bereitstellung für diesen Steckplatz.
Ordnen Sie die erforderliche reservierte IP-Adresse diesem Clouddienstplatz zu.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.