Problembehandlung beim Fehlercode "TooManyRequestsReceived" oder "SubscriptionRequestsThrottled"
In diesem Artikel wird erläutert, wie Sie den oder SubscriptionRequestsThrottled
den Fehler identifizieren und beheben, der TooManyRequestsReceived
auftritt, wenn Sie versuchen, einen Microsoft Azure Kubernetes Service (AKS)-Cluster zu löschen.
Symptome
Wenn Sie versuchen, einen AKS-Cluster zu löschen, erhalten Sie die folgende Fehlermeldung:
internalErrorCode: TooManyRequestsReceived
StatusCode: 429
{
Meldung: "Anzahl der Leseanforderungen für das Abonnement '.....'" hat den Grenzwert von '....' überschritten. für das Zeitintervall 'XX:XX:XX'. Versuchen Sie es nach '.....' erneut. Sekunden."
}
Ursache
Alle Vorgänge auf Abonnement- und Mandantenebene unterliegen Drosselungsgrenzwerten. Diese Grenzwerte gelten für jede Instanz von Azure Resource Manager. Wenn Sie den Grenzwert erreichen, erhalten Sie eine HTTP-Antwort, die den Statuscode 429 angibt: "Zu viele Anforderungen".
Lösung
Die HTTP-Antwort enthält einen Retry-After
Wert. Dies gibt die Anzahl der Sekunden an, die Ihre Anwendung warten (oder in den Ruhezustand versetzt werden soll), bevor sie die nächste Anforderung sendet. Wenn Sie eine Anforderung senden, bevor der Wiederholungswert abgelaufen ist, wird Ihre Anforderung nicht verarbeitet, und ein neuer Wiederholungswert wird zurückgegeben. Weitere Informationen zu Einschränkungsgrenzwerten finden Sie unter Drosselung von Ressourcen-Manager-Anforderungen.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.