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Problembehandlung beim Fehlercode K8SAPIServerConnFailVMExtensionError (51)

In diesem Artikel wird erläutert, wie Sie den K8SAPIServerConnFailVMExtensionError Fehler identifizieren und beheben (auch als Fehlercode ERR_K8S_API_SERVER_CONN_FAIL, Fehlernummer 51 bezeichnet), der auftritt, wenn Sie versuchen, einen Microsoft Azure Kubernetes Service (AKS)-Cluster zu starten oder bereitzustellen.

Voraussetzungen

Symptome

Wenn Sie versuchen, einen AKS-Cluster zu starten oder zu erstellen, erhalten Sie die folgende Fehlermeldung:

Die Verbindung von Agents mit dem Kubernetes-API-Server kann nicht hergestellt werden. Weitere Informationen finden Sie unter https://aka.ms/aks-required-ports-and-addresses .

Details: Code="VMExtensionProvisioningError"

Message="VM hat beim Verarbeiten der Erweiterung 'vmssCSE' einen Fehler gemeldet.

Fehlermeldung: "Fehler beim Ausführen: Befehl konnte nicht ausgeführt werden: Befehl beendet mit exit status=51\n[stdout]\n{

"ExitCode": "51",

"Output": "Thu Oct 14 18:07:37 UTC 2021,aks-nodepool1-18315663-vmss000000\nConnection to

Ursache

Ihre Clusterknoten können keine Verbindung mit Ihrem Cluster-API-Server-Pod herstellen.

Lösung

Führen Sie einen Netcat-Befehl aus, um zu überprüfen, ob Ihre Knoten den vollqualifizierten Domänennamen (FQDN) des Clusters auflösen können:

nc -vz <cluster-fqdn> 443

Wenn Sie die Ausgangsfilterung über eine Firewall verwenden, stellen Sie sicher, dass der Datenverkehr zu Ihrem Cluster-FQDN zulässig ist.

In seltenen Fällen kann die ausgehende IP-Adresse der Firewall blockiert werden, wenn Sie autorisierte IP-Adressen haben, die auf Ihrem Cluster aktiviert sind. In diesem Szenario müssen Sie die ausgehende IP-Adresse Ihrer Firewall zur Liste der autorisierten IP-Bereiche für den Cluster hinzufügen. Weitere Informationen finden Sie unter "Sicherer Zugriff auf den API-Server mithilfe autorisierter IP-Adressbereiche in AKS".

Weitere Informationen

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.