Client-IP-Adresse kann nicht auf den API-Server zugreifen
In diesem Artikel wird beschrieben, wie Sie Probleme beheben, die auftreten, wenn Sie keine Verbindung mit einem Azure Kubernetes Service (AKS)-Cluster herstellen können, da Ihre Client-IP-Adresse nicht auf den AKS-API-Server zugreifen kann.
Voraussetzungen
- Azure-Befehlszeilenschnittstelle.
- Das Client-URL-Tool (curl).
Symptome
Wenn Sie versuchen, auf Kubernetes-Ressourcen wie Mamespaces und Workloads aus dem Azure-Portal zuzugreifen, treten möglicherweise die folgenden Fehler auf:
Netzwerkfehler
Der API-Server "https://< API-server-FQDN>" oder der API-Server kann nicht erreicht werden, um zu reagieren. Überprüfen Sie Ihre Netzwerkeinstellungen, und aktualisieren Sie sie, um es erneut zu versuchen.
Ursache
API-serverautorisierte IP-Bereiche wurden möglicherweise auf dem API-Server des Clusters aktiviert, die IP-Adresse des Clients war jedoch nicht in den IP-Bereichen enthalten. Um zu überprüfen, ob dieses Feature aktiviert wurde, überprüfen Sie, ob der folgende Befehl "Az aks show command" in Azure CLI eine Liste der IP-Bereiche erzeugt:
az aks show --resource-group <cluster-resource-group> \
--name <cluster-name> \
--query apiServerAccessProfile.authorizedIpRanges
Lösung
Sehen Sie sich die API-serverautorisierten Bereiche des Clusters an, und fügen Sie die IP-Adresse Ihres Clients innerhalb dieses Bereichs hinzu.
Notiz
Greifen Sie über ein Unternehmensnetzwerk auf den API-Server zu, in dem Datenverkehr über einen Proxyserver oder eine Firewall weitergeleitet wird? Bitten Sie dann Ihren Netzwerkadministrator, bevor Sie Ihre Client-IP-Adresse zur Liste der autorisierten Bereiche für den API-Server hinzufügen.
Bitten Sie auch Ihren Clusteradministrator, bevor Sie Ihre Client-IP-Adresse hinzufügen, da es möglicherweise Sicherheitsbedenken beim Hinzufügen einer temporären IP-Adresse zur Liste der autorisierten Bereiche gibt.
Navigieren Sie vom Azure-Portal zum Cluster.
Suchen Sie im linken Menü die Einstellungen, und wählen Sie dann "Netzwerk" aus.
Wählen Sie auf der Seite "Netzwerk " die Registerkarte "Übersicht " aus.
Wählen Sie "Verwalten" unter "Ressourceneinstellungen" aus.
Fügen Sie im Bereich "Autorisierte IP-Bereiche " Ihre Client-IP-Adresse hinzu, wie im folgenden Screenshot gezeigt:
Kontaktieren Sie uns für Hilfe
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