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Problembehandlung beim Fehlercode "CannotDeleteLoadBalancerWithPrivateLinkService" oder "PrivateLinkServiceWithPrivateEndpointConnectionsCannotBeDeleted"

In diesem Artikel wird erläutert, wie Sie den oder PrivateLinkServiceWithPrivateEndpointConnectionsCannotBeDeleted den Fehler identifizieren und beheben, der CannotDeleteLoadBalancerWithPrivateLinkService auftritt, wenn Sie versuchen, einen Microsoft Azure Kubernetes Service (AKS)-Cluster zu löschen.

Symptome

Wenn Sie versuchen, einen AKS-Cluster zu löschen, wird eine der folgenden Fehlermeldungen angezeigt:

  • Für den CannotDeleteLoadBalancerWithPrivateLinkService Fehlercode:

    internalErrorCode: "CannotDeleteLoadBalancerWithPrivateLinkService"

    StatusCode=BadRequest

    {

    "Das Lastenausgleichsmodul ...../providers/Microsoft.Network/loadBalancers/kubernetes-internal kann nicht gelöscht werden, da es von privatem Linkdienst ...../providers/Microsoft.Network/privateLinkServices/test referenziert wird. Löschen Sie vor dem Löschen des Lastenausgleichs den Private Link-Dienst."

    }

  • Für den PrivateLinkServiceWithPrivateEndpointConnectionsCannotBeDeleted Fehlercode:

    internalErrorCode: "PrivateLinkServiceWithPrivateEndpointConnectionsCannotBeDeleted"

    StatusCode=BadRequest

    {

    Meldung: "Privater Linkdienst ...../Microsoft.Network/privateLinkServices/test kann nicht gelöscht werden, da er über 1 private Endpunktverbindungen verfügt. Löschen Sie alle privaten Endpunktverbindungen, bevor Sie den Private Link-Dienst löschen."

    }

Ursache

Der private Linkdienst kann nicht gelöscht werden, da der Cluster privaten Endpunktverbindungen zugeordnet ist.

Lösung

Stellen Sie sicher, dass der Private Link-Dienst keine privaten Endpunktverbindungen zugeordnet ist. Bevor Sie den Private Link-Dienst löschen, müssen Sie die privaten Endpunktverbindungen löschen. Weitere Informationen finden Sie unter Azure: Löschen eines privaten Linkdiensts mit einem privaten Endpunkt, der mit dem Dienst verbunden ist?.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.

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