Freigeben über


Azure Container instances shows unexpected memory usage metrics

In diesem Artikel werden Szenarien erläutert, in denen niedrigere als erwartete Speicherauslastungswerte in Microsoft Azure-Containerinstanzen angezeigt werden, wenn Sie die Werte in der Azure-Portal überprüfen.

Symptome

Wenn Sie die Speicherauslastungsmetrik einer Containergruppe mit mehreren Containern im Azure-Portal überprüfen, werden in der Metrik Werte angezeigt, die niedriger sind als die Werte, die angezeigt werden, wenn Sie den Befehl "Free-h" ausführen, während Sie eine Verbindung mit dem Hauptcontainer herstellen.

Ursache

Die Metrik für die Speicherauslastung in der Azure-Portal zeigt einen Mittelwert für alle Container an, die sich in der Containergruppe befinden. Die Speicherauslastung wird nicht nur für einen bestimmten Container angezeigt. Diese Metrik wird mithilfe eines Standardzeitintervalls von einer Minute berechnet. Die Durchschnittlichkeit mehrerer Container kann dazu führen, dass sich die in der Azure-Portal angezeigte Speicherauslastung geringfügig von der Verwendung unterscheidet, die in der Ausgabe des free Befehls angezeigt wird.

Werte für Aggregationstypen (z. B. Mittelwert, Minimum und Maximum) sind nur als Mittelwert für alle Container in der Containergruppe verfügbar. Diese Statistiken sind für einen einzelnen Container innerhalb einer Containergruppe mit vielen Containern nicht verfügbar. Weitere Informationen finden Sie unter "Unterstützte Metriken pro Ressourcentyp" in Azure Monitor.

Lösung

Sie können einen Dimensionsfilter hinzufügen, um Metriken pro Container anzuzeigen, wenn Ihre Containergruppe mehrere Container enthält. Weitere Informationen finden Sie unter Get metrics in the Azure-Portal when monitoring container resources in Azure Container Instances.

Verweis

Informationen zum Haftungsausschluss von Drittanbietern

Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.