Vorgänge können nicht durchgeführt werden, oder die Containergruppe befindet sich in einem ungültigen Status.
In diesem Artikel wird erläutert, wie Sie ein Szenario in Microsoft Azure-Containerinstanzen auflösen, in denen Containergruppenvorgänge nicht durchgeführt werden können oder die Containergruppe in einem ungültigen Zustand ist.
Symptome
Es treten mindestens eine der folgenden Probleme auf:
Sie versuchen, eine Containergruppe zu löschen, aber der Versuch verursacht einen internen Serverfehler.
Sie versuchen, den Befehl "az container show" in Azure CLI auszuführen, der Befehl schlägt jedoch aufgrund eines internen Serverfehlers fehl.
In der Azure-Portal können Sie die Containergruppenressource anzeigen, jedoch keine Vorgänge ausführen.
Die Containergruppe verbleibt in einem ungültigen Zustand (z . B. "Beendet" oder "Fehlgeschlagen").
Ursache
Die verwaltete Identität der Containergruppe wurde gelöscht, bevor versucht wurde, die zugeordnete Containergruppe zu löschen. Dieses Szenario kann auftreten, wenn Sie versuchen, diese Reihenfolge der Löschungen manuell zu erledigen. Es kann auch auftreten, wenn Sie über ein regelmäßig geplantes Skript (z. B. ein nachts ausgeführtes Skript) verfügen, das alle Ressourcen innerhalb einer Entwicklungsressourcengruppe löscht, einschließlich aller verwalteten Identitäten und Containergruppen. Das Skript löscht die Ressourcen nicht in der richtigen Reihenfolge: Zuerst wird die verwaltete Identität gelöscht, die zum Authentifizieren der Containergruppe erforderlich ist, und dann versucht es, die Containergruppe selbst zu löschen.
Lösung 1: Löschen der Containergruppe vor dem Löschen der verwalteten Identität
Löschen Sie zuerst die Containergruppe, warten Sie, bis der Löschvorgang abgeschlossen ist, und löschen Sie dann die verwaltete Identität.
Lösung 2: Öffnen sie ein Supportticket, um die Containergruppen aus einem ungültigen Zustand zu erhalten.
Wenn Containergruppen vorhanden sind, die in einem ungültigen Zustand verbleiben, da Sie zuerst die verwalteten Identitäten gelöscht haben, die für die Containergruppenauthentifizierung erforderlich sind, öffnen Sie ein Supportticket. Microsoft-Support können die betroffenen Containergruppen beenden und Ihnen dabei helfen, die anderen erforderlichen Schritte zu durchlaufen, um die Einrichtung der Containergruppe zu beheben.
Weitere Informationen
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.