Fehler "ServiceUnavailable (409) – Angeforderte Ressource ist am Standort nicht verfügbar"
In diesem Artikel wird erläutert, wie Sie den ServiceUnavailable -Fehler (409) beheben ("Die angeforderte Ressource ist derzeit nicht verfügbar" "<Regionname>" "), die auftritt, wenn Sie versuchen, eine Ressource in Microsoft Azure-Containerinstanzen bereitzustellen.
Symptome
Sie erhalten eine Fehlermeldung, die dem folgenden Text ähnelt:
Die angeforderte Ressource ist derzeit nicht am Speicherort "usgovvirginia" verfügbar. Versuchen Sie es erneut mit einer anderen Ressourcenanforderung oder an einem anderen Speicherort. Ressource angefordert: '2' CPU '4' ARBEITSSPEICHER 'Linux' virtuelles Netzwerk. ServiceUnavailable (409).
Ursache
Dieses Problem kann auftreten, wenn ein Feature in bestimmten Regionen nicht verfügbar ist oder wenn keine Kapazität vorhanden ist. Dieses Problem ist in der Regel zeitweise.
Lösung
Informationen dazu, ob Sie in einer verfügbaren Region bereitstellen können, finden Sie unter Ressourcenverfügbarkeits- und Kontingentbeschränkungen für Azure-Containerinstanzen.
Um zu ermitteln, welche Features in Ihrer Region verfügbar sind, verwenden Sie die REST-API " Location - List Capabilities ". Sie können auch die verfügbaren Features pro Region überprüfen, indem Sie in diesem Artikel die Schaltfläche "Testen" auswählen.
Wenn Sie in einer verfügbaren Region bereitstellen, und es gibt keine Featurebeschränkung, versuchen Sie die Bereitstellung erneut.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.