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DeploymentFailed - InaccessibleImage-Fehlercode

In diesem Artikel wird erläutert, wie Sie einen Bereitstellungsfehler in Microsoft Azure-Containerinstanzen beheben, die einen Fehlercode "InaccessibleImage" generiert.

Symptome

Wenn Sie versuchen, eine Containerinstanz bereitzustellen, schlägt die Bereitstellung fehl, und Sie erhalten eine Fehlermeldung, die dem folgenden Text ähnelt:

{

"code":"DeploymentFailed",
"message":"Mindestens ein Ressourcenbereitstellungsvorgang ist fehlgeschlagen. Listen Sie die Bereitstellungsvorgänge auf, um Details anzuzeigen. Weitere Informationen finden Sie unter https://aka.ms/DeployOperations Verwendungsdetails.",
"Details":[

{

"code":"InaccessibleImage",
"message":"Auf das Image "<container-registry-name.azurecr.io/<> image-name:<version-name>>" in der Containergruppe "<container-group-name>" kann nicht zugegriffen werden. Bitte überprüfen Sie die Bild- und Registrierungsanmeldeinformationen."

}

]

}

Ursache

Sie versuchen, einen Dienstprinzipal für den Zugriff auf die Azure-Containerregistrierung zu verwenden. Dieses Szenario kann aus einem der folgenden Gründe auftreten:

  • Beim Versuch, die Containerinstanz zu erstellen, haben Sie falsche Anmeldeinformationen angegeben.

  • Sie haben die richtigen Anmeldeinformationen angegeben, aber die Dienstaufrufe für Containerinstanzen werden durch Firewallregeln in der Azure-Containerregistrierung blockiert.

Lösung

Sie müssen eine verwaltete Identität verwenden, damit der vertrauenswürdige Containerinstanzdienst auf die Containerregistrierung zugreifen kann. Weitere Informationen finden Sie unter Zulassen des sicheren Zugriffs vertrauenswürdiger Dienste auf eine Containerregistrierung mit Netzwerkeinschränkungen. Weitere Informationen finden Sie auch unter Bereitstellen von Azure-Containerinstanzen aus der Azure-Containerregistrierung mithilfe einer verwalteten Identität.

References

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.