Die Bereitstellung der Containergruppe bleibt im Wartezustand.
In diesem Artikel wird erläutert, wie Sie ein Szenario in Microsoft Azure-Containerinstanzen auflösen, in denen eine Containergruppe nicht reagiert und den Status "Warten" nicht beendet.
Symptome
Wenn Sie versuchen, ein Image über ein virtuelles Netzwerk in einer privaten Containerinstanz bereitzustellen, bricht die Bereitstellung nach 30 Minuten aus und schlägt fehl. Darüber hinaus wird der Bereitstellungsstatus der Containergruppe als Warten im Azure-Portal angezeigt.
Ursache
Ihre Firewall blockiert den Zugriff auf Port 19390. Wenn Containergruppen in virtuellen Netzwerken bereitgestellt werden, ist Port 19390 erforderlich, um über die Azure-Portal eine Verbindung mit Containerinstanzen herzustellen.
Lösung
Erweitern Sie den CiDR-Adressbereich (Classless Inter-Domain Routing) des Subnetzs, indem Sie eine Netzwerkmaske von /24
oder kleiner angeben.
Notiz
Es wird nicht empfohlen, kleine Subnetze zu verwenden, um nicht unterstützte Szenarien zu umgehen (z. B. das Simulieren einer festen IP-Adresse für eine private Containerinstanz durch Einschränken von DHCP auf nur wenige IPs).
Weitere Informationen
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.