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Ein Fehler wird in einem Verzeichnissynchronisierungsbericht angezeigt: Dieses Unternehmen hat die Anzahl der Objekte überschritten, die synchronisiert werden können.

In diesem Artikel wird beschrieben, wie Sie das Active Directory-Verzeichnisdienstkontingent für die Verzeichnissynchronisierung in einer Office 365-, Azure- oder Microsoft Intune-Umgebung erhöhen.

Ursprüngliche Produktversion: Cloud Services (Webrollen/Workerrollen), Microsoft Entra ID, Microsoft Intune, Azure Backup, Office 365-Benutzer- und Domänenverwaltung
Ursprüngliche KB-Nummer: 2812409

Symptome

Sie erhalten eine E-Mail-Nachricht von MSOnlineServicesTeam@MicrosoftOnline.com mit folgender Fehlermeldung:

Fehler 016: Die Synchronisierung wurde beendet. This company has exceeded the number of objects that can be synchronized. Contact Microsoft Online Services Support.“ (Die Synchronisierung wurde beendet. Dieses Unternehmen hat die Anzahl synchronisierbarer Objekte überschritten. Wenden Sie sich an den Support für Microsoft Online Services.)

Notiz

Dieser Artikel kann auch verwendet werden, wenn Sie nur anfordern möchten, das Verzeichnisdienstkontingent zu erhöhen, falls Sie planen, mehr als die zulässige Anzahl von Objekten in einem Microsoft-Clouddienst wie Office 365, Azure oder Microsoft Intune zu haben, und Sie nicht die Active Directory-Synchronisierung verwenden. Das aktuelle Verzeichnisdienstkontingent in der Microsoft Entra-ID beträgt 50.000 Objekte.

Ursache

Dieses Problem tritt auf, da die Anzahl der Objekte, die Sie in Ihrer Microsoft Entra-ID erstellt haben, Ihren Verzeichnisdienstgrenzwert überschreiten. Microsoft Entra ID beschränkt die Anzahl von Objekten, die von einer Organisation erstellt werden können. Gruppen-, Kontakt- und Benutzerobjekte in Ihrer Microsoft Entra-Organisation zählen zur Verzeichnisnutzung Ihrer Organisation.

Ihr Standardkontingent für den Verzeichnisdienst wird auf der Grundlage folgender Richtlinien berechnet:

  • Wenn Sie über keine überprüften Domänen verfügen, beträgt das aktuelle Verzeichnisdienstkontingent in der Microsoft Entra-ID 50.000 Objekte.

    1. Wenn Ihre Organisation vor dem 5. Oktober 2011 erstellt wurde, beträgt Ihr Standardverzeichnisdienstkontingent 10.000 Objekte.
    2. Wenn Ihre Organisation nach dem 5. Oktober 2011 und vor Mai 2012 erstellt wurde, beträgt Ihr Standardverzeichnisdienstkontingent 20.000 Objekte.
    3. Wenn Ihre Organisation nach Mai 2012 erstellt wurde, beträgt Ihr Standardverzeichnisdienstkontingent 50.000 Objekte.
  • Wenn Sie über mindestens eine überprüfte Domäne verfügen, beträgt das Standardverzeichnisdienstkontingent in der Microsoft Entra-ID 300.000 Objekte.

Lösung

Wenn die Anzahl von Gruppen-, Kontakt- und Benutzerobjekten in Ihrer lokalen Active Directory-Instanz Ihr Kontingent für den Verzeichnisdienst übersteigt, können Sie für Ihr Unternehmen eine Erhöhung des Verzeichnisdienstkontingents anfordern. Dadurch können Sie bei Verwendung der Verzeichnissynchronisierung mehr Objekte synchronisieren als mit dem aktuellen Standardgrenzwert.

Wenn Sie in Ihrer Organisation weitere Objekte erstellen möchten, müssen Sie entweder eine Domäne hinzufügen oder eine Erhöhung Ihres Verzeichnisdienstkontingents anfordern. Verwenden Sie hierzu die folgenden Methoden:

Methode 1

Wenn Sie nicht über eine überprüfte Domäne verfügen, müssen Sie eine Domäne hinzufügen, um Ihr Kontingentlimit auf 300.000 Objekte zu erhöhen. Weitere Informationen finden Sie unter Hinzufügen Ihrer Domäne.

Methode 2

Wenn Sie mehr als 300.000 Objekte in Ihrem lokales Active Directory Verzeichnisdienst haben, wenden Sie sich an Microsoft-Support, um die Anzahl der Objekte zu erhöhen, die über 300.000 synchronisiert werden können.

Weitere Informationen

Zur Implementierung eines Verzeichnisdienstkontingents wird mithilfe des Clouddiensts die maximale Anzahl von Objekten begrenzt, die ein einzelner Sicherheitsprinzipal erstellen und besitzen kann. Bei allen Objekten, die mittels Verzeichnissynchronisierung mit einem Unternehmen synchronisiert werden, wird der Ersteller-/Besitzerwert auf die Standardadministratorgruppe für das Unternehmen festgelegt. Die Gruppe "Administratoren" wird z. B. wie folgt festgelegt: admins@contoso1.microsoftonline.com Diese Konfiguration sorgt dafür, dass Benutzer mit der Verzeichnissynchronisierung keine unbegrenzte Anzahl von Objekten erstellen können. Wenn der Synchronisierungsbedarf eines Unternehmens aus nachvollziehbaren Gründen die Kontingentgrenze des Verzeichnisdiensts übersteigt, kann das Unternehmen einen Service Request an den technischen Support senden.

Häufig gestellte Fragen

Frage 1: Zählen Objekte, die manuell über das Clouddienstportal oder über die Clouddienst-API hinzugefügt wurden, z. B. Exchange Online PowerShell, mit meinem Online-Unternehmenskontingent?

Antwort 1: Ja.

Frage 2: Zählen gelöschte Objekte mit meinem Online-Unternehmenskontingent?

Antwort 2: Ja. Wenn ein Clouddienstkunde ein Objekt aus einem Onlineunternehmen löscht, wird das gelöschte Objekt im Verzeichnisdienst in einem Container für gelöschte Objekte platziert. Das Objekt verbleibt bis zum Ablauf der Tombstonelebensdauer in dem Container für gelöschte Objekte. Der Ablauf ist aktuell auf 30 Tage festgelegt.

Ein Beispiel: Ein Onlineunternehmen evaluiert einen Clouddienst im Rahmen einer produktionsfremden lokalen Active Directory-Umgebung. Die Clouddienstorganisation wurde vor dem 5. Oktober 2011 erstellt, und der Standardgrenzwert für die Synchronisierung liegt bei 10.000 Objekten. Das Unternehmen führt mithilfe des Directory Sync-Tools eine Massensynchronisierung von 8.000 Gruppen- und Kontaktobjekten durch. Später führt das Onlineunternehmen folgende Schritte aus:

  1. Löschen Sie diese Gruppenobjekte und Kontaktobjekte aus der lokalen Active Directory DS-Umgebung des Unternehmens.
  2. Fügen Sie ihrer lokalen Active Directory DS-Umgebung 8.000 Benutzerobjekte hinzu.
  3. Synchronisieren Sie die Updates mit ihrem Onlineunternehmen.

Die 8.000 Gruppen- und Kontaktobjekte werden im Verzeichnisdienst in den Container für gelöschte Objekte verschoben. Diese Objekte beanspruchen weiterhin bis zu 25 Prozent des Kontingents des Onlineunternehmens, bis sie nach Ablauf des 30-tägigen Tombstonezeitraums endgültig entfernt werden. (Dieser Prozentsatz entspricht 2.000 Objekten oder 8.000 × 25 Prozent.) Nach der Synchronisierung der 5.000 neuen Benutzerobjekte beansprucht das Onlineunternehmen somit 10.000 Objekte seines verfügbaren Active Directory-Kontingents: 2.000 durch die gelöschten Objekte und 8.000 durch die neuen Benutzerobjekte. Während des 30-tägigen Tombstonezeitraums (der sich ggf. mit dem Evaluierungszeitraum des Onlineunternehmens überschneidet), kann das Onlineunternehmen mithilfe der Verzeichnissynchronisierung möglicherweise keine weiteren Objekte hinzufügen. Das liegt daran, dass das Verzeichnisdienstkontingent des Onlineunternehmens erreicht wurde.

In diesem Szenario muss das Onlineunternehmen, das den Clouddienst evaluiert, die Anzahl von Objekten in der produktionsfremden lokalen Active Directory DS-Umgebung verringern, um die Produktevaluierung abzuschließen. Falls das Onlineunternehmen die Anzahl von Objekten nicht verringern kann, muss es eine Erhöhung des Verzeichnisdienstkontingents anfordern.

Frage 3: Bedeutet das Vorhandensein von mehr als einer überprüften Domäne, dass ich ein Kontingent haben kann, das höher als 300.000 Objekte ist?

Antwort 3: Nein. Ihnen steht ein Verzeichniskontingent von 300.000 Objekten zur Verfügung, wenn Sie über mindestens eine überprüfte Domäne verfügen. Sie erhalten kein Kontingent von 300.000 Objekten für jede überprüfte Domäne, die Sie registrieren.

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