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Beheben eines Konflikts zwischen Websitebenutzer-ID in SharePoint oder OneDrive

Symptome

Wenn Benutzer in Ihrer Organisation versuchen, mithilfe eines neuen Kontos, das einen Benutzernamen mit einem vorherigen Konto freigibt, auf eine OneDrive- oder SharePoint-Website zuzugreifen, treten bei Benutzern mindestens eines der folgenden Probleme auf:

  • Fehlermeldung "Zugriff verweigert"
  • Eine inkonsistente Benutzeroberfläche
  • Eine neue OneDrive-Website, die ein Suffix an die erwartete URL angefügt hat, z https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1 . B. (das Suffix kann eine Zahl oder eine GUID sein)

Ursache

Diese Probleme treten in der Regel auf, wenn ein Benutzerkonto aus dem Microsoft 365 Admin Center gelöscht wird, und dann wird ein neues Konto mithilfe des Benutzerprinzipalnamens (USER Principal Name, UPN) erstellt, der vom gelöschten Konto verwendet wurde. Dem neuen Konto wird ein neuer ID-Wert zugewiesen, obwohl der UPN identisch ist. Die UserInfo-Liste für die SharePoint- und OneDrive-Websites, die dem Konto zugeordnet sind, weist jedoch nur die alte ID auf. Wenn Benutzer versuchen, mithilfe ihres neuen Kontos auf eine SharePoint-Website oder ihre OneDrive-Website zuzugreifen, stimmt ihre neue ID nicht mit der ID überein, die sich in der Liste "UserInfo" befindet. Daher wird ihnen der Zugriff auf die Website verweigert.

Diese Probleme können auch während der Verzeichnissynchronisierung zwischen einer Active Directory-Organisationseinheit (OU) und SharePoint auftreten. Wenn Sich Benutzer bereits bei SharePoint angemeldet haben und später in eine andere ORGANISATIONSeinheit verschoben werden, treten diese Probleme möglicherweise auf, wenn die OU mit SharePoint synchronisiert wird.

Lösung

Um diese Probleme zu beheben, führen Sie die Diagnose "Websitebenutzerkonflikt" mithilfe eines SharePoint-Administratorkontos aus.

Notiz

  • Diese Diagnose ist für die Umgebungen GCC High und DoD sowie für „Microsoft 365 operated by 21Vianet“, nicht verfügbar.
  • Bevor Administratoren die Diagnose ausführen, um die Probleme für OneDrive-Websites zu beheben, müssen sie sicherstellen, dass der Benutzername des neuen Benutzerkontos mit dem alten Konto übereinstimmt. Administratoren dürfen keine OneDrive-Websites verbinden, die zuvor einem anderen Benutzerkonto gehören. 
  • Wenn das Diagnoseproblem erfolgreich behoben wurde, das sich auf eine OneDrive-Website bezieht, können die Änderungen ca. 24 Stunden dauern. Dieser Zeitraum umfasst das Aktualisieren der OneDrive-Kachel, um auf die richtige Website zu verweisen und alle weiteren OneDrive-Websites wiederzuverwerten.

Wählen Sie die folgende Schaltfläche "Tests ausführen" aus, um die Diagnose im Microsoft 365 Admin Center aufzufüllen. Die Diagnose führt eine große Palette von Überprüfungen für interne Benutzer und Gäste durch, die versuchen, auf SharePoint- und OneDrive-Websites zuzugreifen.

Geben Sie bei entsprechender Aufforderung die folgenden Informationen ein:

  • Das betroffene Benutzerkonto, z. B. UserA@contoso.com
  • Die url der ursprünglichen Website, z. B. https://contoso-my.sharepoint.com/personal/UserA_Contoso_com

Führen Sie die folgenden Schritte aus, um die ursprüngliche OneDrive-Website-URL abzurufen:

  1. Melden Sie sich mit einem Administratorkonto bei der OneDrive-Website an.
  2. Wählen Sie in der oberen rechten Ecke das Symbol "Einstellungen (Zahnrad)" aus.
  3. Wählen Sie "OneDrive-Einstellungen" und dann "Weitere Einstellungen" aus.
  4. Kopieren Sie im Abschnitt "Diagnoseinformationen " die OneDrive-Web-URL.

Verwenden Sie zum Abrufen mehrerer OneDrive-URLs eine der Methoden in oneDrive-URLs für Benutzer in Ihrer Organisation.

Gängige Szenarios

Die Diagnose des Websitebenutzerkonflikts kann die folgenden häufig auftretenden Probleme beheben, die auftreten können, wenn ein neues Konto mithilfe des UPN erstellt wird, das von einem gelöschten Konto verwendet wurde.

Ein Benutzer wird an eine neue OneDrive-Website weitergeleitet, die ein Suffix an die erwartete URL angefügt hat.

Wenn ein neues Benutzerkonto erstellt wird, wird ihm eine neue OneDrive-Website zugewiesen. Wenn ein Benutzerkonto gelöscht wird, wird die dem Konto zugewiesene OneDrive-Website sofort nicht gelöscht. Wenn also mithilfe des UPN eines gelöschten Kontos ein neues Benutzerkonto erstellt wird, weist die neue OneDrive-Website, die dem neuen Konto zugewiesen ist, dieselbe URL wie die alte OneDrive-Website zusammen mit einem hinzugefügten Suffix auf. Dieses Suffix ist entweder eine Zahl oder eine GUID.

Wenn Das neue Benutzerkonto dieselbe OneDrive-Website verwenden soll, die dem alten Konto zugewiesen wurde, überprüft die Diagnose, ob dem Benutzer der Besitz der ursprünglichen Website zugewiesen werden kann. Nachdem die Berechtigungen des Benutzers erfolgreich überprüft wurden, bietet die Diagnose an, den Benutzer erneut mit seiner ursprünglichen Website zu verbinden und die neue aktive Website wiederzuverwenden, die das Suffix hat, z https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1. B. .

Wenn Sie zu einem späteren Zeitpunkt auf Inhalte auf der neuen OneDrive-Website zugreifen müssen, können Sie das gelöschte OneDrive wiederherstellen.

Zugriff verweigert auf eine OneDrive-Website

Wenn ein Benutzer den Zugriff auf seine alte OneDrive-Website verweigert, nachdem ein neues Konto für sie erstellt wurde, konfiguriert die Diagnose das Profil des Benutzers neu. Anschließend wird der Benutzer erneut mit seiner alten OneDrive-Website verbunden, um das Zugriffsproblem zu beheben.

Notiz

Administratoren können dieses Problem nicht beheben, indem sie die Besitzer der OneDrive-Website manuell aktualisieren oder die Benutzerprofileigenschaften bearbeiten, die der OneDrive-Website zugeordnet sind. Die Diagnose ist die einzige empfohlene Lösung, um dieses Problem zu beheben.

Nichtübereinstimmung der Benutzer-ID auf SharePoint-Websites oder OneDrive-Websites, die nicht zum Benutzer gehören

Wenn die Diagnose eine Benutzer-ID in der UserInfo-Liste erkennt, wird die alte ID entfernt. Nachdem Sie das Angebot angenommen und die alte ID entfernt wurde, weisen Sie dem neuen Benutzerkonto die entsprechenden Berechtigungen für die SharePoint-Website zu.

Hinweis: Wenn Sie dieses Problem manuell beheben möchten, müssen Sie das alte Benutzerkonto aus der UserInfo-Liste entfernen und dann Berechtigungen für das neue Benutzerkonto erteilen.

Weitere Informationen

Weitere Informationen zu Zugriffsproblemen in SharePoint und OneDrive finden Sie unter "Zugriff verweigert" oder "Sie benötigen Berechtigungsfehler" in SharePoint Online und OneDrive.