Zusätzliche Anmeldeinformationen beim Öffnen von Office-Dokumenten von einem Webserver durch permanente Cookies
Dieser Artikel wurde von Alan Umanos, Support Engineer, geschrieben.
Symptome
Betrachten Sie dazu die folgenden Szenarien:
Szenario 1
Ein Benutzer navige zu einer SharePoint- oder anderen Website mithilfe eines Nicht-Internet-Explorer-Browsers, gibt seine Anmeldeinformationen für die formularbasierte Authentifizierung (FBA) ein und aktiviert das Kontrollkästchen, um seine Kontoinformationen zu speichern. Dadurch wird ein persistentes Cookie erstellt. Sie klicken weiterhin auf einen Link, um ein Office-Dokument zu öffnen, wodurch erneut eine Aufforderung zur Eingabe ihrer Anmeldeinformationen generiert wird.
Wenn der Benutzer zu einem Internet Explorer Browser wechselt, erhält er die zusätzliche Aufforderung nicht.
Szenario 2
Ein Benutzer navihiert zu einer SharePoint- oder anderen Website, indem er internet Explorer zum Durchsuchen verwendet. Dieser Benutzer gibt seine Anmeldeinformationen in das Formular ein und klickt weiterhin auf einen Link, um ein Office-Dokument zu öffnen. Sie erhalten eine weitere FBA-Anforderung für Anmeldeinformationen.
Wenn sie dann die URL der Website entweder in die Zone "Lokales Intranet" oder in die Zone "Vertrauenswürdige Website" einfügen, erhalten sie nicht die zusätzliche Aufforderung für Anmeldeinformationen.
Ursache
Für Szenario 1 besteht der Grund für die Herausforderung im Nicht-Internet-Explorer-Browser darin, dass Office, wenn die persistente angefordert wird, diese aus der Cookie-JAR-Datei von IE abgerufen wird. Andere Browser schreiben ihre Cookies nicht auf die gleiche Weise oder an denselben Ort. Daher kann Office diese Cookies nicht abrufen.
Für Szenario 2 ist der Grund für die Herausforderung der geschützte Modus von Internet Explorer. Wenn die URL auf eine Internet-Explorer Zone festgelegt ist, in der der geschützte Modus festgelegt ist, wird das Cookie von Internet Explorer nicht für andere Anwendungen wie Office freigegeben.
Lösung
Für Szenario 1 besteht die Problemumgehung entweder darin, internet Explorer zu verwenden, um zu nutzen, dass Office das persistente Cookie abrufen kann, oder (bei Browsern, die nicht im Internet Explorer sind) muss sich der Benutzer beim Öffnen von Office-Dokumenten erneut anmelden.
Für Szenario 2 besteht die Problemumgehung darin, das Kontrollkästchen für den geschützten Modus zu entfernen oder die URL der Website in eine Zone zu verschieben, in der sie nicht festgelegt ist.