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Outlook-Leistungsprobleme in einer OST- oder PST-Datei im Exchange-Cachemodus

Ursprüngliche KB-Nummer: 2768656

Symptome

In Microsoft Outlook treten Symptome wie die folgenden auf:

  • Wenn Sie den Exchange-Cachemodus oder eine Outlook-Datendatei (PST) verwenden, stellen Sie eine Leistungseinbuße fest, wenn Sie bestimmte Aktionen ausführen.
  • Wenn die Outlook-Ordner Posteingang, Kalender, Aufgaben, Gesendete Elemente oder Gelöschte Elemente viele Elemente enthalten, tritt eine leistungsschwächte Leistung auf.
  • Die Kalenderleistung ist inkonsistent. Beispielsweise werden Besprechungsupdates möglicherweise nicht im primären, freigegebenen oder delegierten Kalender widergespiegelt.
  • Es dauert lange, bis Ordner angezeigt werden, oder sie werden nicht richtig angezeigt.
  • Wenn Ihr Outlook-Profil freigegebene Postfächer enthält und die Zwischenspeicherung aktiviert ist (Freigegebene Ordner herunterladen ist ausgewählt), treten Probleme bei der Ordnersynchronisierung, leistungseinbußen oder andere Probleme auf, wenn die Anzahl der freigegebenen Ordner pro Postfach 500 überschreitet. Weitere Informationen finden Sie unter Leistungs- und Synchronisierungsprobleme beim Arbeiten mit Ordnern in einem sekundären Postfach in Outlook. Darüber hinaus werden Fehler im Ordner "Synchronisierungsprobleme" und "9646"-Ereignisse im Anwendungsprotokoll protokolliert.
  • In Extremfällen, in denen mehr als 10.000 Ordner vorhanden sind, ist Outlook sehr langsam geöffnet. Dieses Verhalten tritt aufgrund der Zeit auf, die zum Aufzählen der großen Anzahl von Ordnern erforderlich ist.

Ursache

Diese Probleme können auftreten, wenn ein Postfach viele Ordner enthält oder viele Elemente in einem Ordner vorhanden sind. Es gibt keine feste Beschränkung, wie viele Ordner ein Postfach enthalten kann oder wie viele Elemente ein Ordner enthalten kann. Die Leistung kann jedoch beeinträchtigt werden, wenn sich die Anzahl der Elemente 10.000 Kalenderelemente, 10.000 Ordner oder 100.000 E-Mail-Elemente pro Ordner nähert. Eine große Anzahl von besprechungsserien oder langlebigen besprechungsserien kann auch einen übertriebenen Einfluss auf die Leistung haben.

Lösung

Verwenden Sie die folgenden Lösungen, um Leistungsprobleme zu beheben, die sich auf Ihre Kalender-, E-Mail- oder freigegebenen Ordner auswirken.

Lösungen für Kalenderprobleme

Um Leistungsprobleme zu beheben, die sich auf Ihren Kalender auswirken, probieren Sie die folgenden Methoden aus.

Methode 1: Verwalten der Zunahme von Ausnahmen für besprechungsserien

Nicht alle Kalenderelemente haben die gleiche Auswirkung auf die Leistung. Einmalige Besprechungen haben einen relativ geringen Effekt, und langlebige, wiederkehrende Besprechungen haben eine größere Wirkung. Eine Änderung, die in einer instance einer Besprechungsserie vorgenommen wird, führt zu Ausnahmen, die in der Besprechungsserie gespeichert sind. Jede Änderung der Besprechungsattribute, z. B. Betreff, Text, Ort oder Uhrzeit, erzeugt eine entsprechende Ausnahme. Schließlich erhöhen diese Ausnahmen die Größe der Besprechungsserie und verursachen höhere Leistungskosten. Sie können diese höheren Kosten verringern, indem Sie die Terminserieneinstellungen verwenden, um eine Endzeit oder eine maximale Wiederholungsanzahl festzulegen. Anschließend können Sie eine neue Besprechungsserie erstellen, anstatt die vorhandene Wiederholung zu erweitern.

Methode 2: Aktivieren von Verbesserungen für freigegebene Kalender

Verwenden Sie die Option Verbesserungen für freigegebene Kalender aktivieren für Benutzer, die über Bearbeitungsberechtigungen für einen freigegebenen Kalender verfügen, um die Leistung zu verbessern. Wenn Sie diese Option aktivieren, werden Kalenderaktionen direkt an den Server gesendet, anstatt aus dem lokalen Speicher synchronisiert zu werden. Dadurch wird die Konfliktlösung effizienter.

Weitere Informationen zum Aktivieren und Verwalten der Verbesserungen des freigegebenen Kalenders finden Sie unter Aktivieren und Deaktivieren der Outlook-Kalenderfreigabeupdates.

Methode 3: Einschränken des Synchronisierungsfensters

Sie können das für Kalenderordner verwendete Synchronisierungsfenster einschränken, um die Anzahl der lokal in Ihren Kalenderordnern gespeicherten Elemente zu reduzieren. Dies kann die Leistung verbessern.

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Sichern Sie die Registrierung, bevor Sie sie ändern, damit Sie sie bei Bedarf wiederherstellen können.

Passen Sie unter Einstellungen für Synchronisierungsfenster die Anzahl der Monate an Daten an, die für die primären freigegebenen Kalender synchronisiert werden. Fügen Sie dazu die folgenden Registrierungsschlüssel hinzu:

Hinweis: Diese Methode gilt für Version 1810 oder eine höhere Version von Microsoft 365 Apps for Enterprise (Klick-und-Run).

Beschreibung Einstellung zum Aktivieren des Kalendersynchronisierungsfensters
Registrierungspfad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name CalendarSyncWindowSetting
Typ REG_DWORD
Wert Wert = 0: inaktiv
Wert = 1: primärer Kalenderordner
Wert = 2: alle Kalenderordner
Der Standardwert ist 0, wenn nicht festgelegt.
Beschreibung Einstellung zum Steuern der Anzahl der Monate im Kalendersynchronisierungsfenster
Registrierungspfad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name CalendarSyncWindowSettingMonths
Typ REG_DWORD
Wert Wert = Wählen Sie einen Dezimalwert aus, um die Anzahl der Monate im Kalendersynchronisierungsfenster festzulegen. Wählen Sie beispielsweise 1, 3, 6 oder 12 aus.
Der Standardwert ist 6, wenn nicht festgelegt.
Beschreibung Einstellung zum Steuern, ob alle wiederkehrenden Elemente beibehalten werden sollen, anstatt sie zu filtern
Registrierungspfad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name CalendarSyncWindowAllRecurring
Typ REG_DWORD
Wert Wert = 0: Es werden nur besprechungsserien synchronisiert, die ein Enddatum aufweisen, das entweder in der Zukunft liegt oder in die Einstellung des aktuellen Kalendersynchronisierungsfensters fällt.
Wert = 1: Alle Besprechungsserien werden unabhängig vom Enddatum synchronisiert.
Der Standardwert ist 0, wenn nicht festgelegt.
Erklärung Standardmäßig (wenn der Wert nicht festgelegt ist oder auf 0 festgelegt ist), werden wiederkehrende Besprechungsserien mit einem Enddatum synchronisiert, das entweder in der Zukunft liegt oder in die Einstellung des aktuellen Kalendersynchronisierungsfensters fällt. Wenn beispielsweise das heutige Datum der 3. Mai 2022 ist und das Kalendersynchronisierungsfenster auf 1 Monat festgelegt ist, werden alle wiederkehrenden Besprechungsserien synchronisiert, die ein Enddatum am oder nach dem 3. April 2022 haben. Wenn das Enddatum außerhalb der Einstellung des Synchronisierungsfensters liegt, wird die Besprechungsserie aus der OST-Datei entfernt.
Um alle wiederkehrenden Besprechungsserien unabhängig vom Enddatum zu synchronisieren, legen Sie den Wert von CalendarSyncWindowAllRecurring auf 1 fest.

Diese Registrierungsschlüssel aktualisieren die Synchronisierungseinschränkung, sodass der Client, der den Exchange-Cachemodus verwendet, weniger Kalenderelemente herunterlädt, selbst für einen Kalender, der mehrere Jahre verlauf auf dem Server hat. Diese Schlüssel bereinigen keine älteren Kalenderinhalte, die bereits heruntergeladen wurden. Diese Methode kann jedoch wirksam sein, wenn Sie bereit sind, Offlineelemente zu löschen und Ihren Kalender erneut zu synchronisieren (anstatt alte Elemente in einem Massenvorgang zu löschen). Wenn der Kalender bereits im Profil vorhanden ist, müssen Sie die Offlineelemente löschen, nachdem Sie die Registrierungsschlüssel festgelegt und Outlook neu gestartet haben.

Führen Sie die folgenden Schritte aus, um Offlinekalenderelemente zu löschen:

  1. Öffnen Sie den Kalenderbereich in Outlook, und klicken Sie mit der rechten Maustaste auf den Ordner Kalender .
  2. Wählen Sie Eigenschaften aus.
  3. Klicken Sie auf der Registerkarte Allgemein auf Offline-Elemente löschen.
  4. Wählen Sie OK aus.

Lösungen für E-Mail-Probleme

Wenn Sie über Ordner verfügen, deren Inhalt sich dem Grenzwert von 10.000 Kalenderelementen, 10.000 Ordnern oder 100.000 E-Mail-Elementen nähert und diese Elemente in einer Outlook-Datendatei (PST-Datei) oder einer Outlook-Offlinedatendatei (.ost) gespeichert sind, verschieben Sie Elemente aus den größeren Ordnern in separate oder kleinere Ordner im gleichen Postfach oder derselben Datendatei. Wenn Sie über ein Microsoft Exchange-Onlinearchiv verfügen, können Sie optional Elemente in dieses Archiv verschieben oder Aufbewahrungsrichtlinien erstellen, um ältere Elemente automatisch zu löschen.

Archivieren von E-Mail-Elementen

Wenn Sie „Onlinearchivpostfach“ aktiviert haben, archivieren Sie Elemente in diesem Onlinearchivpostfach.

Anwenden einer Aufbewahrungsrichtlinie

Wenden Sie eine Aufbewahrungsrichtlinie an, um ältere Elemente aus dem E-Mail- oder Kalenderordner zu löschen. Beispielsweise wird jedes Element, das nicht innerhalb eines Jahres geändert wird, in den Ordner Gelöschte Elemente verschoben.

Lösung für Probleme mit freigegebenen Ordnern

Um Leistungsprobleme zu beheben, die sich auf freigegebene Ordner auswirken, probieren Sie die folgende Methode aus.

Einschränken des Synchronisierungsfensters

Um die Anzahl der lokal gespeicherten Elemente zu reduzieren, beschränken Sie das Synchronisierungsfenster, das für freigegebene Ordner verwendet wird. Dies kann die Leistung verbessern.

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Sichern Sie die Registrierung, bevor Sie sie ändern, damit Sie sie bei Bedarf wiederherstellen können.

Fügen Sie die folgenden Registrierungswerte hinzu, um die Anzahl der Tage anzupassen, die für freigegebene Ordner synchronisiert werden.

Beschreibung Einstellung zum Aktivieren des Fensters "Freigegebene Ordner"
Registrierungspfad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name SharedFolderSyncWindowSettingDays
Typ REG_DWORD
Wert Wert = Wählen Sie einen Dezimalwert aus, um die Anzahl der Tage (1 bis 365) für das Synchronisierungsfenster für freigegebene Ordner festzulegen.

Führen Sie den Microsoft Support- und Wiederherstellungs-Assistenten aus.

Hinweis

Microsoft-Support- und Wiederherstellungs-Assistent-Szenarien sind für das neue Outlook für Windows nicht verfügbar.

Sie können Microsoft-Support und den Wiederherstellungs-Assistenten verwenden, um Kalender- und E-Mail-Probleme zu diagnostizieren, die Sich auf Outlook auswirken. Informationen zum Herunterladen und Installieren des Assistenten finden Sie unter Informationen zum Microsoft-Support und Wiederherstellungs-Assistenten.

Um die Ursache der Leistungsprobleme zu ermitteln, starten Sie den Assistenten, und führen Sie die Outlook-Diagnose im Abschnitt Erweiterte Diagnose aus.

Weitere Informationen

Um die Elementanzahl in einem Outlook-Kalender anzuzeigen, wenn Sie den Exchange-Cache-Modus verwenden, verwenden Sie das Dialogfeld Kalendereigenschaften:

  1. Öffnen Sie in Outlook den Bereich Kalender , und klicken Sie dann mit der rechten Maustaste auf den Ordner Kalender .
  2. Wählen Sie Eigenschaften aus.
  3. Wählen Sie auf der Registerkarte Allgemein die Option Gesamtanzahl der Elemente anzeigen aus.
  4. Wählen Sie die Registerkarte Synchronisierung aus.
  5. Zeigen Sie die Anzahl unter Statistiken für diesen Ordner anzeigen an.

Outlook verwendet eine .ost-Datei nur, wenn das Exchange-E-Mail-Konto für die Verwendung des Exchange-Cache-Modus konfiguriert ist. Wenn Outlook für die Verbindung mit dem Exchange-Postfach im Onlinemodus konfiguriert ist, wird keine .ost Datei verwendet.

Wenn Ihr Outlook-Client im Onlinemodus mit Exchange verbunden ist und Sie keine Ordner mit hoher Elementanzahl in einer PST-Datei haben, treten möglicherweise Leistungsprobleme auf dem Server auf. Weitere Informationen finden Sie unter Möglicherweise treten Anwendungspausen auf, wenn Sie über eine große Outlook-Datendatei verfügen.