Benutzer öffentlicher Ordner können Unterordner nicht umbenennen, verschieben oder löschen.
Symptome
Nachdem ein Benutzer einen Unterordner in einem öffentlichen Ordner erstellt hat, kann er den Unterordner nicht umbenennen, verschieben oder löschen.
Ursache
Die Eigenschaft benutzerpostfach EffectivePublicFolderMailbox
gibt nicht das primäre Hierarchiepostfach für öffentliche Ordner für Ihre Microsoft Exchange-organization an.
Ein Exchange-Algorithmus, der Einen Lastenausgleich für Benutzer über alle Postfächer für öffentliche Ordner hinweg erstellt, weist jedem Benutzerpostfach automatisch einen EffectivePublicFolderMailbox
Wert zu.
Wenn der Wert des Benutzerpostfachs EffectivePublicFolderMailbox
das Primäre Hierarchiepostfach für öffentliche Ordner für Ihre Exchange-organization angibt, verfügt der Benutzer über die Berechtigung Besitzer für öffentliche Ordnerunterordner, die er in jedem Postfach für öffentliche Ordner erstellt. Mit der Berechtigung Besitzer können Benutzer diese Unterordner umbenennen, verschieben und löschen.
Wenn der Wert user mailbox EffectivePublicFolderMailbox
ein sekundäres Hierarchiepostfach für öffentliche Ordner angibt, erbt der Benutzer die Berechtigungen des übergeordneten Ordners für öffentliche Ordnerunterordner, die er in einem postfach für öffentliche Ordner erstellt. Das im Abschnitt "Symptome" beschriebene Problem tritt auf, wenn der Benutzer über eine der folgenden Berechtigungen für öffentliche Ordner für den übergeordneten Ordner verfügt:
PublishingEditor: rollenbasierter Berechtigungssatz, der die CreateSubfolders-Berechtigung enthält
PublishingAuthor: rollenbasierter Berechtigungssatz, der die CreateSubfolders-Berechtigung enthält
CreateSubfolders: Erforderlich zum Erstellen eines Unterordners
Problemumgehung
Um das Problem zu umgehen, erteilen Sie dem Benutzer die Berechtigung Besitzer für Unterordner, die er erstellt oder verwalten muss. Verwenden Sie eine der folgenden Methoden.
Hinweis
Um die folgenden Methoden verwenden zu können, müssen Sie über Administratorberechtigungen verfügen.
Methode 1: Verwenden des Exchange Admin Centers
Navigieren Sie im Exchange Admin Center (EAC) zu Öffentliche Ordner>Öffentliche Ordner.
Navigieren Sie zum Unterordner des Benutzers, und wählen Sie dann im rechten Bereich Verwalten aus.
Erteilen Sie dem Benutzer die Berechtigung Besitzer für den Unterordner.
Hinweis
Verwenden Sie abhängig vom Speicherort des öffentlichen Ordners und Ihrer Exchange-Umgebung Exchange Online oder das lokale EAC.
Methode 2: Verwenden des Outlook-Desktopclients
Navigieren Sie im Microsoft Outlook-Desktopclient zum Unterordner des Benutzers, und öffnen Sie dann das Fenster Eigenschaften .
Wählen Sie auf der Registerkarte Berechtigungen die Berechtigungsstufe Besitzer und dann Hinzufügen aus, um den Benutzer anzugeben.
Methode 3: Verwenden von PowerShell
Führen Sie das Cmdlet Add-PublicFolderClientPermission aus, um dem Benutzer die Berechtigung Besitzer für einen Unterordner zu gewähren:
Add-PublicFolderClientPermission -Identity <subfolder ID> -User <user ID> -AccessRights Owner
Hinweis
Abhängig vom Speicherort des öffentlichen Ordners und Ihrer Exchange-Umgebung müssen Sie möglicherweise zuerst Ihre PowerShell-Sitzung mit Exchange Online verbinden. Verwenden Sie für lokale öffentliche Ordner die Exchange-Verwaltungsshell (EMS).
Weitere Informationen
Um die Benutzerberechtigungen für einen öffentlichen Ordner oder Unterordner zu bestimmen, checken Sie im EAC ein, oder führen Sie den folgenden Befehl aus:
Get-PublicFolderClientPermission <folder ID> | FT FolderName,User,AccessRights
Führen Sie den folgenden Befehl aus, um den
EffectivePublicFolderMailbox
Eigenschaftswert für ein Benutzerpostfach zu bestimmen:Get-Mailbox -Identity <user mailbox> | FL Name,EffectivePublicFolderMailbox
Um das Primäre Hierarchiepostfach für öffentliche Ordner für Ihre Exchange-organization zu identifizieren, checken Sie im EAC ein, oder führen Sie den folgenden Befehl aus:
Get-Mailbox -PublicFolder | FT Name,IsRootPublicFolderMailbox