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Problembehandlung für BizTalk Server Administration

Dieser Abschnitt enthält ausführliche Informationen zu Problemen, die beim Arbeiten mit der BizTalk Server-Verwaltungskonsole auftreten können.

Zusätzlich zu den folgenden bekannten Problemen bietet die BizTalk Server-Verwaltungskonsole allgemeine Probleme und Lösungen zusätzliche Informationen.

Bekannte Probleme

Verzögerung im ENTSSO-Dienst verhindert Start des BizTalk Server-Diensts

Problem

Wenn Sie den Computer neu starten, ohne für DTC den automatischen Start festzulegen, dann verhindern Sie möglicherweise, dass der BizTalk Server-Dienst gestartet wird.

Ursache

Der Grund hierfür ist, dass der ENTSSO-Dienst mehr Zeit benötigen kann, als durch die Timeoutdauer des BizTalk Server-Diensts zulässig ist.

Lösung

Legen Sie zur Beseitigung dieses Problems den automatischen Start von DTC fest. Wenn DTC gruppiert ist, sollte er auf manuelles Starten festgelegt werden, da der Clusterdienst das Starten und Beenden von gruppierten Diensten verwaltet.

SQL-Ressourcen werden möglicherweise gesperrt

Problem

Die folgenden Fehler können auftreten:

Die Transaktion (Prozess-ID 95) befand sich auf Sperrressourcen aufgrund eines anderen Prozesses in einer Deadlocksituation und wurde als Deadlockopfer ausgewählt. Führen Sie die Transaktion erneut aus.

Ursache

Dies ist eine sehr seltene Situation, in der von einem Benutzer administrative Vorgänge ausgeführt wurden, die dazu führten, dass ein anderer Benutzer von der Datenbankverwaltung ausgesperrt wurde.

Lösung

Das Problem sollte sich in Kürze selbst abstellen. Wiederholen Sie den Vorgang in ein paar Minuten.

SQL-Datenbank wird möglicherweise gesperrt

Problem

Benutzer werden möglicherweise aus der SQL-Datenbank ausgesperrt. Eine Reihe verschiedener Fehlermeldungen können zurückgegeben werden.

Ursache

In einigen Fällen führt das Schreiben eines Benutzers in die Datenbank dazu, dass ein anderer Benutzer tatsächlich aus der Datenbank ausgesperrt wird.

Lösung

Das Problem sollte sich in Kürze selbst abstellen. Wiederholen Sie den Vorgang in ein paar Minuten.

Fehler beim Beenden mehrerer Dienstinstanzen in einer Umgebung mit mehreren MessageBoxes

Problem

Fehler bei Versuchen, mehrere Dienstinstanzen über die BizTalk Server-Verwaltungskonsole zu beenden, wobei Fehlermeldungen ähnlich den Folgenden angezeigt werden:

SQL Server hat den Zugriff auf Prozedur 'sys.xp_sqlagent_enum_jobs' der Komponente 'Agent XPs' gesperrt, weil diese Komponente im Rahmen der Sicherheitskonfiguration für diesen Server deaktiviert ist.

Hinweis

Dieses Problem tritt in einer Umgebung mit mehreren MessageBoxes auf.

Ursache

Dieses Problem kann in einer Umgebung mit mehreren Messageboxen auftreten, wenn der SQL-Agentauftrag "Operations_OperateOnInstances_OnMaster_<dbName>" nicht in den sekundären Messagebox-Datenbanken ausgeführt wird. Dieser Auftrag muss ausgeführt werden, damit Informationen aus den sekundären MessageBox-Datenbanken in die primäre MessageBox-Datenbank weitergegeben werden. Dieser Auftrag kann nicht ausgeführt werden, wenn er nicht aktiviert ist oder falls ein Anmeldefehler auftritt.

Lösung

Wenn Sie die BizTalk-Verwaltungskonsole zum gleichzeitigen Ausführen von Vorgängen für mehrere Dienstinstanzen verwenden und Ihre BizTalk Server-Umgebung mit mehreren Messagebox-Datenbanken konfiguriert ist, überprüfen Sie, ob der SQL Server-Agent Auftrag mit dem Namen "Operations_OperateOnInstances_OnMaster_<dbName>" für alle sekundären Nachrichtenboxen (nicht master) aktiviert ist. Datenbanken. Zusätzlich muss der SQL Server-Agent-Dienst auf dem SQL Server-Computer, der die sekundären MessageBox-Datenbanken hostet, als Konto ausgeführt werden, das in der Datenbankrolle BTS_SQLAGENT_USER der sekundären MessageBox-Datenbank einbezogen ist.

Hinweis

<Dbname> ist ein Platzhalter für den tatsächlichen Namen der BizTalk-Messagebox-Datenbank.

Befolgen Sie diese Schritte zum Hinzufügen des SQL Server-Agent-Dienstkontos zur BTS_SQLAGENT_USER-Datenbankrolle der sekundären MessageBox-Datenbank.

Unter SQL Server 2008

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft SQL Server 2008, und klicken Sie dann auf SQL Server Management Studio.

  2. Wenn Sie dazu aufgefordert werden, wählen Sie den Servertyp der Datenbank-Engine aus , und geben Sie den Servernamen ein, der die sekundäre Messagebox-Datenbank hostet.

  3. Klicken Sie, um Datenbanken zu erweitern, klicken Sie auf , um die sekundäre Meldungsfelddatenbank zu erweitern, klicken Sie auf Sicherheit, klicken Sie auf Rollen, klicken Sie auf Datenbankrollen, und doppelklicken Sie dann auf die BTS_SQLAGENT_USER Datenbankrolle.

  4. Klicken Sie auf die Schaltfläche Hinzufügen .

  5. Klicken Sie auf Durchsuchen, wählen Sie eine Gruppe aus, der das SQL Server-Agent-Dienstkonto angehört, und klicken Sie dann auf OK.

Hinweis

Wenn das SQL Server-Agent-Dienstkonto kein Mitglied der angegebenen Gruppe ist, dann müssen Sie es zur Gruppe hinzufügen.

Änderungen, die in einer Instanz der BizTalk Server-Verwaltungskonsole angewendet werden, werden nicht automatisch in andere Instanzen der Verwaltungskonsole übernommen.

Problem

Wenn mehrere Instanzen der BizTalk Server-Verwaltungskonsole gleichzeitig mit derselben BizTalk Server-Gruppe verbunden sind, werden Änderungen, die in einer Instanz der BizTalk Server-Verwaltungskonsole vorgenommen werden, nicht automatisch in den anderen Instanzen der Verwaltungskonsole wiedergegeben. Dies kann zu Parallelitätsverletzungsfehlern führen, wenn versucht wird, ein in einer Instanz der BizTalk Server-Verwaltungskonsole angezeigtes Element zu ändern, und der Status dieses Elements nicht mit dem tatsächlichen Status des Elements, wie er in der BizTalk-Verwaltungsdatenbank gespeichert ist, übereinstimmt.

Ursache

Jede Instanz der BizTalk Server-Verwaltungskonsole unterhält einen eigenen Cache der BizTalk-Gruppenkonfiguration und gibt nur die in ihrem Cache vorgenommenen Änderungen wieder. Der Cache wird nur beim Aktualisieren der BizTalk-Verwaltungskonsolenansicht aktualisiert.

Lösung

Wenn in der BizTalk-Verwaltungskonsole Fehler aufgrund von Parallelitätsverletzungen auftreten, aktualisieren Sie den Cache für die instance der BizTalk-Verwaltungskonsole, indem Sie auf der Symbolleiste der BizTalk-Verwaltungskonsole auf die Schaltfläche Aktualisieren klicken oder die Taste F5 drücken.

Beim Versuch, eine Orchestrierung mit der BizTalk-Verwaltungskonsole zu beenden, tritt ein Fehler vom Typ "Fehler beim Ausführen der Aktion 'Beenden'" auf.

Problem

Wenn Sie versuchen, in der BizTalk-Verwaltungskonsole eine Orchestrierung zu beenden, wird eine Fehlermeldung in der folgenden Form generiert:

Failed to execute action 'Stop'.
------------------------------
ADDITIONAL INFORMATION:
A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.) (Microsoft SQL Server, Error: 10054)

Dieses Problem kann auftreten, wenn die folgenden Bedingungen zutreffen:

  • Die BizTalk-Verwaltungskonsole ist geöffnet.

  • Die BizTalk-Verwaltungsdatenbank ist auf einer geclusterten Instanz von SQL Server installiert.

  • Auf der geclusterten Instanz von SQL Server erfolgt ein Failover.

  • Sie versuchen nach Abschluss des Failovers, mit der BizTalk-Verwaltungskonsole eine ausgeführte Instanz einer Orchestrierung zu beenden.

Ursache

Die BizTalk-Verwaltungskonsole verwaltet eine Verbindung mit der BizTalk Server-Verwaltungsdatenbank. Wenn die Verbindung mit BizTalk Server Verwaltungsdatenbank während des Failovers unterbrochen wurde, geben einige Verwaltungsaufgaben möglicherweise den Fehler "Fehler beim Herstellen einer Verbindung" oder "Fehler beim Ausführen" zurück, bis die BizTalk-Verwaltungskonsole geschlossen und erneut geöffnet wurde.

Lösung

Schließen Sie die BizTalk-Verwaltungskonsole, und öffnen Sie sie erneut. Wenn die BizTalk-Verwaltungskonsole erneut geöffnet wird, wird eine neue Verbindung mit der angegebenen BizTalk Server-Verwaltungsdatenbank erstellt.

Zuvor gelöschte Windows-Gruppennamen haben keinen Zugriff auf die BizTalk Server-Datenbank

Problem

Wenn Sie bei der Neuinstallation BizTalk Server einen zuvor gelöschten Windows-Gruppennamen verwenden, hat die Windows-Gruppe keinen Zugriff auf die BizTalk Server Datenbanken.

Ursache

Wenn Sie eine Windows-Gruppe löschen und dann eine Windows-Gruppe mit demselben Namen erstellen, wird für die Windows-Gruppe eine neue Sicherheits-ID (SID) erstellt. Die alte SID wird jedoch weiter in SQL Server zwischengespeichert; daher kann sich die neue Windows-Gruppe nicht bei SQL Server anmelden.

Lösung

Sie müssen beim Löschen der Windows-Gruppe auch die SQL Server-Anmeldung für die Windows-Gruppe entfernen.

Ein BizTalk-Administrator kann die BizTalk Server-Verwaltungskonsole nicht starten

Problem

Ein BizTalk-Administrator (Mitglied der Windows-Gruppe BizTalk-Administratoren) kann die BizTalk Server-Verwaltungskonsole nicht öffnen, wenn dieser Benutzer nicht zur Windows-Administratorengruppe auf dem lokalen Computer gehört.

Ursache

Dieses Problem kann auftreten, wenn BizTalk Server erneut installiert oder neu konfiguriert wurde. Der Grund hierfür ist, dass SQL Server zwischengespeicherte Sicherheits-IDs verwendet hat.

Lösung

Fügen Sie den BizTalk-Administrator vorübergehend der lokalen Windows-Administratorengruppe auf dem lokalen Computer hinzu. Nach dem erfolgreichen Öffnen der BizTalk Server-Verwaltungskonsole entfernen Sie den BizTalk-Administrator dann wieder aus der lokalen Windows-Administratorengruppe auf dem lokalen Computer.

Eine Hostinstanz auf einem Remotecomputer kann nicht gestartet werden

Problem

Wenn Sie eine BizTalk-Host-instance auf einem Remotecomputer erstellen, wird möglicherweise der folgende Fehler angezeigt, wenn Sie den BizTalk-Host instance starten: "Fehler beim Starten aufgrund eines Anmeldefehlers".

Ursache

Dieser Fehler kann auftreten, wenn Sie für das Dienstkonto, unter dem die BizTalk-Hostinstanz ausgeführt wird, ungültige Anmeldeinformationen eingegeben haben oder das Dienstkonto keine Berechtigungen zum Anmelden als Dienst besitzt.

Lösung

Weisen Sie dem Dienstkonto auf dem Remotecomputer die Berechtigung zum Anmelden als Dienst zu, bevor Sie die BizTalk-Hostinstanz starten. Auf einem lokalen Computer erfolgt dies automatisch, auf Remotecomputern muss dieser Vorgang jedoch manuell vorgenommen werden.

Fehler beim Erstellen oder Konfigurieren einer Hostinstanz auf einem X64-Computer bei ausgewählter Option 'Nur 32-Bit'

Problem

In der BizTalk Server-Verwaltungskonsole kann das Erstellen eines BizTalk-Host-instance auf einem X64-Computer mit ausgewählter 32-Bit-Option (Standard) fehlschlagen.

Wenn die BizTalk Server-Laufzeit auf einem X64-Computer mit dem BizTalk Server-Konfigurations-Manager konfiguriert wird, kann durch das Erstellen eines Hosts vom Typ "In-Process" oder eines isolierten Hosts mit ausgewählter Option Nur 32-Bit ein Fehler beim Starten des Diensts auftreten.

Ursache

Unbekannt

Lösung

Dieses Problem tritt zeitweise auf. Versuchen Sie, den Host erneut zu erstellen bzw. zu konfigurieren, oder heben Sie die Auswahl der Option Nur 32-Bit auf.

Beim Löschen einer Hostinstanz werden die Registrierungsinformationen nicht gelöscht

Problem

Wenn Sie kein Administrator auf dem lokalen Computer sind, wird beim Löschen eines Hosts vom Typ In-Process oder Isoliert eine Fehlermeldung mit dem Inhalt "Zugriff verweigert" angezeigt. Sie können das Löschen des Hosts erzwingen. Allerdings werden dabei die zugehörigen Registrierungsinformationen nicht gelöscht.

Ursache

Zum Löschen der Registrierungsinformationen einer Hostinstanz sind Administratorberechtigungen erforderlich.

Lösung

Melden Sie sich als lokaler Administrator an, bevor Sie den Host löschen, damit auch die zugehörigen Registrierungsinformationen entfernt werden.

Eine MessageBox-Datenbank kann nicht gelöscht werden

Problem

Es kann vorkommen, dass Sie eine MessageBox-Datenbank nicht löschen können. Dafür kann es einen der folgenden Gründe geben:

  • Das Cacheaktualisierungsintervall ist noch nicht abgelaufen.

  • Die MessageBox-Datenbank enthält unvollständige Instanzen.

    Wenn das Cacheaktualisierungsintervall noch nicht abgelaufen ist, wird die folgende Fehlermeldung angezeigt, wenn der Löschvorgang fehlschlägt: "MessageBox kann nicht gelöscht werden, da im MessageBox-Element möglicherweise Nocharbeit vorhanden ist. Sie werden daraufhin aufgefordert sicherzustellen, dass keine weiteren unvollständigen Instanzen in der MessageBox enthalten sind, um es dann später erneut zu versuchen.

Ursache

Das Cacheaktualisierungsintervall muss zwischen dem Zeitpunkt, zu dem Sie die Veröffentlichung neuer Nachrichten in der MessageBox-Datenbank deaktivieren, und dem Zeitpunkt ablaufen, zu dem Sie die Datenbank löschen. In der Standardeinstellung beträgt das Cacheaktualisierungsintervall 60 Sekunden.

Lösung

Zum Löschen einer MessageBox-Datenbank müssen Sie zuerst die Veröffentlichung neuer Nachrichten für diese MessageBox-Datenbank deaktivieren und dann warten, bis das Cacheaktualisierungsintervall abgelaufen ist, bevor Sie die MessageBox-Datenbank löschen.

Wenn die MessageBox-Datenbank unvollständige Dienstinstanzen enthält, wird die folgende Fehlermeldung angezeigt: "Das MessageBox-Objekt kann nicht gelöscht werden, da es möglicherweise noch unvollständige Instanzen enthält. Sie werden daraufhin aufgefordert sicherzustellen, dass keine unvollständigen Instanzen in der MessageBox enthalten sind, um es dann später erneut zu versuchen.

Sie können unvollständige Dienstinstanzen in der MessageBox-Datenbank über die Gruppenhubseite in der BizTalk Server-Verwaltungskonsole anzeigen. Informationen zum Anzeigen der status von Dienstinstanzen auf der Seite Group Hub finden Sie unter Suchen nach nachverfolgten Dienstinstanzen.

Weitere Informationen

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