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Problembehandlung bei der Nachrichtenreparatur und der neuen Übermittlung

Eine reparierte Nachricht kann nicht gesendet werden, wenn das Umschlagschema nicht bereitgestellt wird.

Symptom

Wenn Sie versuchen, eine Nachricht zu senden, die Sie repariert haben, veröffentlicht A4SWIFT die folgende Meldung:

"Der Adapter konnte keine Nachricht übertragen, die an port http://mrsrtest:80/StsWebReceive/default.aspx?PartnerId=Unparsed&FolderType=MessagesInboxgesendet wird. Sie wird nach dem für diesen Sendeport angegebenen Wiederholungsintervall erneut übertragen. Details:"80131600". Weitere Informationen finden Sie im Hilfe- und Supportcenter unter https://go.microsoft.com/fwlink/?LinkId=142493.

Mögliche Ursache

Das Umschlagschema wird nicht bereitgestellt. Dies gilt für jede MTxxx-Nachricht oder jede Nachricht, bei der die Analyse fehlgeschlagen ist.

Lösung

Stellen Sie ein Umschlagschema für jedes Nachrichtenschema bereit, das Sie verwenden (<Laufwerk:\Programme\Microsoft BizTalk Accelerator for SWIFT-Version><Message Pack \SWIFT Messages\ A4SWIFT-SRG<version>\Category n\MTxxx.xsd) und für nicht analysierte Umschlagschemas (<Laufwerk>:\Programme\Microsoft BizTalk Accelerator for SWIFT-Version><Message Pack \SWIFT Messages\ A4SWIFT-SRG<version>\ Unparsed Message\EnvelopeUnparsedMessage.xsd>). Weitere Informationen finden Sie unter Bereitstellen von A4SWIFT Schemas.

Sie können keine feste, nicht analysierte Nachricht aus einer MRSR-Websitebibliothek mit dem Namen "Nicht analysiert" senden.

Symptom

Wenn Sie versuchen, eine nicht analysierte Nachricht zu senden, die Sie aus einer MRSR-Websitedokumentbibliothek korrigiert haben, die nicht "Unparsed" heißt, schlägt der Vorgang fehl.

Mögliche Ursache

A4SWIFT kann keine Nachricht aus einer Bibliothek senden, die nicht "Unparsed" heißt. Wenn Sie vor der Installation des MRSR-Features (Nachrichtenreparatur) über eine vorhandene "Nicht analysierte" Dokumentbibliothek verfügen, erstellt A4SWIFT Setup eine Bibliothek für nicht analysierte Nachrichten mit dem Namen "Unparsed" mit einem Suffix. Wenn eine Nachricht empfangen wird, die A4SWIFT nicht analysieren konnte, wird die Nachricht an die erstellte Bibliothek weitergeleitet. Wenn Sie jedoch versuchen, eine Nachricht aus dieser Bibliothek zu senden, schlägt der Vorgang fehl.

Lösung

Entfernen Sie das MRSR-Feature, löschen Sie die nicht analysierte Bibliothek, und installieren Sie dann das MRSR-Feature neu.

Eine Nachricht kann in einem zweistufigen Workflow nicht zurückgeschleifet werden.

Symptom

Wenn Sie eine Nachricht in der Reparaturphase eines Workflows ablehnen, der nur über eine Erstellungs- und eine Reparaturphase verfügt, schlägt die Übermittlung fehl. BizTalk Server leitet die Nachricht zurück an messageBox weiter und gibt die folgende Fehlermeldung aus:

"Auf die erste Phase des Workflows konnte nicht zurückgesetzt werden."

Mögliche Ursache

Das Nachrichtenschleifenback wird für einen Workflow, der nur über eine Erstellungs- und eine Reparaturphase verfügt, nicht unterstützt.

Lösung

Fügen Sie dem zweistufigen Workflow eine weitere Phase hinzu, oder brechen Sie die Übermittlung ab.

Eine Nachricht im Reparatureingang in MRSR kann nicht geöffnet werden.

Symptom

Wenn Sie versuchen, eine Nachricht im Reparatureingang in MRSR zu öffnen, wird die folgende Fehlermeldung in einem Popup angezeigt:

"Die in der Anmeldung 'A4SWIFT' angeforderte Datenbank kann nicht geöffnet werden. Fehler bei der Anmeldung. Fehler bei der Anmeldung für den Benutzer "NT AUTHORITY\NETWORK SERVICE".

Mögliche Ursache

Das Anmeldekonto für die Webanwendung, unter der der A4SWIFT_MRSR Webdienst ausgeführt wird, ist Netzwerkdienst und kein lokales Konto oder Domänenkonto, das sich in der Gruppe A4SWIFT Benutzer befindet.

Lösung

Ändern Sie das Anmeldekonto für die Webanwendung, unter der der A4SWIFT_MRSR Webdienst ausgeführt wird.

So ändern Sie das Anmeldekonto für die Webanwendung, unter der der A4SWIFT_MRSR Webdienst ausgeführt wird
  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Verwaltung, und klicken Sie dann auf Internetinformationsdienste-Manager.

  2. Erweitern Sie im IIS-Manager den <Knoten Servername> (lokaler Computer), den Knoten Anwendungspools und Websites . Erweitern Sie unter dem Knoten Websites den Knoten Standardwebsite .

  3. Klicken Sie unter dem Knoten Standardwebsite mit der rechten Maustaste auf A4SWIFT_MRSR, und klicken Sie dann auf Eigenschaften.

  4. Beachten Sie im Dialogfeld A4SWIFT_MRSR Eigenschaften den Anwendungspool.

  5. Klicken Sie im Dialogfeld IIS-Manager unter dem Knoten Anwendungspools mit der rechten Maustaste auf den Anwendungspool für A4SWIFT_MRSR, und klicken Sie dann auf Eigenschaften.

  6. Klicken Sie im Dialogfeld Eigenschaften des <Anwendungspoolnamens> auf die Identitätsnotiz . Wenn auf Vordefiniert geklickt und Netzwerkdienst ausgewählt ist, klicken Sie auf Konfigurierbar, geben Sie Ihr lokales oder Domänenkonto ein, und geben Sie dann Ihr Kennwort ein. Klicken Sie auf OK.

Eine Nachricht, die auf einem lokalisierten Computer auf einem MRSR-Standort erstellt wurde, wird nicht verarbeitet.

Symptom

Wenn ein Benutzer, der an einer englischen Version von A4SWIFT arbeitet, die auf einer lokalisierten Plattform ausgeführt wird, eine Nachricht in einem InfoPath-Formular in MRSR erstellt und die Nachricht erfolgreich übermittelt, scheint die Nachricht von der Orchestrierung Nachrichtenreparatur und neue Übermittlung verarbeitet zu werden, wird aber nicht erfolgreich verarbeitet. Die Nachricht wird an den Postausgang gesendet, aber nicht vom BizTalk-Adapter abgerufen. Im Ereignisanzeige wird kein Fehler oder eine Warnung veröffentlicht, und es gibt keinen Datensatz einer ausgeführten Orchestrierung instance in HAT.

Mögliche Ursache

Der pfad, der als URI für den STS eingegeben wurde. Der Postausgangsspeicherort enthält den englischen Namen, nicht den lokalisierten Namen.

Lösung

Ändern Sie die URI-Adresse für den STS. Postausgangsspeicherort wie folgt:

  1. Erweitern Sie in der BizTalk Server 2009-Verwaltungskonsole die Knoten BizTalk-Gruppe, Anwendungen und BizTalk-Anwendung 1.

  2. Klicken Sie auf Empfangsspeicherorte.

  3. Doppelklicken Sie auf Sts.Outbox.Location.

  4. Klicken Sie im Dialogfeld Eigenschaften des Empfangsspeicherorts auf Konfigurieren.

  5. Ersetzen Sie im Dialogfeld Transporteigenschaften den Wert für sharePointSite URL durch die lokalisierte Entsprechung.

  6. Klicken Sie auf OK und dann nochmals auf OK.

Das Entfernen einer Rolle während der Verarbeitung einer Nachricht führt zu einer unvollständigen Entfernung von Dokumenten und Artefakten.

Symptom

Wenn Sie eine Rolle im Profilwebclient entfernen, wird ein Dialogfeld bereitgestellt, das angibt, dass alle Dokumente und Artefakte, die der Rolle zugeordnet sind, entfernt werden. Die Rolle wird jedoch nicht aus der Abteilung in der A4SWIFT-Verwaltungskonsole entfernt, und die Dokumentordner der Rolle (Posteingang und Gesendete Elemente) werden nicht aus MRSR entfernt. Partei, Sendeport und Vereinbarung, die der Rolle zugeordnet sind, werden entfernt, und das Profil der Rolle wird nicht bereitgestellt.

Mögliche Ursache

Eine Nachricht befindet sich noch im Posteingang der Rolle in MRSR, und die Nachricht ist im InfoPath-Format geöffnet.

Lösung

Löschen Sie die Nachricht manuell aus dem MRSR-Website-Posteingang, und löschen Sie dann die Dokumentbibliothek, die der Rolle zugeordnet ist, die Sie entfernt haben. Schließen Sie das Formular, und entfernen Sie die Rolle erneut.

Fehler bei der Nachrichtenverarbeitung aufgrund eines Fehlers in der BIC-Masterrichtlinie

Symptom

Wenn Sie eine Nachricht zur Verarbeitung übermitteln, erhalten Sie die folgende Fehlermeldung:

"Fehler beim Ausführen der BicMasterPolicy. Überprüfen Sie die Richtlinie auf gültige Werte."

Mögliche Ursache

Der SQL Server Name, BIC-Datenbankname und integrierter Sicherheitswert in der BIC_Master_Policy.xml-Datei in <Laufwerk>:\Programme\ Microsoft BizTalk Accelerator für SWIFT-Version <> Message Pack\SWIFT Messages\A4SWIFT-SRG<version>\Base Policies sind in doppelten Anführungszeichen enthalten. Um die BIC-Validierung zu aktivieren, geben Sie diese Zeichenfolgen in die Standarddatei BIC_Master_Policy.xml ein, wie unter Aktivieren der Überprüfung von Bankbezeichnercodes beschrieben.

Lösung

Gehen Sie wie folgt vor, um die BIC-master-Richtlinie zu reparieren:

Hinweis

Weitere Informationen zum Bereitstellen der BIC-master-Richtlinie finden Sie unter Bereitstellen von BRE-Regeln.

  1. Heben Sie in Business Rule Composer die Bereitstellung von Version 1.0 der BIC_Master_Policy auf, und löschen Sie dann die BIC_Master_Policy.

  2. Öffnen Sie in einem Text-Editor, z. B. Editor, BIC_Master_Policy.xml in <laufwerk>:\Programme\ Microsoft BizTalk Accelerator for SWIFT <version> Message Pack\SWIFT Messages\A4SWIFT-SRG<version>\Base Policies. Entfernen Sie die doppelten Anführungszeichen um den SQL Server Namen, den BIC-Datenbanknamen und den integrierten Sicherheitswert.

  3. Importieren Sie im Bereitstellungs-Assistenten für Geschäftsregeln-Engine BIC_Master_Policy.xml, und stellen Sie dann BIC_Master_Policy.xml bereit.

  4. Starten Sie im MMC Dienste den Updatedienst der Regel-Engine und den BizTalk-Empfangshostdienst neu.

A4SWIFT kann eine nicht analysierte Nachricht ohne die erforderlichen Datenbankberechtigungen nicht verarbeiten.

Symptom

Wenn Sie eine Nachricht ablegen, die A4SWIFT nicht analysieren kann, kann A4SWIFT die Nachricht nicht verarbeiten, schlägt jedoch mit einer nicht durchgeführten Ausnahme fehl.

Mögliche Ursache

Es liegt ein Datenbankberechtigungsproblem vor. Das Anmeldekonto für den BizTalk-Dienst, der standardmäßig HostSvc ist, ist nicht in den Gruppen A4SWIFT Administratoren und A4SWIFT Benutzer enthalten.

Lösung

Fügen Sie das Anmeldekonto für den BizTalk-Dienst den Gruppen A4SWIFT Administratoren und A4SWIFT Benutzer hinzu.

Ein Timeout des InfoPath-Reparaturformulars kann zu zwei Kopien einer Nachricht in verschiedenen Phasen des Reparaturworkflows führen.

Symptom

Wenn Sie eine Nachricht aus einem InfoPath-Formular (für jede Workflowphase) senden und bei der Übermittlung des Formulars ein Fehler auftritt, kann der Fehler zu zwei Kopien der Nachricht führen. Eine Nachricht befindet sich noch im Posteingang für die aktuellen Phasen, und die andere Nachricht befindet sich im Posteingang für die nächste Rolle im Workflow. Der Versuch, diese Nachrichten zu verarbeiten, führt zu Folgendem:

  • Wenn Sie die Nachricht aus dem Posteingang für die nächste Rolle des Workflows übermitteln, wird die Nachricht durch den Workflow fortgesetzt.

  • Wenn Sie die Nachricht aus dem Posteingang für die aktuelle Phase übermitteln, nachdem die Verarbeitung der aus dem Posteingang der nächsten Phase übermittelten Nachricht abgeschlossen wurde, wird die nachricht, die aus dem aktuellen Posteingang gesendet wurde, mit einem Routingfehler angehalten.

  • Wenn Sie die Nachricht im Posteingang für die aktuelle Phase übermitteln, bevor die Verarbeitung der aus dem Posteingang der nächsten Phase übermittelten Nachricht abgeschlossen wurde, wird die nachricht, die aus dem Posteingang für die aktuelle Phase gesendet wurde, an den Posteingang für diese Phase zurückgegeben, und Sie erhalten die folgende Fehlermeldung: "Zurücksetzen des Workflows aufgrund von: entweder wurde die Nachricht manipuliert, oder der Benutzer ist für diese Phase ungültig." Wenn Sie danach die Nachricht aus dem Posteingang für die nächste Phase übermitteln, wird auch der Workflow dafür zurückgesetzt. Es wird an den Posteingang für die aktuelle Phase zurückgegeben, und Sie erhalten den obigen Fehler.

Mögliche Ursache

Das InfoPath-Formular hat die Nachricht über Microsoft Windows Sharepoint Services und einen benutzerdefinierten Webdienst, der Überprüfungen ausführt, an BizTalk Server übermittelt. Das Übermitteln einer Nachricht erfolgt in mehreren Schritten, und diese Schritte sind nicht transaktional, da Windows Sharepoint Services nicht transaktional ist. Um diese Einschränkung zu berücksichtigen, haben die MRSR-Orchestrierungen eine Wiederherstellungslogik integriert, um Fehler zu erkennen und wiederherzustellen, die bei der Nachrichtenübermittlung auftreten. Die MRSR-Orchestrierungen verhindern immer, dass doppelte Nachrichten an SWIFT gesendet werden.

Lösung

In diesem Fall sollten Sie die Nachricht auswählen, die sich weiter im Workflow befindet, und ihren Workflow abschließen, bevor Sie versuchen, die anderen Nachrichten zu verarbeiten, die sich in den früheren Phasen des Workflows befinden. Nachdem die Verarbeitung der nachricht, die sich weiter im Workflow befindet, abgeschlossen wurde, können Sie die zweite Nachricht (die mit einem Routingfehler angehalten wurde) nach Bedarf löschen.

Wenn die Weiter unten im Workflow enthaltene Nachricht die Verarbeitung nicht abgeschlossen hat, bevor Sie die zweite Nachricht verarbeitet haben, sollten Sie die Nachricht, die sich weiter unten im Workflow im InfoPath-Formular reparatur befindet, erneut reparieren und dann übermitteln. Lassen Sie den Abschluss der Verarbeitung zu, und senden Sie dann die zweite Nachricht. Nachdem die zweite Nachricht angehalten wurde, verwerfen Sie sie.

Eine neue Übermittlung ohne Überprüfungsphase führt zu einer angehaltenen Nachricht.

Symptom

Wenn Sie eine neue Nachricht in einem Workflow senden, der keine Überprüfungsphase aufweist, wird die Nachricht angehalten.

Mögliche Ursache

Das Fehlen einer Überprüfungsphase führt zu einer angehaltenen Meldung, wenn A4SWIFT_MRSRLastStage nicht auf Erstellen festgelegt ist.

Lösung

Verwenden Sie ein Abonnement von A4SWIFT_MRSRLastStage == Create, um sicherzustellen, dass die Nachricht ordnungsgemäß weitergeleitet wird.

Die Überprüfung der Nachricht führt zu einem "Analysefehler" im Aufgabenbereich des InfoPath-Formulars.

Symptom

Die Schaltfläche "Nachricht überprüfen" im Aufgabenbereich des InfoPath-Formulars zeigt "Analysefehler" ohne Beschreibung an.

Lösung

Starten Sie den MRSR-Webdienst neu, oder führen Sie iisreset aus.

Das Veröffentlichen eines InfoPath-Formulars führt zu einem Autorisierungsfehler.

Symptom

Beim Veröffentlichen eines InfoPath-Formulars tritt ein Autorisierungsfehler auf.

Lösung

Ersetzen Sie den Computernamen durch localhost in der MRSR-Website-URL.

InfoPath-Formular-Aufgabenbereich zeigt HTML-Quellcode an

Symptom

Der InfoPath-Formularaufgabenbereich zeigt HTML-Quellcode anstelle von Websteuerelementen an.

Lösung

Wechseln Sie zu Extras-Security>Tab ->Internet Zone, und aktivieren Sie Datei basierend auf Inhalten öffnen, die nicht auf der Erweiterung basieren unter Verschiedenes.

Profilwebclientwebsite führt zu einem Authentifizierungsfehler

Symptom

Profilwebclientwebsite zeigt Authentifizierungsfehler an.

Lösung

Führen Sie btSharePointAdapterWSAppPool und DefaultAppPoolApplication aus,> und führen Sie den Pool in Internetinformationsdienste (IIS) unter dem Administratorkonto aus.

Weitere Informationen

Problembehandlung: Probleme und Lösungen