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Behandlung von Installations- und Konfigurationsproblemen

Setup kann die RuntimeSchemas-Assembly nicht bereitstellen.

Symptom

Das A4SWIFT Setupprogramm konnte RuntimeSchemas.dll nicht bereitstellen. Wenn die Assembly nach dem Setup nicht manuell bereitgestellt wird, schlägt der A4SWIFT-Konfigurations-Assistent fehl.

Mögliche Ursache

Eine der folgenden Bedingungen ist vorhanden:

  • Die RuntimeSchemas-Assembly wurde bereits bereitgestellt, als Sie versucht haben, eine Erstinstallation von A4SWIFT durchzuführen.

  • Microsoft SQL Server wurde auf dem Computer, auf dem Sie versucht haben, A4SWIFT zu installieren, nicht gestartet.

  • Die Runtime Schemas-Assembly wurde bereits bereitgestellt, als Sie versucht haben, A4SWIFT zu aktualisieren, und von einer anderen Assembly referenziert wurde. Dadurch wurde verhindert, dass die Bereitstellung der Runtime Schemas-Assembly durch das A4SWIFT Upgradeprogramm aufgehoben wird.

Lösung

Gehen Sie je nach Art des Problems wie folgt vor:

  • Wenn die Runtime Schemas-Assembly bereits bereitgestellt wurde, als Sie versucht haben, eine Erstinstallation von A4SWIFT auszuführen, öffnen Sie BizTalk Explorer in Microsoft Visual Studio.NET, und klicken Sie mit der rechten Maustaste auf die Assembly Microsoft . Solutions.FinancialServices.SWIFT.RuntimeSchemas, und klicken Sie dann auf Bereitstellung aufheben. Verwenden Sie den BizTalk-Bereitstellungs-Assistenten, um die neueste Version von RuntimeSchemas.dll aus %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Assemblies bereitzustellen.

  • Wenn SQL Server nicht gestartet wurde, starten Sie SQL Server im SQL Server Service Manager. Verwenden Sie den BizTalk-Bereitstellungs-Assistenten, um die neueste Version von RuntimeSchemas.dll aus %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Assemblies bereitzustellen.

  • Wenn die Runtime Schemas-Assembly bereits bereitgestellt wurde, als Sie versucht haben, A4SWIFT zu aktualisieren, und von einer anderen Assembly referenziert wurde, heben Sie die Bereitstellung der verweisenden Assembly in BizTalk Explorer auf, und heben Sie die Bereitstellung RuntimeSchemas.dll in BizTalk Explorer auf. Verwenden Sie den BizTalk-Bereitstellungs-Assistenten, um die neueste Version von RuntimeSchemas.dll aus %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Assemblies bereitzustellen.

Nachdem das Feature "Webkomponenten" entfernt wurde, wird die Nachrichtenreparatur und -abstimmung fälschlicherweise als deinstalliert angezeigt.

Symptom

Nachdem Sie die Webkomponenten für die Nachrichtenreparatur und die neue Übermittlungsfunktion von A4SWIFT entfernt haben, können Sie das Feature "Nachrichtenreparatur und -abstimmung" (oder A4SWIFT-Komponenten) nicht deinstallieren, installieren oder konfigurieren. Wenn die Nachrichtenreparatur und -abstimmung installiert ist, erkennt A4SWIFT nicht, dass das Feature installiert ist. Wenn Sie versuchen, die Nachrichtenreparatur und -abstimmung in "Programme hinzufügen/entfernen" (aus Systemsteuerung angezeigt) zu installieren, zu ändern oder zu entfernen, gibt das Hinzufügen/Entfernen von Programmen an, dass das Feature nicht installiert ist.

Mögliche Ursache

Sie wurden aus der Gruppe BizTalk Server Administratoren entfernt, nachdem Sie die Webkomponenten für die Funktion "Nachrichtenreparatur und neue Übermittlung" und das Feature "Nachrichtenreparatur und -abstimmung" installiert hatten. Wenn Sie dann das Webkomponentenfeature entfernen (das Sie tun können, ohne Mitglied der Gruppe BizTalk Server Administratoren zu sein), entfernt das A4SWIFT Setupprogramm Dateien, von denen das Feature "Nachrichtenreparatur und -abstimmung" abhängig ist. Diese Dateien enthalten ConfigFramework.exe.

Lösung

Wenn dieses Problem auftritt, gehen Sie wie folgt vor:

  1. Fügen Sie sich im Fenster Computerverwaltung wieder der Gruppe BizTalk Server Administrator hinzu, melden Sie sich vom Computer ab, und melden Sie sich dann wieder an.

  2. Installieren Sie das Feature Webkomponenten für die Nachrichtenreparatur und neue Übermittlung erneut.

    Hinweis

    Schritt 2 fügt der A4SWIFT Installation ConfigFramework.exe wieder hinzu.

  3. Installieren Sie das MRSR-Feature erneut.

  4. Wenn Sie die Webkomponenten für die Nachrichtenreparatur und neue Übermittlungsfunktion weiterhin nicht möchten, entfernen Sie es.

Das Reparieren A4SWIFT zum Hinzufügen des Dienstordners kann zu falschen Zugriffsberechtigungen für diesen Ordner führen.

Symptom

Wenn Sie den Ordner %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service aus einer ordnungsgemäß konfigurierten A4SWIFT Installation löschen und dann das Reparaturfeature von A4SWIFT Setup ausführen, um den Serverordner wieder der A4SWIFT-Installation hinzuzufügen, sind die Zugriffsberechtigungen für den Dienstordner nicht richtig. Die richtigen Berechtigungen sind Vollzugriff für A4SWIFT Administratoren und Lesen & Ausführen für A4SWIFT Benutzer.

Dies tritt auch auf, wenn Sie die Reparaturfunktion von A4SWIFT Setup ausführen, wenn der Dienstordner vorhanden ist. Die Zugriffsberechtigungen, die vom A4SWIFT-Konfigurations-Assistenten festgelegt werden, werden mit falschen Werten überschrieben.

Mögliche Ursache

Durch die Installation der Webkomponenten für die Funktion "Nachrichtenreparatur" und "Neue Übermittlung" wird der Ordner "Dienst" hinzugefügt. Wenn Sie den Ordner löschen und dann die Option Reparieren von A4SWIFT Setup ausführen, um die Webkomponenten für die Nachrichtenreparatur und neue Übermittlung hinzuzufügen, führt A4SWIFT Setup nicht den Konfigurations-Assistenten (ConfigFramework.exe) aus, um die Berechtigungen für den Ordner festzulegen. Da der Konfigurations-Assistent bereits ausgeführt wurde, ist es sehr schwierig, den Assistenten erneut auszuführen, um die Konfiguration zurückzusetzen. Infolgedessen erstellt die Option Reparieren alle gelöschten Dateien und Ordner erneut, legt die Zugriffsberechtigungen jedoch nicht ordnungsgemäß fest.

Der Reparaturprozess überschreibt auch Berechtigungen für den Dienstordner, wenn der Ordner vorhanden ist, wenn die Reparatur ausgeführt wird. Wie beim Löschen des Dienstordners vor der Reparatur ist es sehr schwierig, das Konfigurationsprogramm auszuführen, um die Berechtigungen festzulegen. Auch in diesem instance sind die Berechtigungen falsch, und Sie müssen sie manuell festlegen.

Lösung

Wenn dieses Problem auftritt, legen Sie die folgenden Zugriffsberechtigungen für den Ordner Dienst manuell fest:

Gruppen- oder Benutzername Berechtigung
A4SWIFT-Administratoren Vollzugriff
A4SWIFT Benutzer Lesen und Ausführen

Gehen Sie wie folgt vor, um diese Berechtigungen festzulegen:

Wechseln Sie in Windows Explorer zu %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service.

  1. Klicken Sie mit der rechten Maustaste auf den Ordner Dienst, klicken Sie auf Eigenschaften, und klicken Sie dann auf die Registerkarte Sicherheit .

  2. Klicken Sie im Bereich Gruppen- oder Benutzernamen des Dialogfelds Diensteigenschaften auf Hinzufügen, geben Sie <Servername>\A4SWIFT Administratoren ein, und klicken Sie dann auf OK.

    Hinweis

    Wenn die Gruppe A4SWIFT Administratoren eine Domänengruppe ist, geben Sie <Domänenname>\A4SWIFT Administratoren ein.

  3. Wiederholen Sie Schritt 2 für <Servername>\A4SWIFT Benutzer oder <Domänenname>\A4SWIFT Benutzer , wenn die Gruppe A4SWIFT Benutzer eine Domänengruppe ist.

  4. Wählen Sie im Bereich Gruppen- oder Benutzernamen die Option A4SWIFT Administratoren aus. Wählen Sie im Bereich Berechtigungen die Option Vollzugriffzulassen aus.

  5. Wählen Sie im Bereich Gruppen- oder Benutzernamen die Option A4SWIFT Benutzer aus. Klicken Sie im Bereich Berechtigungen auf Lesen zulassen & Ausführen, Ordnerinhalt auflisten und Lesen.

  6. Klicken Sie auf OK.

Das Upgrade führt zu einer parallelen Installation von zwei Versionen von A4SWIFT

Symptom

Wenn Sie versuchen, ein Upgrade auf A4SWIFT durchzuführen, werden frühere Versionen von A4SWIFT möglicherweise nicht vollständig entfernt. Wenn Sie "Programme hinzufügen/entfernen" aus dem Systemsteuerung ausführen, werden in der Liste derzeit installierte Programme möglicherweise die aktuellen und die vorherigen Versionen angezeigt.

Mögliche Ursache

Eine der folgenden Bedingungen kann dazu führen, dass die obigen Bedingungen auftreten:

  • Der Benutzer, der ein Upgrade versucht, ist kein Mitglied der Gruppe BizTalk Server Administratoren.

  • Der SQL Server-Dienst (MSSQLSERVER) wird beendet.

  • Sie haben ein unbeaufsichtigtes Upgrade mithilfe des Befehlssetup.exe /addlocal durchgeführt.

Lösung

Um eine parallele Installation von A4SWIFT 2.1 und A4SWIFT 3.0 während des Upgrades zu verhindern, stellen Sie sicher, dass Sie (der angemeldete Benutzer) Mitglied der Gruppe BizTalk Server Administratoren sind und dass der SQL Server-Dienst (MSSQLSERVER) gestartet wird.

Wenn Sie am Ende eine parallele Installation von A4SWIFT 2.1 oder A4SWIFT 2.3 und A4SWIFT 3.0 durchführen, gehen Sie wie folgt vor:

  1. Sichern Sie die Daten im Ordner SWIFT Messages.

  2. Melden Sie sich beim BizTalk Server als Mitglied der Gruppe BTS-Administratoren an, und stellen Sie sicher, dass der MSSQLSERVER-Dienst ausgeführt wird.

  3. Entfernen Sie die vorherige Version von A4SWIFT.

  4. Aktualisieren Sie erneut auf die neueste Version von A4SWIFT. Dieses Mal funktioniert das Upgrade, und es wird keine parallele Installation erstellt.

  5. Heben Sie mithilfe des BizTalk-Bereitstellungsprogramms die Bereitstellung von Microsoft .Solutions.FinancialServices.SWIFT.RuntimeSchemas.dll manuell auf, und stellen Sie sie dann im Ordner Assemblys Ihres A4SWIFT Installationsspeicherorts erneut bereit. Weitere Informationen zu diesem Tool finden Sie unter BRE-Bereitstellungsprogramm.

Der Deinstallations- oder Upgradevorgang wird möglicherweise nicht ordnungsgemäß abgeschlossen, wenn Sie nicht neu starten, wenn Sie dazu aufgefordert werden.

Symptom

Deinstallations- oder Upgradeprozesse werden nicht ordnungsgemäß abgeschlossen.

Mögliche Ursache

Wenn Sie ein Projekt, das auf eine vorhandene bereitgestellte Assembly verweist, nicht bereitgestellt haben, nicht aufgehoben haben, erhalten Sie möglicherweise eine Aufforderung, das System neu zu starten, damit A4SWIFT Konfigurationsänderungen wirksam werden. Wenn Sie nicht auf Ja klicken, um sofort neu zu starten, werden einige Assemblys, die zum Entfernen im globalen Assemblycache zugewiesen wurden, möglicherweise nicht entfernt, sodass zusätzliche Deinstallations- oder Upgradeprozesse nicht ordnungsgemäß abgeschlossen werden.

Lösung

Heben Sie die Bereitstellung eines Projekts auf, das auf eine vorhandene bereitgestellte Assembly verweist, und führen Sie dann den Deinstallations- oder Upgradevorgang erneut aus.

Wenn der IIS-Admin-Dienst während des Setups beendet wird, müssen Sie das WebService-Feature neu konfigurieren.

Symptom

Der A4SWIFT-Konfigurations-Assistent konfiguriert das WebService-Feature nicht ordnungsgemäß. Sie erhalten die folgende Fehlermeldung:

"MRSR-Artefakte können nicht erstellt werden: Es kann keine Verbindung mit dem Remoteserver hergestellt werden."

Mögliche Ursache

Der IIS-Admin-Dienst wurde beendet, als Sie den A4SWIFT-Konfigurations-Assistenten ausgeführt haben.

Lösung

Gehen Sie wie folgt vor, um den Konfigurationsprozess erfolgreich abzuschließen:

  1. Schließen Sie die A4SWIFT-Konfigurationskonsole.

  2. Starten Sie den IIS-Admin-Dienst neu.

  3. Führen Sie %programfiles%\Microsoft BizTalk Accelerator für SWIFT\Configuration.exe aus.

  4. Wählen Sie in der A4SWIFT Konfigurationskonsole die Option Features unkonfigurieren und dann WebService aus.

  5. Stellen Sie sicher, dass die status des WebService-Features in der Konfigurationskonsole als nicht konfiguriert angezeigt wird.

  6. Wählen Sie Konfiguration anwenden aus.

    Hinweis

    Der A4SWIFT-Konfigurations-Assistent konfiguriert nun das WebService-Feature ordnungsgemäß.

A4SWIFT Konfiguration schlägt fehl, wenn der BizTalkServerApplication-Host nicht in BizTalk Server Konfiguration erstellt wurde.

Symptom

Der A4SWIFT-Konfigurations-Assistent konfiguriert das WebService-Feature nicht ordnungsgemäß. Sie erhalten die folgende Fehlermeldung:

"MRSR-Artefakte können nicht erstellt werden: Der Objektverweis ist nicht auf eine instance eines Objekts festgelegt."

Mögliche Ursache

Ein In-Process Host und eine Hostinstanz wurden während BizTalk Server Runtime-Konfiguration nicht erstellt.

Lösung

Gehen Sie wie folgt vor, um die A4SWIFT Konfiguration zu reparieren:

  • Erstellen Sie einen Host in BizTalk Server Administration. Es ist jetzt nicht erforderlich, eine ausgeführte instance zu haben.

  • Führen Sie das RepairBAS-Tool im Ordner %programfiles%\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools der A4SWIFT Installation aus.

    Gehen Sie hierzu wie folgt vor:

  1. Starten Sie BizTalk Server Verwaltungskonsole.

  2. Erweitern Sie in der BizTalk Server Verwaltungskonsole BizTalk Server Verwaltung, dann BizTalk-Gruppe und dann Plattformeinstellungen.

  3. Klicken Sie mit der rechten Maustaste auf Hosts, zeigen Sie auf Neu, und wählen Sie dann Host aus.

  4. Geben Sie im Bildschirm Hosteigenschaften im Bereich Allgemein Folgendes ein:

    • Hostname: BizTalkServerApplication

    • Typ: Prozessintern

    • Windows-Gruppe: <Domäne>\BizTalk-Anwendungsbenutzer (oder das Konto, das Sie während BizTalk Server Konfiguration für die Ausführung von BizTalk In-Process-Anwendungen eingerichtet haben)

    • Wählen Sie im Abschnitt Optionen die Option Hostnachverfolgung zulassen und Dies als Standardhost in der Gruppe festlegen aus.

  5. Klicken Sie auf OK.

  6. Klicken Sie auf Start und dann auf Ausführen. Geben Sie cmd ein, und klicken Sie dann auf OK.

  7. Navigieren Sie an der Eingabeaufforderung zu %programfiles%\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools.

  8. Geben Sie RepairBAS.exe ein, und drücken Sie dann die EINGABETASTE.

Sie müssen die KONFIGURATIONSdatei für die BRE-Bereitstellung ändern, wenn Sie das BRE-Bereitstellungshilfsprogramm auf einem 64-Bit-Computer ausführen.

Symptom

Das BRE-Bereitstellungsprogramm funktioniert nicht ordnungsgemäß, wenn Sie es auf einem 64-Bit-Computer oder in einem nicht standardmäßigen Verzeichnis (außer C:\Programme\Microsoft BizTalk Accelerator for SWIFT) auf einem 32-Bit-Computer ausführen.

Mögliche Ursache

Das BRE-Bereitstellungshilfsprogramm funktioniert erst ordnungsgemäß, wenn Sie die Pfade in der BREDeployment.exe.config Datei ändern, die <sich im Ordner Laufwerk>:\Programme\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools befindet.

Lösung

Aktualisieren Sie die Konfiguration des Hilfsprogramms, indem Sie BREDeployment.exe.config in Editor öffnen und die Ordner für die Basisrichtlinien, Schemas und Vokabelverzeichnisse ändern.

Weitere Informationen

Problembehandlung: Probleme und Lösungen