Problembehandlung bei FabricInternalServerError oder ServiceAllocationFailure beim Bereitstellen eines Clouddiensts (klassisch) in Azure
Wichtig
Cloud Services (klassisch) ist jetzt ab dem 1. September 2024 für alle Kunden veraltet. Alle vorhandenen ausgeführten Bereitstellungen werden beendet und von Microsoft heruntergefahren, und die Daten sind ab Oktober 2024 dauerhaft verloren. In neuen Bereitstellungen sollte das neue auf Azure Resource Manager basierende Bereitstellungsmodell für Azure Cloud Services (erweiterter Support) verwendet werden.
In diesem Artikel behandeln Sie Zuordnungsfehler, bei denen eine Zuordnung durch den Fabric Controller nicht möglich ist, wenn Sie einen Azure-Clouddienst (klassisch) bereitstellen.
Wenn Sie Instanzen für einen Clouddienst bereitstellen oder neue Instanzen von Web- oder Workerrollen hinzufügen, weist Microsoft Azure Compute-Ressourcen zu.
Unter Umständen erhalten Sie bei diesen Vorgängen auch dann gelegentlich Fehlermeldungen, wenn Sie die Grenzwerte des Azure-Abonnements noch nicht erreicht haben.
Tipp
Diese Informationen können auch hilfreich sein, wenn Sie die Bereitstellung Ihrer Dienste planen.
Symptom
Navigieren Sie im Azure-Portal zu Ihrem Clouddienst (klassisch), und klicken Sie in der Randleiste auf Vorgangsprotokolle (klassisch) , um die Protokolle anzuzeigen.
Wenn Sie die Protokolle Ihres Clouddienstes (klassisch) überprüfen, sehen Sie die folgende Ausnahme:
Ausnahme | Fehlermeldung |
---|---|
FabricInternalServerError | Fehler beim Vorgang. Fehlercode „InternalError“ und errorMessage „Interner Serverfehler. Versuchen Sie die Anfrage noch einmal.“ |
ServiceAllocationFailure | Fehler beim Vorgang. Fehlercode „InternalError“ und errorMessage „Interner Serverfehler. Versuchen Sie die Anfrage noch einmal.“ |
Ursache
FabricInternalServerError und ServiceAllocationFailure sind Ausnahmen, die auftreten können, wenn der Fabric Controller keine Instanzen im Cluster zuordnen kann. Die Ursache hängt davon ab, ob der Clouddienst angeheftet oder nicht angeheftet ist.
- Nicht angeheftet: Fehler bei der ersten Bereitstellung eines neuen Clouddiensts
- Angeheftet: Fehler bei vorhandenen Clouddiensten
Hinweis
Wenn die erste Instanz in einem Clouddienst bereitgestellt wird (entweder beim Staging oder in der Produktion), wird der Clouddienst an einen Cluster angeheftet.
Im Laufe der Zeit können die Ressourcen in diesem Ressourcenpool vollständig ausgelastet werden. Wenn ein Clouddienst eine Zuordnungsanforderung für zusätzliche Ressourcen sendet, wenn die Ressourcen im angehefteten Ressourcenpool unzureichend sind, führt die Anforderung zu einem Zuordnungsfehler.
Lösung
Befolgen Sie die Anleitungen zur Behandlung von Zuordnungsfehlern in den folgenden Szenarien.
Nicht an einen Cluster angeheftet
Wenn Sie einen Clouddienst (klassisch) zum ersten Mal bereitstellen, wurde der Cluster noch nicht ausgewählt, sodass der Clouddienst nicht angeheftet ist. Bei Azure kann aus folgenden Gründen ein Bereitstellungsfehler auftreten:
- Sie haben eine bestimmte Größe ausgewählt, die in der Region nicht verfügbar ist.
- Die Kombination der Größen, die in verschiedenen Rollen benötigt werden, ist in der Region nicht verfügbar.
Wenn in diesem Szenario ein Zuordnungsfehler auftritt, sollten Sie die verfügbaren Größen in der Region überprüfen und die von Ihnen zuvor angegebene Größe ändern.
Sie können auf der Seite Verfügbare Produkte nach Region überprüfen, welche Größen in einer Region verfügbar sind.
Hinweis
Die verfügbare Kapazität wird auf der Seite Produkte nicht angezeigt. Für jede neue Zuordnung sollte Azure in der Lage sein, den zu diesem Zeitpunkt optimalen Cluster in Ihrer Region auszuwählen.
Aktualisieren Sie die Dienstdefinitionsdatei für Ihren Clouddienst (klassisch), um eine andere Produktgröße in Ihrer Region anzugeben.
An einen Cluster angeheftet
Vorhandene Clouddienste werden an einen Cluster angeheftet. Alle weiteren Bereitstellungen für den Clouddienst (klassisch) erfolgen im gleichen Cluster.
Wenn in diesem Szenario ein Zuteilungsfehler auftritt, wird empfohlen, einen neuen Clouddienst (klassisch) bereitzustellen (und den CNAME-Eintrag zu aktualisieren).
Tipp
Diese Lösung ist wahrscheinlich am erfolgreichsten, da die Plattform hierbei eine Auswahl aus allen Clustern in dieser Region treffen kann.
Hinweis
Bei dieser Lösung sollten keine Ausfallzeiten entstehen.
Stellen Sie die Workload in einem neuen Clouddienst (klassisch) bereit.
- Weitere Hinweise finden Sie im Leitfaden Erstellen und Bereitstellen eines Clouddiensts (klassisch).
Warnung
Wenn Sie die mit diesem Bereitstellungsslot verknüpfte IP-Adresse nicht verlieren möchten, können Sie Lösung 3 – Beibehalten der IP-Adresse verwenden.
Aktualisieren Sie den CNAME- oder A-Eintrag, um den Datenverkehr an den neuen Clouddienst (klassisch) umzuleiten.
- Weitere Anleitungen finden Sie im Leitfaden Konfigurieren eines benutzerdefinierten Domänennamens für einen Azure-Clouddienst (klassisch).
Wenn kein Datenverkehr mehr an die alte Website geleitet wird, können Sie den alten Clouddienst (klassisch) löschen.
- Weitere Anleitungen finden Sie im Leitfaden Löschen von Bereitstellungen und eines Clouddiensts (klassisch).
- Informationen zum Netzwerkdatenverkehr in Ihrem Clouddienst (klassisch) finden Sie unter Einführung in die Überwachung von Clouddiensten (klassisch).
Weitere Wartungsschritte finden Sie unter Problembehandlung von Zuteilungsfehlern in Clouddiensten (klassisch) | Microsoft-Dokumentation.
Nächste Schritte
Weitere Informationen zu Zuteilungsfehlern und Hintergrundinformationen:
Wenn Ihr Azure-Problem in diesem Artikel nicht adressiert wird, besuchen Sie die Azure-Foren im MSDN (Microsoft Developer Network) und Stack Overflow. Sie können Ihr Problem in diesen Foren oder an @AzureSupport auf X posten. Sie können auch eine Azure-Supportanfrage senden. Wenn Sie eine Supportanfrage senden möchten, wählen Sie auf der Azure-Support-Seite die Option Support erhalten aus.